LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 04-05-2006, 10:03 AM   #1
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Rep: Reputation: 15
pae


please somebody help me to enable the pae cpu option, how to?
i need it for vmware my cpu sony vaio vgn-u70p 1ghz pentium m as much as i know i should have it, i mean the pae option in the cpu.

Code:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 9
model name      : Intel(R) Pentium(R) M processor 1000MHz
stepping        : 5
cpu MHz         : 595.600
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips        : 1192.25
 
Old 04-06-2006, 04:54 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
The pae flag is not set in your config ... you may be able to turn it on via the kernel line in grub (enable-pae) - otherwise you will have to recompile the kernel.

Usually this will be autodetected when you install and switched on if it should be there. Is, for eg, for my 2.2GHz Celeron.
 
Old 04-06-2006, 12:07 PM   #3
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Original Poster
Rep: Reputation: 15
thank you very much for the reply, unfotunately it didnt help, seems like i have to recompile, but how is the option called in the kernel config menu, i cant find it, i have the following kernel version "2.6.13-15.8"
on suse linux 10
thank you in advance
 
Old 04-06-2006, 11:19 PM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
in xconfig - processor type > high memory > 4Gb.
 
Old 04-07-2006, 01:38 AM   #5
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Original Poster
Rep: Reputation: 15
i tried but it still doesnt show up in cpuinfo under proc.
and vmware is still requesting pae, i did enale pae in the vmware virtual machine to. but it has no effect, and im sure ihave the option, because when i try to boot from the same cd/dvd natively, it works.

ps.: thank you for your help, and thanks in advance
 
Old 04-07-2006, 08:26 PM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
What exactly did you do?

when you go to you kernel source directory, you types "make xconfig" then looked through the menue until you found "processor type" et al ... you saw the check boxes for "off", "4GB", and "64GB".

Was the 4GB box already checked? With a dot or a tick?

Then you compiled the kernel? How? What commands did you issue?

Then you rebooted into the newly compiled kernel?

Then you idd cat /proc/cpuinfo ?
 
Old 04-08-2006, 02:20 AM   #7
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Original Poster
Rep: Reputation: 15
there was a dot

and cpuinfo gives

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 9
model name : Intel(R) Pentium(R) M processor 1000MHz
stepping : 5
cpu MHz : 595.610
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe est tm2
bogomips : 1193.87


i compiled the kernel with

make && make modules_install

and after that restart

Last edited by shadowsa; 04-08-2006 at 02:25 AM.
 
Old 04-09-2006, 02:15 AM   #8
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Original Poster
Rep: Reputation: 15
anything? any idea?
 
Old 04-09-2006, 07:32 PM   #9
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
was the 4Mb box already checked?

make sure you are booting into the correct kernel with the grub menue.

did you try to enable pae on the grub kernel line?

The thing is - the kernel should be detecting the cpu capability here and then just sticking in the things the cpu can do. The high mem stuff should also come in automatically if you have more than 4Mb.

If all else fails, you could try recompiling with the 4Mb module compiled right into the kernel instead of just as a loadable module. Then it is definately there, and we can eliminate it from consideration.
 
Old 07-03-2006, 05:41 PM   #10
angramainyu
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
pae

I solved the problem this way:

Go to your vmware directory in your user directory
like /home/user/vmware/

cd to the directory of guest OS.. There you should find a file like Windows XP Home Edition.vmx file

edit it with a text editor and look for the line: paevm =

if it is present, then make sure is is paevm = "TRUE"

there was not such a line in my .vmw file but I added it at the bottom of file and it works fine now.
 
Old 04-16-2007, 12:03 PM   #11
shadowsa
Member
 
Registered: Jul 2005
Posts: 149

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by angramainyu
I solved the problem this way:

Go to your vmware directory in your user directory
like /home/user/vmware/

cd to the directory of guest OS.. There you should find a file like Windows XP Home Edition.vmx file

edit it with a text editor and look for the line: paevm =

if it is present, then make sure is is paevm = "TRUE"

there was not such a line in my .vmw file but I added it at the bottom of file and it works fine now.
hrmm seems not to work with osx86
anybody any idea?
 
Old 04-17-2007, 02:11 AM   #12
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 30
Hi,

Unfortunately, it seems that pae isn't supported in early generations of the pentium-m processor.

from http://www.gossamer-threads.com/list.../kernel/699332

Quote:
which CPU do you have? Not all laptop processors support PAE at all...
(for example the pentiumM generations before NX was added)

check /proc/cpuinfo the flags line to see if "pae" is there
For instance, here is my pentium-m info:

Quote:
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor
1.10GHz
stepping : 8
cpu MHz : 1100.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8
apic sep mtrr pge mca cmov pat clflush dts acpi mmx
fxsr sse sse2 ss tm pbe est tm2
bogomips : 2195.19
clflush size : 64
It my have something to do with my higher model number.

Hate to break the bad news, but your cpu may not support it at all.

As a last resort, try compiling the kernel with pentium-m selected in the xconfig's "processor type and features" and disable the "generic x86" just below it.

Sam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pae option? shadowsa Suse/Novell 0 04-03-2006 01:18 PM
How do I open ports on my generic conexant PRI PAE CE84 router scarymary Linux - Newbie 1 04-29-2005 01:14 PM
ACPI: s3/pae do not like each other.. s0me0ne Linux - Software 0 05-23-2004 03:04 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration