LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-02-2004, 07:39 AM   #1
OvaClocka
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Question OSS-emulation doesn't work on nforce soundstorm


Hello!

I have Gentoo 2004.0 with Kernel 2.6.4 running.
The problem is, that I can't get the OSS Emulation to work, neither on the analogue out nor on the spdif out.
I want to use the S/PDIF out.

snd-pcm-oss won't load properly when I have the line
"alias snd-pcm-oss dsp_map=2 adsp_map=2" in my /etc/modules.d/alsa.

When I'm removing that line, the module loads properly and oss seems to be available, but I can't hear anything, neither on the analogue out nor on the s/pdif out.

Any application that uses Alsa works fine and sound works.

Please help me, I couldn't find a solution to this on google
And the Alsa docs didn't help me, too.

Greetings

-Max
 
Old 06-02-2004, 08:14 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Hmmmm...so did you unmute and up the levels using alsamixer?


Håkan
 
Old 09-10-2006, 10:46 AM   #3
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
same problem for me here with nforce mcp51 hda audio controller from nvidia (using module sound_intel_hda). aplay and ogg123 etc. work without problems, but any oss applications, even "play" do not. They can play 48000 Hz signed stereo wave files, but no other wave files (e.g. mono 8KHz)

any hints?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 01:37 PM
Oss emulation SquidProject Linux - Software 2 05-24-2005 03:11 PM
OSS emulation SquidProject Linux - Hardware 2 05-14-2005 10:08 PM
ALSA and OSS emulation crud Slackware 6 01-30-2005 04:48 PM
Soundstorm (nForce 2) + Alsa Anzxio Linux - Hardware 0 02-08-2004 06:25 PM


All times are GMT -5. The time now is 01:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration