LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-19-2008, 06:55 AM   #1
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Rep: Reputation: 18
OpenSuSE11 - ATi proprietary driver - refresh rate won't stick


I am using OpenSuSE11 and installed the ATi proprietary driver via the OpenSuSE repositories. I now have to control my graphics card settings via the ATi Catalyst Control Centre, as opposed to YaST. It reports my monitor as having a max refresh rate of 60Hz, yet keeps setting its actual refresh rate to 75Hz. 75Hz looks OK until I try to view anything with mid-shades of grey, like this forum - then the screen flickers and jumps all over the place. I can manually set the refresh rate back to 60Hz which works fine, but then every time I reboot it reverts back to 75Hz.

Is there a file I can edit manually to stop this?

Any help much appreciated.
 
Old 07-21-2008, 02:45 PM   #2
OldBob1
LQ Newbie
 
Registered: Jun 2008
Posts: 8

Rep: Reputation: 0
--New driver at ATI.com (came out today) - Give that a try.
 
Old 09-22-2008, 02:17 AM   #3
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
I have updated a couple of times now the problem persists. Currently I'm using x11-video-fglrxG01 version 8.522-2.1.

I have fed this problem back to ATi, but in the meantime does anyone know of a workaround? Although my monitor displays 75Hz, it seems to have trouble with certain colours (specifically greens and greys) where the whole screen flickers and jumps depending on how much of that colour is being displayed. Reducing the refresh rate to 60Hz prevents this, but I'm sick of having to set it manually every time I boot up.

Interestingly, in Windows XP the flickering is also seen until I install the monitor driver, then it's fine. There are no linux drivers available from Viewsonic, although I have emailed them to request they develop them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ati-drivers/fglrx refresh rate problem andymadigan Linux - Hardware 1 03-02-2006 03:37 PM
none of the changes i make to my monitor refresh rate in the control centre stick Michael_aust Mandriva 3 01-24-2006 04:46 PM
display driver - refresh rate TranceDude Fedora 16 08-16-2005 07:52 AM
Can I set the refresh rate without using official driver? hyapadi Linux - Hardware 1 04-07-2005 08:15 AM
IMPOSSIBLE to set vert. refresh rate with ati drivers hdagelic Linux - General 0 03-17-2004 03:57 PM


All times are GMT -5. The time now is 07:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration