LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-04-2006, 10:09 AM   #1
grooveharder
LQ Newbie
 
Registered: Jul 2005
Distribution: Gentoo
Posts: 23

Rep: Reputation: 15
OpenGL apps produce black screen on ATI X1300 using binary drivers


hello all,

i'm a bit confused as to why whenever i run glxgears, fgl_glxgears or any other opengl app, all i get is a window where the image would normally be, filled entirely with black. glxinfo etc reports that i'm using direct rendering, and all the vendor strings say "ATI". i'm using kernel 2.6.18.1 and xorg 6.9.0 on slackware 11.

any ideas would be greatly appreciated.
 
Old 11-08-2006, 05:59 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
I had the exact same problem on FC3 under the 2.6.14.3 kernel. I've got a Nvidia based GFX card though. My problem was that I needed certain permissions set in the /dev folder to get OpenGL to work at all. These /dev nodes were

/dev/nvidia0
/dev/nvidia1
.
.
.
up to /dev/nvidia7

and then a /dev node called

nvidiactl had to be set to

a+rw

before any OpenGL app would work. I don't know what you'll need to change (since you have an ATI based card) - maybe /dev/ati0 and its associated /dev nodes???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen when trying to install ATI drivers on Radeon x1600 vangelis Linux - Hardware 6 03-25-2008 12:18 AM
X800 with ATI drivers: Black screen, and XFree86 uses 99% CPU GeirG Linux - Hardware 6 06-23-2005 04:24 PM
hard lockups when using opengl apps on ATI radeon 9600 schatoor Linux - Hardware 2 03-12-2005 12:47 PM
Radeon 9200se w/ATI drivers - black screen! MarasW Linux - Hardware 7 05-17-2004 11:49 AM
ATI binary drivers and Kernel 2.6: BLANK SCREEN FIX adamjaskie Linux - Hardware 0 02-08-2004 11:13 PM


All times are GMT -5. The time now is 05:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration