LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-25-2009, 10:03 AM   #1
cfp
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Rep: Reputation: Disabled
Post [DONE] On (x)Ubuntu 9.04, usb hard drive isn't listed in /dev/sd*, yet seen by lsusb.


Hello world :)

Summary : On my (x)ubuntu installation, on an external hard drive, other usb hard drives do not appear in /dev, although they appear in lsusb output, and can't be mounted. It seems to be a problem with the order in which devices are listed.

Details : I'm using XUbuntu 9.04, which I just installed (I was running ubuntu and I had the same problem). The system is installed on an external usb hard drive. When I connected my music player (Toshiba Giabeat F), it was first detected and auto-mounted, but then disappeared. It does not appear in /dev, and yet lsusb can find it. On ubuntu, if the system drive was plugged in the front usb plugs and my player in the back, the system would crash (the system drived was remounted to another location).
The drive is clean and works without problems in windows.

Additional info :
lsusb, player unplugged (underlined : system drive) :
Code:
Bus 001 Device 004: ID 1058:0701 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04fc:0003 Sunplus Technology Co., Ltd CM1092 Optical Scroller Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 056a:0015 Wacom Co., Ltd 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
lsusb, player plugged (the system drive is second) :
Code:
Bus 001 Device 012: ID 0930:0009 Toshiba Corp. Gigabeat F/X (HDD audio player)
Bus 001 Device 004: ID 1058:0701 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04fc:0003 Sunplus Technology Co., Ltd CM1092 Optical Scroller Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 056a:0015 Wacom Co., Ltd 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
fdisk -l
Code:
Disque /dev/sda: 160.0 Go, 160000000000 octets
255 têtes, 63 secteurs/piste, 19452 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xe335e335

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *           1       19451   156240126    7  HPFS/NTFS

Disque /dev/sdb: 250.0 Go, 250059350016 octets
255 têtes, 63 secteurs/piste, 30401 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x0b3ae5b2

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1               1       30401   244196001    7  HPFS/NTFS

Disque /dev/sdc: 80.0 Go, 80026361856 octets
255 têtes, 63 secteurs/piste, 9729 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xddb2a95f

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1               1        9698    77899153+   5  Etendue
/dev/sdc4            9699        9729      249007+  82  Linux swap / Solaris
/dev/sdc5               1        2432    19534977   83  Linux
/dev/sdc6            2433        6079    29294496   83  Linux
/dev/sdc7            6080        9698    29069586    b  W95 FAT32

dmesg (some errors on first plug (when the drive was auto-mounted) :
Code:
[  320.950693] FAT: Directory bread(block 53327730) failed
(...)
[  320.950850] FAT: Directory bread(block 53327749) failed
(...)
[  320.951047] FAT: Directory bread(block 53327773) failed
[  356.880015] usb 1-3: new high speed USB device using ehci_hcd and address 6
[  357.013032] usb 1-3: configuration #1 chosen from 1 choice
[  357.080375] scsi8 : SCSI emulation for USB Mass Storage devices
[  357.084445] usb-storage: device found at 6
[  357.084448] usb-storage: waiting for device to settle before scanning
[  540.458430] usb 1-3: USB disconnect, address 6
[  540.568016] usb 1-8: reset high speed USB device using ehci_hcd and address 4
[  558.524015] usb 1-1: new high speed USB device using ehci_hcd and address 7
[  558.692319] usb 1-1: configuration #1 chosen from 1 choice
[  558.732056] scsi9 : SCSI emulation for USB Mass Storage devices
[  558.732323] usb-storage: device found at 7
[  558.732326] usb-storage: waiting for device to settle before scanning
[  752.242930] usb 1-1: USB disconnect, address 7
(...)
[18793.100017] usb 1-7: new high speed USB device using ehci_hcd and address 12
[18793.272039] usb 1-7: configuration #1 chosen from 1 choice
[18793.316035] scsi14 : SCSI emulation for USB Mass Storage devices
[18793.316311] usb-storage: device found at 12
[18793.316313] usb-storage: waiting for device to settle before scanning
I do wish someone could help me. Thanks for reading all this anyway :)
CFP.

Last edited by cfp; 07-28-2009 at 04:11 PM. Reason: [RESOLVED]
 
Old 07-28-2009, 04:10 PM   #2
cfp
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Original Poster
Rep: Reputation: Disabled
Bug fixed

The problem is related to a bug in libgphoto, using MTP. Some devices are detected as audio players and yet accessed through MTP, even if the don't support this protocol. The solution is to be found here : https://bugs.launchpad.net/ubuntu/+s...ux/+bug/355998 .
CFP.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB problems on ubuntu 7.04 wifi not in lsusb hydroscrog Linux - Hardware 4 12-30-2007 07:43 PM
usb hdd not found in /dev or with lsusb /y0shi Slackware 7 12-19-2007 04:41 PM
ubuntu partitioning tool does not see external usb hard drive when installing ubuntu fakie_flip Linux - Software 2 07-30-2006 12:44 AM
USB Hard drive in Ubuntu NeoChaosX Linux - Hardware 1 06-26-2005 11:37 AM
USB hard drive rejects dev number mad2physicist Linux - Hardware 16 12-15-2003 12:11 PM


All times are GMT -5. The time now is 11:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration