LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Old-styled mouse not recognized by the GUI. (http://www.linuxquestions.org/questions/linux-hardware-18/old-styled-mouse-not-recognized-by-the-gui-799515/)

stf92 04-02-2010 12:44 AM

Old-styled mouse not recognized by the GUI.
 
GNU/Linux kernel 2.6
Slackware 12.0
KDE 3.5.7

Hi:
In my machine and in its rear panel there is a DB9 male connector, it being
the only DB9 connector anywhere in the machine. My mouse is pluged into that
connector (old-styled mouse; newer mice end in a mini din conector
(PS/2 mice)).

Up to here the conditions. The problem is when I boot certain non-linux
operating systems on this machine the o.s. is aware of the mouse but,
if linux is the o.s. running, it is the same as if the mouse does not
exist (assuming I am in the GUI). What can probably be the cause? Thanks
for reading and regards.

P.S.: maybe the configuration file for the X server is where I should
look at. I regret not being able to specify who is the graphics server
(something like XFree86?).

paulsm4 04-02-2010 01:11 AM

Hi -

Yes, you are correct: even if the "auto-configure" tool doesn't recognize a serial mouse, you can always configure it manually. Look here:

Quote:

https://help.ubuntu.com/community/SerialMouseHowto

vi /etc/X11/xorg.conf

navigate down to
Quote:

Navigate (using the arrow and/or Page Up/Down keys) to the following section: (all lines may not be present)

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection
Change the Change the "Option Device" and "Option Protocol" lines as follows:
Quote:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/ttyS0"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
EndSection

'Hope that helps .. PSM

stf92 04-02-2010 03:45 AM

Hi:

It helped, indeed. Most grateful, PSM, for your reply. Enrique.


All times are GMT -5. The time now is 07:49 PM.