LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   nVidia udev nodes in gentoo (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-udev-nodes-in-gentoo-413119/)

superkav 02-08-2006 03:00 PM

nVidia udev nodes in gentoo
 
Hello, All,

Udev is not creating the proper device nodes for my nVidia card in Gentoo. On top of this, when I manually create the nodes with "mknod" (the /sbin/NVdevices script is not on my system), it is to no avail (I've seen other threads where this is the solution). With the manually created nodes, sometimes I'll get the nVidia splash followed by a total meltdown --> hard reset. Other times my screen will just go blank --> hard reset.

I'm using:
kernel: 2.6.15-gentoo-r1 (with MTTR support & module loading)
udev: udev-084
nvidia-kernel: 1.0.8178-r3]
nvidia-glx: 1.0.8178

lsmod | grep nv:
nvidia 4084304 0
agpgart 28872 2 via_agp,nvidia

lspci | grep NV:
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

I am by no means a linux expert. Any help would be greatly appreciated.

Thanks.

comprookie2000 02-08-2006 06:50 PM

Look at /etc/conf.d/rc
Code:

cat /etc/conf.d/rc
Do you have this;
Code:

RC_FORCE_AUTO="no"

# Use this variable to control the /dev management behavior.
#  auto  - let the scripts figure out what's best at boot
#  devfs  - use devfs (requires sys-fs/devfsd)
#  udev  - use udev (requires sys-fs/udev)
#  static - let the user manage /dev

RC_DEVICES="udev"

# UDEV OPTION:
# Set to "yes" if you want to save /dev to a tarball on shutdown
# and restore it on startup.  This is useful if you have a lot of
# custom device nodes that udev does not handle/know about.

RC_DEVICE_TARBALL="no"

I don't even use gentoo's nvidia, I know it is sacrilegious but The one from there site works fine for me Plus I'm lazy and it will even update xorg for me.

superkav 02-08-2006 07:04 PM

Hey, thanks for responding.

I had that snippet in my /etc/conf.d/rc, with the exception of RC_DEVICES being set to "udev." I'll try this out, thanks for the tip. If it doesn't work, I may just use the nvidia driver, too.

K

comprookie2000 02-08-2006 07:18 PM

Also which version of udev do you have
udevinfo -V
I have 070 0n this box


All times are GMT -5. The time now is 01:46 AM.