LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-14-2007, 08:58 PM   #1
Doug Vitale
Member
 
Registered: Feb 2007
Distribution: Fedora 10/Mint 5 KDE
Posts: 69

Rep: Reputation: 16
Nvidia settings not being saved


I have an Nvidia 8600 GTS graphics card. Using PCLinuxOS 2007.

I have installed dkms-nvidia_100.14.xx (version: 100.14.23-1pclos2007) and nvidia_100.14.xx (version: 100.14.23-1pclos2007) via Synaptic. The problem is that when I run the Nvidia settings manager and change the resolution and refresh rate to 1280x1024/75, these settings revert back to 1024x768/60 after I reboot or log off.

When I click the "Save to X configuration" button, I get this error message: Unable to create new X config backup file '/etc/x11/xorg.conf.backup'. When I boot to PCLinux, I do see the Nvidia splash screen though.

When I go in the PCLinuxOS Administration and select View and Configure Hardware, by video card is coming up as "null".

I just switched from Kubuntu and I didn't have this problem before.

I have tried uninstalling and reinstalling the Nvidia driver with Synaptic and that didn't help. I'm wondering if I should uninstall and then download the driver manually from nvidia.com.

Would anyone have any suggestions as to how I can get my Nvidia card fully utilized by PCLinux?

Here are the contents of my xorg.conf file:

Code:
# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # font server independent of the X server to render fonts.
    FontPath "unix/:-1"
    
    # minimal fonts to allow X to run without xfs
    FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
    Option "Composite"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1024x768 @ 60 Hz"
    HorizSync 31.5-48.5
    VertRefresh 50-70
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "True"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
 
Old 11-14-2007, 09:58 PM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
According to your xorg.conf, 75Hz is not possible (see the VertRefresh).

You can manually edit the xorg.conf file (you need root privileges). Check the specs of your monitor and change the following lines to reflect your monitors specifications.
Code:
    HorizSync 31.5-48.5
    VertRefresh 50-70
Next modify the display subsection for your default depth (24) and add the required resolution.
Code:
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
 
Old 11-14-2007, 10:07 PM   #3
ddstyles
LQ Newbie
 
Registered: Nov 2001
Location: Auckland NZ
Distribution: ubuntu 7.10
Posts: 16

Rep: Reputation: 0
I've seen this before when the user trying to save the change does not have access to /etc/X11/x11.conf (or where ever its stored) file. If you save as another file name and then use a terminal move the new config file to the current one your changes work after the reboot. You may wish to save a copy of the original too.

Cheers, Duncan
 
Old 11-14-2007, 10:12 PM   #4
RRepster
Member
 
Registered: Dec 2002
Location: aksarben
Distribution: Several
Posts: 116

Rep: Reputation: 15
are you root?

Are you running the nvidia-settings as user by chance? I know in Ubuntu running the program from the gnome-start will not let you save to xorg.conf and produce that exact message you gave because it's running in usermode. The fix for that is to go to console and do
gfsudo (or is it gksudo, I've forgotten already and just did this myself a few minutes ago) anyway, gfsudo nvidia-settings then it will run in root mode and save when you click save to xorg button.
 
Old 11-15-2007, 12:44 PM   #5
ddstyles
LQ Newbie
 
Registered: Nov 2001
Location: Auckland NZ
Distribution: ubuntu 7.10
Posts: 16

Rep: Reputation: 0
from a terminal, as normal user, its gksudo nvidia-settings (ubuntu gutsy). thanks for the tip rob! It has written the file:
dunc3@xx-desktop:~/Desktop/mfc215c$ ls -al /etc/X11/xorg.conf
-rw-r--r-- 1 root root 1878 2007-11-16 07:41 /etc/X11/xorg.conf

Now i reboot - let's hope it works.....
 
Old 11-15-2007, 04:25 PM   #6
RRepster
Member
 
Registered: Dec 2002
Location: aksarben
Distribution: Several
Posts: 116

Rep: Reputation: 15
excellent

excellent, glad I could help.

take care,

Rob
 
Old 11-15-2007, 08:49 PM   #7
Doug Vitale
Member
 
Registered: Feb 2007
Distribution: Fedora 10/Mint 5 KDE
Posts: 69

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Wim Sturkenboom View Post
According to your xorg.conf, 75Hz is not possible (see the VertRefresh).

You can manually edit the xorg.conf file (you need root privileges). Check the specs of your monitor and change the following lines to reflect your monitors specifications.
Code:
    HorizSync 31.5-48.5
    VertRefresh 50-70
Next modify the display subsection for your default depth (24) and add the required resolution.
Code:
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
Great advice, Wim. It worked. I went to dell.com and got the specs of my monitor. Then I edited xorg.conf manually as you suggested. Thanks.

I also added my user account to the sudoers file, and I find now that if I run "sudo nvidia-settings", I can save any changes to the xorg.conf file.
 
  


Reply

Tags
nvidiasettings, save, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X server settings not being saved... Ineed2muchHelp Linux - General 1 12-22-2005 10:15 AM
application settings not saved in 9.2 gavinbeatty Suse/Novell 0 12-09-2004 04:43 PM
Where are settings for apps saved? vbmark Mandriva 1 11-19-2004 08:58 AM
Firewall settings aren't saved Error1312 Mandriva 10 05-31-2004 10:47 AM
NIC settings not being saved supa2003 Linux - Networking 4 01-17-2004 07:20 PM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration