LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-20-2010, 10:08 AM   #1
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Rep: Reputation: 15
NVIDIA proprietary driver, resolution changes not saved on restart, Fedora 14


I recently installed Fedora 14 KDE and NVIDIA proprietary driver for GeForce FX 5200. I'm able to change the resolution to 1920x1080 (Acer H213H 21.5" lcd monitor), but when I restart the box, I lose these settings and I have to fiddle with NVIDIA and KDE monitor settings until I get the settings back. Here is my xorg.conf file:
Code:
# nvidia-xconfig:  version 260.19.06  (mockbuild@)  Sun Oct 10 17:27:36 EDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    Modes "1920x1080" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Is this (in)correct? What else can I try in order to keep my resolution at 1920x1080? When I restart, it reverts to 640x480.

I didn't have this problem before installing NVIDIA driver, however, I had visual anomalies and slowness in video refresh/repaint whenever moving windows. I don't want to go back to that so I'd like to see how to permanently propagate my resolution settings through reboots of this box. I've search multiple forums with no relevant hits as far as I was able to discern.

Thanks!
 
Old 12-20-2010, 10:44 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Try to find the /var/log/Xorg.0.log file. If there is an error it will show up in there.

Also, have you disabled kernel mode setting (kms) for this kernel ? The proprietary driver and the default Fedora plymouth graphical boot don't normally play nicely together.

To test this, you can nomodeset to the end of your kernel options while at the grub chooser screen when booting. This is temporary for this boot only. To make permanent, edit your grub.lst or grub.conf file and add that option.

Last edited by smoker; 12-20-2010 at 10:49 AM.
 
Old 12-20-2010, 10:51 AM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,454
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
problem is you need root permission to change the the xorg.conf open a terminal and assume root and type nvidia-xconfig this should set it to auto.
or login as root and run nvidia-settings make changes and save.
 
Old 12-20-2010, 02:14 PM   #4
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Drakeo View Post
problem is you need root permission to change the the xorg.conf open a terminal and assume root and type nvidia-xconfig this should set it to auto.
or login as root and run nvidia-settings make changes and save.
I modified the file in a terminal using root and also double-checked and the changes were saved upon reboot. That's what's got me stumped about this. It seems as though the config is being ignored.
 
Old 12-20-2010, 02:46 PM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,454
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
ok the it is in your /home/your user .nvidia if you have one I know FC14 changed things ok. and this is the big reason I stay away from fc14 it is not my cup of tea.
the day I cant edit my xorg and have it work is the day I stay away from that OS
 
Old 12-21-2010, 09:35 AM   #6
mbvpixies78
Member
 
Registered: Nov 2007
Location: IL
Distribution: CentOS 6 & Fedora 17
Posts: 179
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Drakeo View Post
ok the it is in your /home/your user .nvidia if you have one I know FC14 changed things ok. and this is the big reason I stay away from fc14 it is not my cup of tea.
the day I cant edit my xorg and have it work is the day I stay away from that OS
Drakeo,

I haven't found any real critical analysis of the pros and cons of particular distros so I'm interested in hearing more about fc14 in your opinion or if you know of anywhere to point me for further reading I'd much appreciate it. I'm not married to fc14 so if you have any suggestions of other distros I'd be very much willing to check them out. EDIT: I just noticed the distros you have listed-- I actually tried PCLinux and Mandriva and I liked both but for whatever reason I settled on Fedora. I'm going to try Mandriva again, maybe also check out the Kubuntu live cd.

I looked at my .nvidia-settings-rc file and there's nothing in it to specify screen resolution. When I type "nvidia-settings --query all" it runs through much output, ending with an error:

Code:
Gdk-ERROR **: The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 384 error_code 8 request_code 140 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Aborted (core dumped)
so it seems at least one of the settings is incorrect:
Code:
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Mon Dec 20 09:29:45 2010
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Graphics_Card_(GPU_0),Yes,1000

# Attributes:

0/CursorShadow=0
0/CursorShadowAlpha=64
0/CursorShadowRed=0
0/CursorShadowGreen=0
0/CursorShadowBlue=0
0/CursorShadowXOffset=4
0/CursorShadowYOffset=2
0/SyncToVBlank=0
0/LogAniso=0
0/FSAA=0
0/TextureSharpen=0
0/GammaCorrectedAALines=0
0/AllowFlipping=1
0/FSAAAppControlled=1
0/LogAnisoAppControlled=1
0/OpenGLImageSettings=1
0/RedBrightness=0.000000
0/GreenBrightness=0.000000
0/BlueBrightness=0.000000
0/RedContrast=0.000000
0/GreenContrast=0.000000
0/BlueContrast=0.000000
0/RedGamma=1.000000
0/GreenGamma=1.000000
0/BlueGamma=1.000000
0/DigitalVibrance[CRT-0]=0
0/ImageSharpening[CRT-0]=0
0/XVideoTextureSyncToVBlank=1
0/XVideoBlitterSyncToVBlank=0
0/XVideoSyncToDisplay=1

Last edited by mbvpixies78; 12-21-2010 at 09:43 AM.
 
Old 12-21-2010, 10:08 AM   #7
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,722

Rep: Reputation: 195Reputation: 195
If I had that problem...

I would look at the README for the Nvidia driver and use the commands in "nvidia-xconfig" to configure the driver. Thereafter, if that didn't solve the problem, I would begin to edit an "xorg.conf" file.

http://us.download.nvidia.com/XFree8...DME/index.html

http://linux.die.net/man/1/nvidia-xconfig

See Chapter 6 on using "nvidia-xconfig" Note the mention of two locations for configuration files, and the command for finding the right one to edit. "nvidia-xconfig" has an option for adding a given resolution(mode).

Last edited by thorkelljarl; 12-24-2010 at 06:19 PM.
 
1 members found this post helpful.
Old 12-23-2010, 03:24 AM   #8
Babertje
Member
 
Registered: Jun 2009
Location: Haarlem, The Netherlands
Distribution: Archlinux
Posts: 125

Rep: Reputation: 20
You should use a lecacy driver for a FX5200 which is : 173.14.28 not according to your nvidia-xconfig : 260.19.06
The new drivers try to hook-up to HW things that do not exist in a 5200
 
  


Reply

Tags
fedora 14, nvidia, screen resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound through inboard HDMI on Fedora 12 with proprietary NVIDIA video driver rcx11 Linux - Hardware 9 08-21-2010 08:29 PM
Nvidia, Arch Driver vs proprietary... Alexvader Arch 4 08-13-2010 08:39 AM
Has anyone tried the proprietary driver with an Nvidia gt310m? damgar Linux - Hardware 1 04-18-2010 03:05 AM
[SOLVED] Is anyone succesfully running 2.6.32 with the proprietary NVIDIA driver? damgar Slackware 16 12-19-2009 12:58 PM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 06:51 AM


All times are GMT -5. The time now is 07:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration