LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-22-2012, 10:51 AM   #1
olexandr.klymenko
LQ Newbie
 
Registered: Jun 2011
Posts: 18

Rep: Reputation: Disabled
NVidia GT 430 onboard VGA(DVI-I) + Display Port


Hi guys,
We are about to use Z68ITXBE (ZOTAC with NVidia GT 430 onboard) is our appliances based on linux (kernel 2.6.38) .
For the moment we are trying to make available such configuration:
Use only NVidia card, to one analog display is connected to DVI-I (via dvi-vga adapter), second one is connected to Display Port
In this configuration only first display is available. Second one is in standby mode.

In /var/log/Xorg.0.log there are such lines:

(EE) Feb 22 09:50:37 NVIDIA(1): The requested configuration of display devices (DFP-0) in
(EE) Feb 22 09:50:37 NVIDIA(1): MetaMode "640x480" is not supported on this GPU; none is
(EE) Feb 22 09:50:37 NVIDIA(1): recommended, instead.
(WW) Feb 22 09:50:37 NVIDIA(1):
(WW) Feb 22 09:50:37 NVIDIA(1): Unable to validate any modes; falling back to the default mode
(WW) Feb 22 09:50:37 NVIDIA(1): "nvidia-auto-select".
(WW) Feb 22 09:50:37 NVIDIA(1):
(EE) Feb 22 09:50:37 NVIDIA(1): The requested configuration of display devices (DFP-0) in
(EE) Feb 22 09:50:37 NVIDIA(1): MetaMode "nvidia-auto-select" is not supported on this
(EE) Feb 22 09:50:37 NVIDIA(1): GPU; none is recommended, instead.
(EE) Feb 22 09:50:37 NVIDIA(1): Unable to use default mode "nvidia-auto-select".
(II) UnloadModule: "nvidia"

When we use both video out in digital mode it's OK. There is no errors in log file and both displays work.
xorg.conf and full Xorg.0.log are attached
Attached Files
File Type: txt xorg.conf.txt (4.2 KB, 1 views)
File Type: txt Xorg.0.log.txt (253.7 KB, 1 views)
 
Old 03-19-2012, 07:09 PM   #2
lulzwar
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Same machine, different problem

I'm trying to get the same machine to work. Though I don't have a DisplayPort adapter as of yet. Once I get that DisplayPort->HDMI I might want to discuss this further.

I've tested with even 3.3 kernel and never got a signal from the Nvidia card (from the DVI out, DisplayPort still untested). Which drivers were you using for Nvidia?

I just get "GPU has fallen of the bus" from nvidia driver, occasional freezes with certain settings, nouveau driver causes some major error. Otherwise the boars seems to work.

Which BIOS settings did you use? I have the newest BIOS.

Last edited by lulzwar; 03-19-2012 at 07:12 PM.
 
  


Reply

Tags
dual_head, linux, nvidia, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IBM T42(type 2373) and Port Replicator II(74P6733): DVI and VGA at same time m4rtin Linux - Laptop and Netbook 3 09-28-2009 05:49 AM
External Display Issue with nVidia Card over DVI cable on Ubuntu lazeeboy Linux - Newbie 2 03-25-2008 05:01 PM
nvidia, cant gdmlogin be the DVI and not the VGA ? Xeratul Linux - Hardware 2 08-19-2007 02:31 PM
suse 10.1 x86-64: installation of nvidia drivers for onboard nForce 430 failed... jojolx Linux - Hardware 0 08-18-2006 08:37 AM
Suse Linux 9.3 for multihead display with my Nvidia 6600 GT AGP Dual DVI GreekMan978 Linux - Hardware 16 08-07-2005 08:07 PM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration