LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Nvidia GF4 440MX SE TVout problem , help! (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-gf4-440mx-se-tvout-problem-help-58250/)

DVDke 05-05-2003 01:56 PM

Nvidia GF4 440MX SE TVout problem , help!
 
Ok this is my problem:

I have a 19 inch crt monitor and my TVset connected on my geforce4 440 mx se.
I installed the nvidia drivers for the card and everything still works fine, lucky me :)
Now I edited my XF86config file with the nvidiamanual which was in the driverset.
The problem I have is that I can't get anything on the screen on my tvscreen. Goth picture on both screens (in colour) while booting untill I get my loginscreen of X then just my crt monitor works and the tvscreen get's blank. When I only put the "TV" in the Option "ConnectedMonitor" "CRT, TV" in my XF86Config file and reboot I have picture on my tvscreen in X but not on my crtmonitor which is logic. But the image is in black and white on my tvscreen.
I think it must be something stupid but I can't find it :o

Here is the relevant part of my XF86Config file :


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 31-60
Identifier "Monitor[0]"
ModelName "1024X768@75HZ"
VendorName "--> VESA"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 78.80 1024 1040 1136 1312 768 769 772 800
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce4 MX 440"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
Option "TwinView" "true"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768,1024x768; 800x600, 800x600; 640x480, 640x480"
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "CRT, TV"
Option "TwinViewOrientation" "Clone"
Option "TVOutFormat" "SVIDEO"

EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection


I'm running on suse 8.2 pro and live in belgium (a small spot on the map )
The hardware is ok in winblows, everything works there so i know the cables and connections are ok.
I'm sorry for the long thread but i hope it's enough to give some pointers on this.

thx ad advance
I would be very gratefull

MasterC 05-10-2003 10:52 AM

Wow, I really don't see anything immediately... However, here's my XF86Config file working with TwinView, maybe you can use it to compare the differences:
www.masterc.no-ip.org/share/XF86Config.TwinView

The only thing I'm still having problems with (and I found this while searching for resolutions) is getting the full display on the TV... I will post up a thread soon on that though.

Cool

DVDke 05-10-2003 11:09 AM

I managed to get the tvout working, it was something stupid.
Things i've changed:

Option "MetaModes" "1024x768, 800x600; 800x600, 800x600; 640x480, 640x480"
Option "TVOutFormat" "COMPOSITE"

But the problem is now, when I'm running a 1024x768 desktop on my crt is everything ok but on the tv it doesn't show my complete desktop. So I have to work in 800x600 desktop and I really want 1024x768.

Greetzzzzz

MasterC 05-10-2003 11:24 AM

he he he, yep, me too :) See my other post:
http://www.linuxquestions.org/questi...threadid=59053

That's exactly my problem. There are ways around it, just not ones I like...

Cool

MasterC 05-10-2003 08:12 PM

Woohoo! Look at the above mentioned thread. It's working like a champ now!

:)

Cool

startail 05-24-2003 05:21 PM

Hiya folks,

I've tried to use the abow examples about how to get a twin View setted up but as soon as I add the options:

Code:

Option "TwinView"        "on"
Option "ConnectedMonitor"        "CRT,TV"
Option "SecondMonitorHorizSync"        "30 - 50"
Option "SecondMonitorVertRefresh"        "60"
Option "MetaModes"        "1024x768, 800x600, 640x480"
Option "TVStandard"        "NTSC-M"
Option "TVOverscan"        "0.0"
#Option "TVOutFormat"        "SVIDEO"
#Option "TVOutFormat"        "COMPOSITE"

My CRT gives a weird output and the computer totally hangs.

Any idea what I should do to get the TV working ? Do I need to add some more "Devices" or "Screens" in the condig file to get it to know theres a TV to ?

I've tried to understand the example XF86Config.TwinView file but I still can't get it to work ...

One thing tough, When I run "redhat-config-xf86config" it gives output on both the CRT and the TV ... so It works, but not when I run X ...

startail 07-12-2003 04:43 PM

I finally had the time to take a look at this and I've got it to work really good now.
When I run TwinView with the TV at "RightOf" mode the TV is running at 800x600 but that's not how I want it as it puts some windows at the TV when I dosn't use it for the comp.
But when I run it in "Clone" mode it dosn't the TV in 800x600 mode.

Even tough I've used the
MetaModes as mentioned before to be working good ...

If anyone got any tips I would be happy

rechever 10-13-2003 08:07 PM

Hi

I got it
you have to change
Option "MetaModes" "1024x768, 800x600; 800x600, 800x600; 640x480, 640x480"
for this
Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x480"

Anmar 03-23-2005 09:52 AM

I'm new at this,,Sorry!!
 
First I never tried to tv-out in an other tv screen using linux,

And there is no utility that I can go and play with the screens like the one in Windo$e and I don't k'now where to go or what to do exactly with my ati radeon 9600 that my brother has installed already,,

So I need help,,

Please give me steps for that to be done,

Appreciate it

Ba'BYEZ!!

Cute BEAST


All times are GMT -5. The time now is 08:12 AM.