LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-15-2006, 11:42 AM   #1
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Rep: Reputation: 15
Nvidia GeForce4 MX440 video issues


I just replaced my old (outdated) ATI Rage 6 card with a (less outdated) Nvidia GeForce4 MX440 that my dad gave me. I booted into Windows and it installed the correct driver and works great, so I know the card works. The problem is I try to boot linux and it gives me an Xserver error and just boots to the command propmt "Desktop Login:". How do I get my GUI back?

I'm running Suse 10.1 on an older Dell 8100.

Thanks

Last edited by dsyebert; 09-15-2006 at 12:10 PM.
 
Old 09-15-2006, 01:49 PM   #2
jchance
Member
 
Registered: Sep 2003
Location: New Hampshire USA
Distribution: Mandriva 2006 & 2007 Power Pack Club
Posts: 178

Rep: Reputation: 30
Simply put you need to go to Nvidia's website and download the driver files and install them. Then use whatever utility your distro uses to configure x or manually change your xorg.conf file.
 
Old 09-15-2006, 01:59 PM   #3
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
The nv driver works quite well for recent versions of X. Edit your xorg.conf file, find the Graphics Device section, and change the Driver to "nv".

Brian
 
Old 09-15-2006, 04:38 PM   #4
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Original Poster
Rep: Reputation: 15
Sorry, maybe this is a stupid question, but how do I do this all from the "Desktop Login:" prompt?
 
Old 09-15-2006, 04:47 PM   #5
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
Enter your user name, then your password when you are prompted.

Then you need to open xorg.conf in a text editor. I use vi, but something like pico would be a little more newbie-friendly. Try: pico /etc/X11/xorg.conf.

Brian
 
Old 09-15-2006, 09:58 PM   #6
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Original Poster
Rep: Reputation: 15
Okay, but I will have to install the drivers berfore I do this, correct? Will I have to put the old card back in to install the drivers, or can I do that from the prompt as well?
 
Old 09-15-2006, 11:01 PM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
If you want to use the nvidia driver, you must install it. The nv driver comes with X, so you don't have to install anything.

Brian
 
Old 09-16-2006, 01:21 AM   #8
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Original Poster
Rep: Reputation: 15
I logged in and modified the xorg.config file to read "nv" for the driver. When I tried to save it, it said [cannot open file for writing: Permission denied]. Any Ideas? Also, do I leave the board name and vendor name alone? Will that change automatically?
 
Old 09-16-2006, 11:07 AM   #9
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
You need to edit the file as root user. To become root user enter the command "su" and the root password when prompted.

As to changing the descriptive information, it is not necessary but probably a good idea so you don't get confused later on. It would change automatically if you configure with your systems x configuration program, but since you are editing manually you'd need to change it yourself. All you really need is the Driver line and the Identifier line, which is then used a little further down in Screen Sections section.

Brian
 
Old 09-16-2006, 12:29 PM   #10
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Original Poster
Rep: Reputation: 15
Okay, that all worked great. I'm now running the GUI again. Just for kicks I decided to install the Nvidia driver from their site. I added the "download.nvidia.com/novell" installation source to YOU as directed on their site. I go into YAST and select the packages to install and it gives me dependency conflits. It is telling me "there are no installable providers of kernels...". Why is this? I have the installation sources enabled and set to refresh.
 
Old 09-16-2006, 01:03 PM   #11
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
Sorry, can't help you with SUSE-specific stuff like YAST.

You could try compiling the nvidia driver yourself, though. It's simple, and you should get some more meaningful error messages if it doesn't work.

Brian
 
Old 09-16-2006, 01:20 PM   #12
dsyebert
LQ Newbie
 
Registered: Aug 2006
Location: San Luis Obispo, CA
Distribution: Suse 10.1
Posts: 27

Original Poster
Rep: Reputation: 15
Okay. Thanks for all the help!
 
Old 09-18-2006, 02:22 PM   #13
alpurl
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Ok, I'm sitting here reading this and it's all Greek to me.

I had a similar problem and started another thread.

I managed to find something somewhere that I needed to type "Yast" while logged in to the command line without the GUI. I did that and managed to get my gui back. I still don't have 3d at all. And am trying to get this set up to run XGL.

I'm using SuSE 10.1 and my vid card is the nVidia FX5200.

I know nothing about compiling and such.

Nor do I understand how to actually change run levels and the like.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer video display problem with NVIDIA MX440 (128MB) msvijayabaskar Linux - Software 2 04-13-2005 09:38 AM
Nvidia GeForce4 refresh issues slymer Linux - Hardware 0 02-25-2005 11:42 AM
NVIDIA GEFORCE4 MX440 and MANDRAKE 9.1 frog-newbie Linux - Hardware 4 09-10-2003 05:11 PM
choppy video nvidia geforce4 frog-newbie Linux - Hardware 7 09-06-2003 01:06 AM
mandrake 9.1 and geforce4 mx440 sfinga Linux - Newbie 2 05-06-2003 04:25 PM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration