LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   nvidia geforce4 mx440 drivers for debian squeeze (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-geforce4-mx440-drivers-for-debian-squeeze-783253/)

2handband 01-19-2010 11:45 AM

nvidia geforce4 mx440 drivers for debian squeeze
 
I need drivers for an nvidia geforce4 mx440 video card which will run on Debian Squeeze with the 2.6.30 kernel. Does anybody know where I can get them?

Earl Parker II 01-19-2010 04:39 PM

http://www.nvidia.com/object/linux_d..._96.43.14.html

2handband 01-19-2010 06:02 PM

Okay, I just installed that driver; thanks. Maybe the problem isn't the drivers because when I first log in all the stuff on my screen is still squished over to the extreme left. Here's my xorg.conf:

Code:

nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Mon Nov  9 06:17:18 PST 2009                                                                         

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"   
EndSection                                 

Section "Files"
EndSection   

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse" 
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      30.0 - 110.0
    VertRefresh    50.0 - 150.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Does anybody see anything out of place?

2handband 01-19-2010 06:11 PM

Okay, solved it. The problem was that it was starting up with the highest available resolution, which happened to be 1600x1200. I simply removed that resolution from xorg.conf and it is now functioning properly. Hope this helps anyone who runs across the same prob.

jlinkels 01-19-2010 06:12 PM

I don't see anything out of place, but it is better to study /var/log/Xorg.0.log.

The 1600x1200 resulution seems a bit high to me for such an ancient card. Delete all resolutions higher than 1024x768 and try again.

Try to change the video driver name to "nv" instead of "nvidia" in the xorg.conf and restart X.

jlinkels

tofino_surfer 01-21-2010 12:23 PM

Quote:

Originally Posted by jlinkels (Post 3832711)
I don't see anything out of place, but it is better to study /var/log/Xorg.0.log.

The 1600x1200 resulution seems a bit high to me for such an ancient card. Delete all resolutions higher than 1024x768 and try again.

Try to change the video driver name to "nv" instead of "nvidia" in the xorg.conf and restart X.

jlinkels

Both of these statements are wrong and arrogant.

I am still using a 2001 era GeForce 2 MX400, older than this card, which supports resolutions up to 2048 X 1536. I am now using it as 1680 X 1050 with my Samsung widescreen LCD. I previously used it at 1600 X 1200 with 24-bit depth for years with my 19" LG CRT monitor.

Despite complaints from open source fanatics, the binary "nvidia" drivers from Nvidia themselves are better than the provided open source "nv" drivers. I can attest to this. The open source "nv" driver did not support the widescreen 1680 X 1050 mode I needed but the binary "nvidia" drivers I switched to supports this newer mode perfectly as well as providing smoother video performance.

I will soon upgrade this card finally to one with better 2D performance and a DVI link but it has done me well and is doing me well at high resolutions, 1680X1050 currently, and 1600 X 1200 previously. It is two generations older than the geforce 4.

2handband 01-21-2010 01:21 PM

Okay, what's your secret? In general the nvidia proprietary driver gives me better display qualities, but it gives me horrible, jerky video playback performance (that goes for both flash and dvds). If I can fix the video performance issue I'll happily use the nvidia driver.

jlinkels 01-21-2010 05:44 PM

Quote:

Originally Posted by tofino_surfer (Post 3835258)
Both of these statements are wrong and arrogant.

I beg your pardon?

First the recommendation I gave to delete the higher resolutions was right. The OP posted his solution at the same instant as I did as you can see.

Secondly all three advices are sound advices in case of problems with any NVIDIA driver. Study Xorg.0.log, lower the resolution, use the nv driver.

Last, please show me the "arrogant" answer I gave.

jlinkels

2handband 01-21-2010 06:51 PM

You're both right to a point, although I fail to see in what way jinkels was arrogant. Both drivers are giving me some problems. The nvidia one is better in general, but the jerky vid playback is a showstopper. Does anyone know of a fix?

2handband 01-21-2010 07:41 PM

Okay, here's the scoop: I experimented some with resolution settings and discovered that the nvidia drivers work fine so long as I keep my resolution down to 1024x768. Not my first choice, but worth it to fix my graphics issues.

GrapefruiTgirl 01-21-2010 07:52 PM

http://www.linuxquestions.org/questi...nitors-751939/

I know of no reason why that card shouldn't do 1600x1200; I have the identical card (GeForce4 mx440 AGP8x, currently in the roommates computer as I have upgraded) and it had always worked just great at 1600x1200. It will go higher too, but for me, things got sketchy above that resolution because the monitor I was using had a native res of 1600x1200.

There should be no direct bearing at all because of your OS (Debian?) though I used Slackware.. :scratch: Hmm.. Well, two ideas: (1) make sure your horiz and vert frequencies are appropriate for your monitor, and (2) in case it helps, have a look at the link I put above; I pasted some of my past xorg.conf files there. Some of them IIRC were from when I had the mx440 card in this machine, so maybe you will see something in there to try out (config options, etc..)

Good luck, keep us posted!
Sasha

2handband 01-21-2010 08:18 PM

Spoke too soon. Lowering the resolution improved vid performance with Dragonplayer, but flash is still bad and Kaffeine is awful. I don't get it.

GrapefruiTgirl 01-21-2010 08:20 PM

One thing that will probably help a fair bit is reducing your colordepth to 16. You won't notice a difference in quality, but your machine will thank you.

(NOTE: I can't remember if this will affect openGL or not, so beware. Worth a try though)

BTW, what sort of hardware is this all happening on? Fairly decent/speedy hardware, or an older slower machine? (Sorry if you mentioned it, but I didn't see it above)

Sasha

2handband 01-21-2010 10:35 PM

The motherboard, cpu, and ram are all about three days old; a shiny new msi board with an AMD dual-core 2.9 ghz processor. I suspect this is part of the problem; I'm mixing new hardware with some old parts that were around during the Clinton administration. Thanks for the colordepth tip. Unfortunately it didn't work.

If I use the nv driver I have an off-center display. If I use the nvidia driver my video playback sucks.

nxja 02-01-2010 09:57 PM

2002...
 
Quote:

Originally Posted by 2handband (Post 3835939)
... I suspect this is part of the problem; I'm mixing new hardware with some old parts that were around during the Clinton administration...

http://en.wikipedia.org/wiki/GeForce_4_Series#Lineup_2
http://en.wikipedia.org/wiki/Compari...Force_4_series
2002, though that also says that nv17 "evolved" from gf2 (of 2000, gf2: http://en.wikipedia.org/wiki/GeForce_2_Series) .. the nv11? nv15? unless I'm getting lost in nvidia's model-labeling flimflammery.


All times are GMT -5. The time now is 03:23 AM.