LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-02-2009, 02:34 PM   #1
Hosando
LQ Newbie
 
Registered: Jan 2009
Posts: 8

Rep: Reputation: 0
Nvidia geforce2 mx on fedora ppc


Hello lq!

This is my first post.

I am currently installing fedora 10 ppc on an emac 700. This machine is using a nvidia geforce2 mx gpu. I know that x is probably not going to work when I boot up, for I have tried it with a bunch of distros. What are the steps to take to get this card working with x? Has anyone ever pulled it off on one of these computers?

Thanks
 
Old 01-03-2009, 01:54 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,051

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
there is a beta driver for that old card and i know it works on fedora 9 32 bit
NVIDIA-Linux-x86-96.43.09-pkg1.run
ftp://download.nvidia.com/XFree86/Linux-x86/96.43.09/

for 10 ??? don't know if it will work, but on 9
the install dvd will use the gui and gnome will start up
after that just install the *.run driver installer
 
Old 01-03-2009, 04:50 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,940

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
# 2
Quote:
NVIDIA-Linux-x86-96.43.09-pkg1.run
I doubt that x86 will work on mac / ppc
....
 
Old 01-03-2009, 09:36 AM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,051

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
true but Hosando can look and ask around on the nvidia forum
http://www.nvnews.net/vbulletin/foru...?s=&forumid=14
 
Old 01-03-2009, 02:38 PM   #5
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 384

Rep: Reputation: 34
I have been using a geforce2mx until recently. It works, just be sure to use the so-called legacy driver.
 
Old 01-03-2009, 08:19 PM   #6
Hosando
LQ Newbie
 
Registered: Jan 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Smile Success!

I have gotten x to work, under debian. i modified parts from this users xorg.conf (http://homepage.univie.ac.at/georg.koe/XF86Config/XF86Config-4.emac700nvidia.working), merged it with mine to make x finnaly work:

Quote:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection
Section "Monitor"
Identifier "monitor1"
VendorName "Apple"
ModelName "HiRes Display 1152x864"
HorizSync 30.0-112.0
VertRefresh 50.0-160.0
# emac
ModeLine "800x600" 112 800 816 824 840 600 616 624 640 -hsync -vsync
ModeLine "1152x864" 100 1152 1173 1269 1440 768 769 772 800 +vsync +vsync
ModeLine "1024x768" 100 1024 1108 1280 1408 768 768 780 796 +hsync +vsync
ModeLine "1280x960" 100 1280 1288 1392 1664 1024 1027 1030 1064
EndSection


Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nv"
BusID "PCI:0:16:0"
# Option "useFBDev"
Option "DPMS"
EndSection


Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16
Subsection "Display"
Depth 8
Modes "default"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768"
EndSubsection

Subsection "Display"
Depth 24
Modes "default"
EndSubsection
EndSection


Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
Thank you so much for all of your help!

LQ rocks, and linux is awesome!
 
  


Reply

Tags
fedora, mx, nvidia, ppc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newb needs help with an nvidia geforce2 mx 400 mart351 Mandriva 1 11-27-2005 05:54 PM
'nvidia' module doesn't persist for nVidia GeForce2 DDR card dude_a_b_c Mandriva 8 05-19-2004 02:50 PM
Kernel2.6/NVIDIA GeForce2 Problems Y2J Linux - Newbie 1 12-21-2003 08:31 PM
nVidia GeForce2 MX 40 - Open GL - HOW? Ciccio Linux - Hardware 4 05-22-2003 03:49 AM
NVIDIA geForce2 GO 16MB Linux05180 Linux - Software 1 08-13-2001 01:43 AM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration