LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-05-2004, 04:12 PM   #1
rcrules
Member
 
Registered: Jun 2003
Location: USA
Distribution: Gentoo 2005.0
Posts: 54

Rep: Reputation: 15
NVIDIA GeForce Drivers + MM-Sources kenrel = BAD


I've found myself in a strange perdicament with the most recent NVIDIA driver for my GeForce4 MX440. For some reason, ever since I started using MM-Sources (kernel 2.6.5-mm6), the driver compiles and does everything fine, until I go to modprobe the driver. Now, it gives me the error:
FATAL: Error inserting nvidia (/lib/modules/2.6.5-mm6/video/nvidia.ko): Invalid module format
The strange thing is, the other day I got it to work once, immediately after I compiled the driver the first time, although I have had no luck since, even though I have changed nothing else other than to re-install the driver (after the problem hit, of course). Does anyone know what this means exactly, and what I can do to fix it? By the way, I'm using NVIDIA-Linux-x86-1.0-5336-pkg1.run, the latest module with 2.6 kernel support, to my knowledge. Thanx for any help!
 
Old 05-05-2004, 04:43 PM   #2
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
are you using the same version of the kernel sources for your working kernel? if not, that could be your problem.
 
Old 05-06-2004, 10:20 PM   #3
rcrules
Member
 
Registered: Jun 2003
Location: USA
Distribution: Gentoo 2005.0
Posts: 54

Original Poster
Rep: Reputation: 15
After talking to some friends, i have discovered that the problem is appaently an incompatability with mm-sources, and not simply with the 2.6.* kernel. I am going to try another flavor of the 2.6.* kernel and post back my results...
Thanx for the input... btw, i was indeed using the same version of the kernel sources, but that appears to make no difference in this situation, i suppose
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia geforce fx 5200 drivers... snip128 Linux - Hardware 1 10-31-2004 04:58 PM
Nvidia Geforce drivers problem remz Linux - Software 7 07-29-2004 06:20 PM
Installing Nvidia GeForce 3 Drivers on Mandrake 10.0 Thomas_Swanicke Linux - Newbie 2 05-07-2004 10:24 PM
installing NVIDIA drivers for Geforce 4 and Redhat 9.0 Armand Linux - Hardware 7 07-20-2003 07:06 PM
Need help with Redhat 8 and nvidia drivers for geforce 4 ashleygorell Linux - General 14 03-16-2003 12:12 AM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration