LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Nvidia GeForce 9400 GT on SuSE 11.1 (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-geforce-9400-gt-on-suse-11-1-a-694564/)

bkorb 01-02-2009 04:09 PM

Nvidia GeForce 9400 GT on SuSE 11.1
 
After downloading the driver from nvidia.com, it rebuilt itself and installed. It fiddled the /etc/X11/xorg.conf file. X would not come up. It came up under SuSE 11.0, but not 11.1. So, I'm using whatever it
is the sax2 configurator does, which settles on "VESA Framebuffer Graphics". My 1680X1050 monitor is running in 1280X1024 mode. And, I should point out, that it is only one of my two monitors. (Same as with SuSE 11.0.) Googling has not yielded anything useful. Anybody with a clue? :( Thank you.

Mega Man X 01-02-2009 04:36 PM

Quote:

Originally Posted by bkorb (Post 3395003)
After downloading the driver from nvidia.com, it rebuilt itself and installed. It fiddled the /etc/X11/xorg.conf file. X would not come up. It came up under SuSE 11.0, but not 11.1. So, I'm using whatever it
is the sax2 configurator does, which settles on "VESA Framebuffer Graphics". My 1680X1050 monitor is running in 1280X1024 mode. And, I should point out, that it is only one of my two monitors. (Same as with SuSE 11.0.) Googling has not yielded anything useful. Anybody with a clue? :( Thank you.

I would suggest you to try to enable nvidia driver at the xorg.conf file again (make a backup of xorg first) and try to start x. If that fails, see if any error message is shown at the console. If it is, copy and paste it here so we can see it.

Also, you could take a look for some logs for a potential explanation of what is going on. There should be some at /var/logs. Start taking a look there for X logs.

Third and probably the most important, I would suggest you to install Nvidia (and everything else actually) through SuSE's YaST. Take a look in here to see if that is of any help:

http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html

I've not used SuSE in years, but I remember always succeeding in installing nvidia through YaST. I just wanted to point out some clues for you to look around on your system for possible errors (logs) and recommend to stick with YaST for things like this.

Regards!

bkorb 01-02-2009 05:33 PM

Still no joy
 
Actually, I did also get it from the Yast software repository. Though it installed readily enough (just like with SuSE 11.0), this time it left the xorg.conf file in a completely unusable state. Black screen. No display at all. It also said it was talking to a GeForce 8300, which happens to be the integrated chip on the main board. My monitors are plugged into the graphics card. I'll get out of graphics mode and see if I can capture some console messages and look in /var/log/messages for anything once again. Back in a bit. Thank you.

bkorb 01-02-2009 05:50 PM

/var/log/messages
 
Jan 2 23:42:13 linux-g7g1 kernel: CPU0 attaching NULL sched-domain.
Jan 2 23:42:13 linux-g7g1 kernel: CPU1 attaching NULL sched-domain.
Jan 2 23:42:13 linux-g7g1 kernel: CPU2 attaching NULL sched-domain.
Jan 2 23:42:13 linux-g7g1 kernel: CPU3 attaching NULL sched-domain.
Jan 2 23:42:13 linux-g7g1 kernel: CPU0 attaching sched-domain:
Jan 2 23:42:13 linux-g7g1 kernel: domain 0: span 0-3 level CPU
Jan 2 23:42:13 linux-g7g1 kernel: groups: 0 1 2 3
Jan 2 23:42:13 linux-g7g1 kernel: domain 1: span 0-3 level NODE
Jan 2 23:42:13 linux-g7g1 kernel: groups: 0-3
Jan 2 23:42:13 linux-g7g1 kernel: CPU1 attaching sched-domain:
Jan 2 23:42:13 linux-g7g1 kernel: domain 0: span 0-3 level CPU
Jan 2 23:42:13 linux-g7g1 kernel: groups: 1 2 3 0
Jan 2 23:42:13 linux-g7g1 kernel: domain 1: span 0-3 level NODE
Jan 2 23:42:13 linux-g7g1 kernel: groups: 0-3
Jan 2 23:42:13 linux-g7g1 kernel: CPU2 attaching sched-domain:
Jan 2 23:42:13 linux-g7g1 kernel: domain 0: span 0-3 level CPU
Jan 2 23:42:13 linux-g7g1 kernel: groups: 2 3 0 1
Jan 2 23:42:13 linux-g7g1 kernel: domain 1: span 0-3 level NODE
Jan 2 23:42:13 linux-g7g1 kernel: groups: 0-3
Jan 2 23:42:13 linux-g7g1 kernel: CPU3 attaching sched-domain:
Jan 2 23:42:13 linux-g7g1 kernel: domain 0: span 0-3 level CPU
Jan 2 23:42:13 linux-g7g1 kernel: groups: 3 0 1 2
Jan 2 23:42:13 linux-g7g1 kernel: domain 1: span 0-3 level NODE
Jan 2 23:42:13 linux-g7g1 kernel: groups: 0-3
Jan 2 23:43:30 linux-g7g1 sshd[22105]: Did not receive identification string from 116.50.231.196

Looks like someone is trying to ssh in. Anyway, I seem
to get these "sched-domain" messages around the same time
I'm trying to configure my video. Probably a connection,
but I'm not one to have a clue what these mean. Neither
the .xsession-errors file in my home directory nor in
root's has anything at all. The console where I run sax2
says this:
# sax2 -r
SaX: initializing please wait...
SaX: your current configuration will not be read in

SaX: access to your display has been granted
SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: NVidia
SPP: calling device [0] profile script: NVidia
SPP: prepare device [0] profile: NoModelines
SPP: prepare device [0] profile: Composite
SPP: prepare device [0] profile: microsoft-natural
SPP: including prepared profile(s)...

SaX: startup
SaX: X-Server: :0.0 -> grant
SaX: using cache data...

and it yields an xorg.conf file that won't run.
I'll get out of X now, try to run that xorg file
and see if I get any .xsession-error stuff of interest.
I have to run an errand, so the next gap will be a couple
hours. Thank you.

Mega Man X 01-02-2009 06:14 PM

Hmmmm, strange. I wonder, what if we move the xorg.conf and run sax2? I expect it to create a new xorg.conf file and, hopefully, fix this problem. Can you try the following, as root:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_bak
sax2 -r -m 0=nvidia


This is a long shot and I am assuming that the drivers were installed correctly, only X is messed up then. If that works, you should have 3D enabled only by doing that. I've no experience configuring dual monitors in Linux, but if the above works I will try to give a you a hand :)

bkorb 01-02-2009 07:25 PM

Quote:

Originally Posted by Mega Man X (Post 3395132)
Hmmmm, strange. I wonder, what if we move the xorg.conf and run sax2?

sax2 does that automatically and I've already squirreled away a "working" version (xorg.conf.degraded :).
Quote:

Originally Posted by Mega Man X (Post 3395132)
I expect it to create a new xorg.conf file and, hopefully, fix this problem.

It creates the xorg.conf file that doesn't work at all.
I could try installing the analog video connector to see if
the signals get redirected to the motherboard port.
I'd maybe get my 1680X1050 resolution back, but I would
not be using the add-on card at all then. I'd really
like to have my dual monitors working. Can't do that
from the integrated graphics device.
Quote:

Originally Posted by Mega Man X (Post 3395132)
Can you try the following, as root:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_bak
sax2 -r -m 0=nvidia

maybe, 1=nvidia 'cuz it's the second controller:

02:00.0 VGA compatible controller: nVidia Corporation GeForce 8300 (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation Device 0641 (rev a1)

Quote:

Originally Posted by Mega Man X (Post 3395132)
I've no experience configuring dual monitors in Linux, but if the above works I will try to give a you a hand :)

Thanks. I've done dual monitors before. It's really simple when the sax2 window asks if you want the second monitor activated and not possible at all when the generic driver doesn't support two monitors. ;-)

========== TIME PASSES ==============

IT IS SOLVED!!!

All you gotta do is "lspci" to figure out the correct BusID for the add on card (03:00.0, shown above). Then run sax2. It will only configure the main board graphics. But, when it's done, fix the BusID "2:0:0" line in xorg.conf by hand. Rerun sax2 *without* the "-r" option. The world is happy again.

Now, why didn't I think of that straight out of the gate?


All times are GMT -5. The time now is 12:07 AM.