LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-geforce-4-mx-440-poor-performance-nvidia-glx-drivers-451865/)

jollyjoice 06-05-2006 02:44 PM

Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers
 
Using the nvidia drivers, 1.0-8762 on gentoo 64bit, getting ~ 110fps in glxgears and KDE finds it impossible to use transparancy or even shadows, well it can use them but I can't!

I know it's not an amazing card, but I'm sure it should be able to do more than this...

DrOzz 06-05-2006 03:02 PM

Are you 100% that this driver had a successful install ? If you are unsure, give this command a try and see what your output is :
Code:

glxinfo | grep rendering
Your answer should be :
Code:

direct rendering: Yes
I know I had this card, and your right, its not the fact that its not amazing, but it should have better performance. I thought the ~800fps I was getting was bad when I was using it, and always tried to improve it. So your right, something is missing, lets just see if we can find it ;)

jollyjoice 06-05-2006 03:32 PM

Code:

~ $ glxinfo | grep rendering
direct rendering: Yes


DrOzz 06-05-2006 03:41 PM

What does the section for your video look like in your xorg.conf file ?

DrOzz 06-05-2006 03:45 PM

actually to save typing, make sure you did all of the following :
http://www.linuxquestions.org/linux/...n_5_EASY_Steps

just for we are on the same page ;)

jollyjoice 06-05-2006 03:46 PM

Code:

        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName  "NV17 [GeForce4 MX 440]"
        BusID      "PCI:1:0:0"

Think thats the right bit.

And yes, I followed that or something similar when setting up originally, and everything seems to be in order, however I have less stuff in modules:
Code:

Section "Module"
        Load  "extmod"
#      Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "type1"
        Load  "freetype"
EndSection


DrOzz 06-06-2006 07:36 PM

Well I noticed that you didn't set the option in xorg.conf which is
Code:

Option "NoLogo" "1"
With that said, when you shut down the X server and then restarted it, did you see the nvidia splash screen ?

Also, I am wondering if you played with the following option in the xorg.conf file in your video settings, which is :
Code:

Option "NvAGP"
If not, try playing with that setting. Valid options for that setting are :
Code:

Option "NvAGP" "0"
Option "NvAGP" "1"
Option "NvAGP" "2"
Option "NvAGP" "3"

Only use one at a time ;)) And just for your knowledge the description of each are :
"0" ... disables AGP support
"1" ... use NVAGP, if possible
"2" ... use AGPGART, if possible
"3" ... try AGPGART; if that fails, try NVAGP

Personally I use 1, but that's what "acceptable" for me. You can play with each setting and see if you see any/no improvement.

But if your not hitting the splash screen everything I said after that point is irrelevant cause it would appear to me that the driver isn't loading, cause like I said if you didn't set the option not to display it, it should be displaying.

Also, just out of curiousity, what kernel version, and what nvidia driver version are you using.

Oh, one more thing I thought about, that affects some users of nvidia cards, is not have dma enabled on your harddrive. So you also may wanna check that too. Crash course to check this is as follows.

Under the assumption your first drive is /dev/hda you issue this command as root :
Code:

hdparm /dev/hda | grep dma
your result should be :
Code:

using_dma    =  1 (on)
If it is set to one, you will just enable it by typing (again as root):
Code:

hdparm -d1 /dev/hda
Again, if it states using_dma is 1, then your fine in that department, but its worth checking.

jollyjoice 06-07-2006 09:02 AM

I didn't list all the options, over looked that :)
Here you go then, I'm no*w* getting ~150 something fps.

Nvidia-glx 1.0-8762, and Gentoo 2.6.16-gentoo-r6 64bit.

Just the ones that are enabled:
Code:

Option    "NoLogo"                      "Flase"
Option    "NvAGP"                      "3"
Option    "RenderAccel"                "True"
Option    "CursorShadow"                "True"
Option    "AllowGLXWithComposite"      "True"

<edit, corrected typo>


All times are GMT -5. The time now is 01:34 AM.