LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-12-2004, 10:42 AM   #1
Crashcourse
LQ Newbie
 
Registered: Feb 2004
Location: Finland
Distribution: Mandrake
Posts: 10

Rep: Reputation: 0
Nvidia fx5900 Ultra causes x freeze/crash


Hello!

My videocard is Nvidia fx 5900 Ultra 256 Mb and MDK 10 official doesn't work. I have installed the kernel source and latest Nvidia drivers. I've also fixed the XF86Config-4 file, but I can't get X working. The system boots normally but when X starts the screen goes black with few blue lines. I'm running... no, I'm trying to run kernel 2.6.3-7 and my machine specs are:

Asrock k7s8xe r3.0 with SIS 748 chipset
AMD Athlon xp 2500+ Barton
Terratec Nvidia FX 5900 Ultra 256 Mb
Maxtor 60Gb & 80 Gb
Creative Audigy Platinum EX
SIS Ethernet 10/100

Does anyone have any words of wisdom to solve my problem?

Thank you!
 
Old 06-12-2004, 10:00 PM   #2
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 178

Rep: Reputation: 30
try editing the XF86Config file, not the XF86Config-4. also, make sure you added "nvidia" in the drivers section in the XF86Config. Did you add the correct syncs to your XF86Config file?
 
Old 06-13-2004, 01:36 PM   #3
randyding
Member
 
Registered: May 2004
Posts: 552

Rep: Reputation: 31
nvidia driver lockup

For the longest time I had the same symptoms, and couldn't use the NV Drivers.
Then someone in nv's help forum posted the Option "NvAGP" "1" solution.
This solved my problem.

Here is what my device section looks like now with the addition of this option.
From XF86Config:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
VideoRam 131072
Option "NvAGP" "1"
EndSection
 
Old 06-13-2004, 02:02 PM   #4
Crashcourse
LQ Newbie
 
Registered: Feb 2004
Location: Finland
Distribution: Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
HAHAHAHAHA!!! YES!!! YOU DA MAN!!!

It finally works! Thank you very much indeed!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New RAM, system freeze/crash MrLizard Linux - Hardware 11 04-27-2005 04:57 AM
Konqueror Crash -> Freeze??? Snyke Suse/Novell 0 12-26-2004 06:49 AM
nVidia GeForce FX5900 + lastest drivers = 1300fps???? Hammett Linux - Software 2 04-22-2004 11:45 AM
VMWare 4 crash/freeze in SuSE 9 uranologist Linux - Software 2 02-27-2004 06:54 PM
Blank screen when trying to install MDK 9.1 with my new nVidia fx5900 Stevetgn Linux - Newbie 3 08-15-2003 09:41 PM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration