LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-29-2004, 12:13 AM   #1
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Rep: Reputation: 30
nVidia drivers makes the system freeze. help.


Sorry about the repost, I placed this in Newbie under a 20day old thread. I think it should be in hardware instead.

I have used Linux off and on for a few years but this is my first time really getting my hands dirty with Gentoo. I currently have my main system installed as well as x and several xapps. Everything works great (wireless, sound, usb storage etc..) I was going to install Gnome today and I decided to install the real nVidia drivers (I have a GeForce 4 128mg AGP). After emerging and configuring nvidia-kernel and nvidia-glx exactly as the Gentoo docs say, I restarted and ran startx.

The screen went blank and the system froze. I then realized there may be a problem with rivafb coexisting. So I actually took console framebuffer support out of the kernel and removed the module from my runlevel. X still freezes. I tried several other things such as changing Load in Xorg.conf between "glx", "dri", and neither. I am really stumped with this one. I have read many other forums and tried some suggestions I thought would fit my problem.

Any suggestions? Are there any logs or confs that will be of use for diagnosing my problem? Thank you for your time, here are my specs:

Athlon XP 2100
1gig DDR
nVidia geForce4 ti4200 128mb
A-bit kt7 series mobo
Netgear ma311 wifi (prism I)
Terratec DMX 6fire (envy)
120gb eide hd

Also, when I start even a light program such as xterm it really causes my input (cursor and keyboard) to lag up. Also the sound will skip. I would think my processor can handle running xmms in the background. Is this related to the video drivers?

Thanks
Paul
 
Old 09-29-2004, 02:47 AM   #2
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Original Poster
Rep: Reputation: 30
Some more information

I can not run lspci.. bash says it doesn't exist, and I have no idea what package it is in. Here is some more information anyways:

cat /proc/driver/nvidia/agp/status returns:
Status: Disabled

/etc/modules.autoload.d/kernel-2.6:
Code:
orinoco_pci
nvidia
snd-ice1712
sections from /etc/X11/xorg.conf:
Code:
# This loads the GLX module
Load       "glx"

Section "Monitor"
    Identifier  "Gateway VX1110"
    HorizSync   31.5 - 115.0
    VertRefresh 50-160
EndSection

Section "Device"
    Identifier  "nVidia geForce4"
    Driver      "nvidia"
    #VideoRam    131072
    # Insert Clocks lines here if appropriate
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "nVidia geForce4"
    Monitor     "Gateway VX1110"
    DefaultDepth 24
    ....
EndSection

Screen "Screen 1"
And this is my log from when it freezes.. Be careful its huge
Code:
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 29 03:13:01 2004
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "Gateway VX1110"
(**) |   |-->Device "nVidia geForce4"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) XKB: rules: "xorg"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "/usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/Speedo/,/usr/share/fonts/Type1/,/usr/share/fonts/CID/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/local/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.2
	X.Org Video Driver: 0.7
	X.Org XInput driver : 0.4
	X.Org Server Extension : 0.2
	X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.0
	ABI class: X.Org Video Driver, version 0.7
Using vt 7
(--) using VT number 7

(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80006860, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3099 card 0000,0824 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b099 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:08:0: chip 100b,0020 card 1385,f312 rev 00 class 02,00,00 hdr 00
(II) PCI: 00:0b:0: chip 1260,3873 card 1385,4105 rev 01 class 02,80,00 hdr 00
(II) PCI: 00:0d:0: chip 1412,1712 card 153b,1138 rev 02 class 04,01,00 hdr 00
(II) PCI: 00:0f:0: chip 1106,3038 card 1106,3038 rev 61 class 0c,03,00 hdr 80
(II) PCI: 00:0f:1: chip 1106,3038 card 1106,3038 rev 61 class 0c,03,00 hdr 80
(II) PCI: 00:0f:2: chip 1106,3104 card 1106,3104 rev 63 class 0c,03,20 hdr 80
(II) PCI: 00:11:0: chip 1106,3147 card 1106,3147 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1106,0571 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:2: chip 1106,3038 card 0925,1234 rev 23 class 0c,03,00 hdr 00
(II) PCI: 00:11:3: chip 1106,3038 card 0925,1234 rev 23 class 0c,03,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0253 card 0000,0000 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
	[0] -1	0	0xe4000000 - 0xe5ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
	[0] -1	0	0xd0000000 - 0xdfffffff (0x10000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV25 [GeForce4 Ti 4200] rev 163, Mem @ 0xe4000000/24, 0xd0000000/27, 0xd8000000/19
(II) Addressable bus resource ranges are
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xe3ffffff to 0xdfffffff
(II) Active PCI resource ranges:
	[0] -1	0	0xe7002000 - 0xe70020ff (0x100) MX[B]
	[1] -1	0	0xe7001000 - 0xe7001fff (0x1000) MX[B]
	[2] -1	0	0xe7000000 - 0xe7000fff (0x1000) MX[B]
	[3] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
	[4] -1	0	0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
	[5] -1	0	0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
	[6] -1	0	0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
	[7] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
	[8] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[9] -1	0	0x0000dc00 - 0x0000dc0f (0x10) IX[B]
	[10] -1	0	0x0000d800 - 0x0000d81f (0x20) IX[B]
	[11] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[12] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
	[13] -1	0	0x0000cc00 - 0x0000cc0f (0x10) IX[B]
	[14] -1	0	0x0000c800 - 0x0000c80f (0x10) IX[B]
	[15] -1	0	0x0000c400 - 0x0000c41f (0x20) IX[B]
	[16] -1	0	0x0000c000 - 0x0000c0ff (0x100) IX[B]
(II) Active PCI resource ranges after removing overlaps:
	[0] -1	0	0xe7002000 - 0xe70020ff (0x100) MX[B]
	[1] -1	0	0xe7001000 - 0xe7001fff (0x1000) MX[B]
	[2] -1	0	0xe7000000 - 0xe7000fff (0x1000) MX[B]
	[3] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
	[4] -1	0	0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
	[5] -1	0	0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
	[6] -1	0	0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
	[7] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
	[8] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[9] -1	0	0x0000dc00 - 0x0000dc0f (0x10) IX[B]
	[10] -1	0	0x0000d800 - 0x0000d81f (0x20) IX[B]
	[11] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[12] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
	[13] -1	0	0x0000cc00 - 0x0000cc0f (0x10) IX[B]
	[14] -1	0	0x0000c800 - 0x0000c80f (0x10) IX[B]
	[15] -1	0	0x0000c400 - 0x0000c41f (0x20) IX[B]
	[16] -1	0	0x0000c000 - 0x0000c0ff (0x100) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[5] -1	0	0xe7002000 - 0xe70020ff (0x100) MX[B]
	[6] -1	0	0xe7001000 - 0xe7001fff (0x1000) MX[B]
	[7] -1	0	0xe7000000 - 0xe7000fff (0x1000) MX[B]
	[8] -1	0	0xe0000000 - 0xdfffffff (0x0) MX[B]O
	[9] -1	0	0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
	[10] -1	0	0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
	[11] -1	0	0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[14] -1	0	0x0000e400 - 0x0000e41f (0x20) IX[B]
	[15] -1	0	0x0000e000 - 0x0000e01f (0x20) IX[B]
	[16] -1	0	0x0000dc00 - 0x0000dc0f (0x10) IX[B]
	[17] -1	0	0x0000d800 - 0x0000d81f (0x20) IX[B]
	[18] -1	0	0x0000d400 - 0x0000d41f (0x20) IX[B]
	[19] -1	0	0x0000d000 - 0x0000d03f (0x40) IX[B]
	[20] -1	0	0x0000cc00 - 0x0000cc0f (0x10) IX[B]
	[21] -1	0	0x0000c800 - 0x0000c80f (0x10) IX[B]
	[22] -1	0	0x0000c400 - 0x0000c41f (0x20) IX[B]
	[23] -1	0	0x0000c000 - 0x0000c0ff (0x100) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.2
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="X.Org Foundation"
	compiled for 6.7.0, module version = 1.0.1
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 6.7.0, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
And it leaves off there after attempting glx... it freezes when not using "Load glx" too though.

Thanks
 
Old 09-29-2004, 03:54 PM   #3
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Original Poster
Rep: Reputation: 30
correction

Wow, 60 views and no ideas yet... I made a mistake in an earlier post. My motherboard is actually an abit kx7-333 which uses the KT333 chipset.

I tried taking AGPGART out of the kernel, rebooting, and starting X with Load GLX and Option "nvAGP" "1" to no avail. Do I have to setup nvAGP outside of emerging nvidia-kernel??

when I do a dmesg I get some lines that look like this (this is when using nv instead of nvidia:
Code:
Linux agpgart interface v0.100 (c) Dave Jones
( ^ but nothing follows it.)
  ...
nvidia: module license 'NVIDIA' taints kernel.
0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-5336  Wed Jan 14 18:29:26 PST 2004
Although I don't have lspci (if anyone knows where to get it that would be great because it isnt installed and there isnt an emerge for it) here are my results from cat /proc/pci:

Code:
cat /proc/pci
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333] (rev 0).      Prefetchable 32 bit memory at 0xe0000000 [0xe3ffffff].
  Bus  0, device   1, function  0:
    PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP] (rev 0).
      Master Capable.  No bursts.  Min Gnt=12.
  Bus  0, device   8, function  0:
    Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller (rev 0).
      IRQ 10.
      Master Capable.  Latency=32.  Min Gnt=11.Max Lat=52.
      I/O at 0xc000 [0xc0ff].
      Non-prefetchable 32 bit memory at 0xe7000000 [0xe7000fff].
  Bus  0, device  11, function  0:
    Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 1).
      IRQ 10.
      Master Capable.  Latency=32.
      Prefetchable 32 bit memory at 0xe7001000 [0xe7001fff].
  Bus  0, device  13, function  0:
    Multimedia audio controller: IC Ensemble Inc ICE1712 [Envy24] (rev 2).
      IRQ 12.
      Master Capable.  Latency=32.
      I/O at 0xc400 [0xc41f].
      I/O at 0xc800 [0xc80f].
      I/O at 0xcc00 [0xcc0f].
      I/O at 0xd000 [0xd03f].
  Bus  0, device  15, function  0:
    USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 97).
      IRQ 12.
      Master Capable.  Latency=32.
      I/O at 0xd400 [0xd41f].
  Bus  0, device  15, function  1:
    USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#2) (rev 97).
      IRQ 10.
      Master Capable.  Latency=32.
      I/O at 0xd800 [0xd81f].
  Bus  0, device  17, function  2:
    USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#3) (rev 35).
      IRQ 10.
      Master Capable.  Latency=32.
      I/O at 0xe000 [0xe01f].
  Bus  0, device  17, function  3:
    USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#4) (rev 35).
      IRQ 10.
      Master Capable.  Latency=32.
      I/O at 0xe400 [0xe41f].
  Bus  0, device  15, function  2:
    USB Controller: VIA Technologies, Inc. USB 2.0 (rev 99).
      IRQ 5.
      Master Capable.  Latency=32.
      Non-prefetchable 32 bit memory at 0xe7002000 [0xe70020ff].
  Bus  0, device  17, function  0:
    ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge (rev 0).
  Bus  0, device  17, function  1:
    IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 6).
      IRQ 11.
      Master Capable.  Latency=32.
      I/O at 0xdc00 [0xdc0f].
  Bus  1, device   0, function  0:
    VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4200] (rev 163).
      IRQ 11.
      Master Capable.  Latency=32.  Min Gnt=5.Max Lat=1.
      Non-prefetchable 32 bit memory at 0xe4000000 [0xe4ffffff].
      Prefetchable 32 bit memory at 0xd0000000 [0xd7ffffff].
      Prefetchable 32 bit memory at 0xd8000000 [0xd807ffff].
Thanks again for your time.

Last edited by AngryLlama; 09-29-2004 at 05:22 PM.
 
Old 09-30-2004, 12:30 AM   #4
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Original Poster
Rep: Reputation: 30
I fixed Option "nvAGP" "1" to be Option "NvAGP" "1".
I also removed vga=ask support from the kernel and grub.
I have also removed AGPGART from the kernel when testing with Option "NvAGP" "1".

here is my lspci:

Code:
 0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:08.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
0000:00:0b.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
0000:00:0d.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
0000:00:0f.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
0000:00:0f.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
0000:00:0f.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
0000:00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4200] (rev a3)
thanks again.

Last edited by AngryLlama; 09-30-2004 at 01:39 AM.
 
Old 09-30-2004, 01:40 AM   #5
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
Did you download the Nvidia self installer, run it and then edit xorg.conf or xfree86?
Is it just freezing or are you getting kicked to console with any errors?
http://www.nvidia.com/object/linux.html

Last edited by BajaNick; 09-30-2004 at 01:42 AM.
 
Old 09-30-2004, 05:17 AM   #6
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
I couldn't get xorg to work with the nvidia drivers.It gave me some crap about not being able to use 16 or 24 bit color depth and that is necessary for glx to load.Works fine with xfree though.I'd give xfree a spin and see how that goes.
 
Old 09-30-2004, 01:02 PM   #7
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Original Poster
Rep: Reputation: 30
Thank you everyone for your replies.

I hate to say this but it was a simple driver problem. I assumed that the portage
drivers are the latest and greatest, but apparently not. Doing nVidia's self-install
fixed it. Hallelujah! Now I just need to get alsa to work with multiple devices at
once.

Paul
 
Old 09-30-2004, 11:50 PM   #8
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
Quote:
Originally posted by crashmeister
I couldn't get xorg to work with the nvidia drivers.It gave me some crap about not being able to use 16 or 24 bit color depth and that is necessary for glx to load.Works fine with xfree though.I'd give xfree a spin and see how that goes.
I had that same exact problem just the other day and I reinstalled the driver using the nvidia self install program , changed the driver to nivdia in xorg.conf and it fixed that, and now the nvidia drivers are working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia drivers freeze whatpot Linux - Hardware 2 04-09-2005 08:28 AM
firefox makes system freeze when amule is running granth Slackware 24 04-04-2005 09:06 PM
Nvidia drivers freeze system push Linux - Newbie 12 10-18-2004 07:51 PM
NVidia 3Dcard makes my system crash Boudewijn Linux - Hardware 1 12-09-2003 03:31 AM
Doing "make" command makes system freeze weiss Linux - Newbie 16 10-09-2003 08:26 AM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration