LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   nvidia driver configuration not possible: my xorg.conf (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-driver-configuration-not-possible-my-xorg-conf-615268/)

riccisit 01-21-2008 02:51 PM

nvidia driver configuration not possible: my xorg.conf
 
Hi all,

under OpenSuse 10.2 I installed NVIDIA drivers successfully and activated compiz. Everything works fine, except when launchng the Nvidia configuration app. There I receive this alert:

- You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. -

I did it, but nothing happens, still I get this message. I don't know what to do, even if I suppose that Nvidia is actually recognized, because the graphic is slightly better than before, I receive the Nvidia splash screen and I can have compiz. But I can't set brightness and so on without that app.

I post the xorg.conf ;)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Dec 13 19:09:35 PST 2007

# /.../
# SaX generated X11 config file
# Created on: 2008-01-14T15:21:44+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "USB Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse[3]"
Driver "synaptics"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "HorizScrollDelta" "0"
Option "InputFashion" "Mouse"
Option "Name" "Synaptics;Touchpad"
Option "Protocol" "explorerps/2"
Option "SHMConfig" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
ModeLine "1280x800" 69.8 1280 1328 1360 1440 800 803 809 823 +hsync -vsync
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "SEC"
ModelName "SAMSUNG LCD MONITOR"
UseModes "Modes[0]"
DisplaySize 331 207
HorizSync 30.0 - 62.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVidia"
BoardName "GeForce Go 6150"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
EndSection

rednuht 01-21-2008 04:26 PM

run
Code:

glxinfo
if you get a few lines that do not mention nvidia then you are not running nvidia drivers if it gives you loads of output plus a line at the top
Quote:

server glx vendor string: NVIDIA Corporation
then you can be sure you are running the NVIDIA drivers

riccisit 01-22-2008 01:27 PM

No, it shows server glx vendor string : SGI

while some lines below it says client glx vendor string: NVIDIA corporation

Uhm? Any idea?

rednuht 01-22-2008 05:01 PM

when I have had problems with a distrobutions NVidia implimentations in the past I have gone straight to nvida.com and followed the links to download their latest version.
Should give a more definative "its now installed and working" result.
Let us know how you get on.

ice60 01-22-2008 05:03 PM

i think it's a problem with Xgl, i've got the same problem, i tried uninstalling Xgl and the nvidia-settings worked, but the composite stuff didn't lol. i might try using AIGLX instead.

i just found this -
can't post this URL either, eventhough it's to this site lol

it says you can change the settings with this -
/opt/gnome/bin/gnome-xgl-settings

i clicked on the Sax button and nothing happened!

here's some stuff about AIGLX if you want it -
i can't post urls to other sites, i'm not allowed with my first post.

ice60 01-22-2008 05:05 PM

http://forums.suselinuxsupport.de/in...3&#entry249133

http://en.opensuse.org/AIGLX

http://www.linuxquestions.org/questi...errerid=195877


All times are GMT -5. The time now is 10:56 PM.