LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Nvidia and Intel cards issue in Debian (http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-and-intel-cards-issue-in-debian-817473/)

nicogarcia 07-01-2010 01:40 PM

Nvidia and Intel cards issue in Debian
 
Hello,

I have two video cards, an Intel GMA3000 and an NVidia 8500GT (NV).

My OS is Debian testing.

In the BIOS I can choose one of the cards as primary to see through that card the BIOS screen, GRUB and Debian loading process until GDM.

If I choose the NV card as primary, I see the BIOS screen, GRUB and then I got a Kernel Panic.
Otherwise, choosing the Intel VGA in the BIOS and keeping the Monitor plugged to the NV output I don't see anything until GDM, but everything works. (That's how I'm using the PC right now, and what I'm trying to solve)

Does anyone know what is the reason of this problem?
Why does is throw a Kernel Panic?

Looking for a long time in the net I've found a workaround that worked for me in Ubuntu 9.10:

It consisted in adding

Code:

blacklist intel_agp
to /etc/modprobe.d/blacklist.conf file.
But then I couldn't use the Intel card as a secondary monitor.

Now, in Debian, that doesn't work. I've tried with combinations of driver blacklisting:

Code:

blacklist intel_agp
blacklist agpgart
blacklist i915

And running
Code:

update-initramfs -u
after modifying blacklist.conf, but it does not work.

If i try to load intel_agp or agpgart into kernel I got an error because they do not exist. But blacklisting i915 should work as in Ubuntu.

The ideal solution would be to have BOTH cards working. But at least I would like to blacklist the Intel card and use NV as primary without Kernel Panics.

Thank you very much for your help!

Extra information about my pc:
Code:

$ lspci -k

01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8500 GT] (rev a1)
        Subsystem: Micro-Star International Co., Ltd. NX8500GT-TD512EH/M2
        Kernel driver in use: nvidia

00:02.0 VGA compatible controller: Intel Corporation 82946GZ/GL Integrated Graphics Controller (rev 02)
        Subsystem: Intel Corporation Device 5354
        Kernel driver in use: i915

$ uname -a
Linux debian-desktop 2.6.32-5-amd64 #1 SMP Tue Jun 1 04:34:03 UTC 2010 x86_64 GNU/Linux


craigevil 07-03-2010 01:08 AM

Try disabling the Intel kms, http://wiki.debian.org/KernelModesetting

In /etc/default/grub edit the GRUB_CMDLINE_LINUX_DEFAULT= line and change it to

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

While you are in there tinkering you might want to go ahead and disable ipv6. Not that it has anything to do with the problem.
GRUB_CMDLINE_LINUX="ipv6.disable=1"

nicogarcia 07-04-2010 03:01 PM

That didn't work. I'm still getting a kernel panic. I've searched about KMS but didn't found any working solution. I'm totally stucked.

Thanks for your help!

nicogarcia 07-04-2010 03:36 PM

Well.. I've found a workaroud, and now I'm working just like in Ubuntu. I've disabled Intel VGA by adding agp=off to Grub.

GRUB_CMDLINE_LINUX_DEFAULT="agp=off"

However, this is not the real solution, because now I can't use the Intel VGA (for example to dual-head)

I'm still hoping to find the real solution or just a good explanation of the issue :)

Thank you very much!


All times are GMT -5. The time now is 07:59 AM.