LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 02-08-2005, 03:17 AM   #1
astroboiii
Member
 
Registered: Feb 2004
Posts: 83

Rep: Reputation: 15
Nomad Zen Xtra problems =C


i just bought a nomad Zen Xtra and i have been trying to install it for about 4/5 hours now and i simply CANNOT do it......

i've gried gnomad that neutrino program and even kionjb and nothing.
The problem with gnomad is dependencies i've downloaded EVERY gnome dependencie possible but after installing them, it doens't recognize them (even after i've installed them) i've tried including them in my path and still no avail.. maybe i'm not naming them right....?)

kionjb is just smiplyu a mystery as to how i get it working, after installing it the command available make absolutely no sense to me even after reading all the documentation i can possibly find for it....

neutrino won't work for the same reason gnomad won't and i just do not kno what to do . My zen IS being read by the system tho i kno that for sure cuz every time i disconnect/connect it, /var/logs/messages reacts.....

ne suggestions?
 
Old 02-08-2005, 06:46 AM   #2
astroboiii
Member
 
Registered: Feb 2004
Posts: 83

Original Poster
Rep: Reputation: 15
I'm losing my mind..... i've installed over 20 packages just to get gnomad2 working ..... i'm down to libbonoboui,libnomeui......... libglade seems to not want to be *seen* by libbonoboui which is needed by libgnomeui.... up all night hwo created this MESS@)(#@)( =\

condensed version of the error i'm getting when installing linbbonoboui
No package 'libglade-2.0' found
and i have installed libglade a million times...... =\
 
Old 02-08-2005, 07:15 AM   #3
scoops98
Member
 
Registered: Nov 2001
Location: Cornwall
Distribution: Gentoo, Debian,Knoppix
Posts: 85

Rep: Reputation: 15
HI

Wot distro are you using?
I have a creative zen extra working perfectly fine in Mandrake 10.1 Official. I used easy urpmi to get additional sources and then installed Gnomad using that.
Hope this helps
 
Old 02-08-2005, 07:32 AM   #4
astroboiii
Member
 
Registered: Feb 2004
Posts: 83

Original Poster
Rep: Reputation: 15
using slack 10 =\ should've stuck with 9 =\
 
Old 02-08-2005, 07:35 AM   #5
astroboiii
Member
 
Registered: Feb 2004
Posts: 83

Original Poster
Rep: Reputation: 15
basically what's happening is that everything that i eventually get to iworking, ends up not being seen by either PATH or PKG_CONFIG_PATH and ends up fucking the next dependency i try to install... i've gone throgh a million dependencies just to get gnomad to run... =\
 
Old 02-08-2005, 08:47 AM   #6
astroboiii
Member
 
Registered: Feb 2004
Posts: 83

Original Poster
Rep: Reputation: 15
somehow i installed everything but the make for gnomad gives me erros =\

root@h0me:~/progz/gnomad/gnomad2-2.6.2# make
Making all in src
make[1]: Entering directory `/root/progz/gnomad/gnomad2-2.6.2/src'
if gcc -DPACKAGE_NAME=\"gnomad2\" -DPACKAGE_TARNAME=\"gnomad2\" -DPACKAGE_VERSION=\"2.6.2\" -DPACKAGE_STRING=\"gnomad2\ 2.6.2\" -DPACKAGE_BUGREPORT=\"http://sourceforge.net/tracker/\?func=add\&group_id=65573\&atid=511470\" -DPACKAGE=\"gnomad2\" -DVERSION=\"2.6.2\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DGETTEXT_PACKAGE=\"gnomad2\" -DHAVE_LOCALE_H=1 -DHAVE_LC_MESSAGES=1 -DHAVE_BIND_TEXTDOMAIN_CODESET=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -DENABLE_NLS=1 -DGNOMADLOCALEDIR=\"/usr/local/share/locale\" -DHAVE_DIRENT_H=1 -DSTDC_HEADERS=1 -DHAVE_MALLOC_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_FCNTL_H=1 -DHAVE_CHDIR=1 -I. -I. -pthread -DORBIT2=1 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/local/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/local/include/libbonoboui-2.0 -I/usr/include/libxml2 -I..//root/progz/gnomad/libbonobo-2.8.0/bonobo/.. -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/libgnome-2.0 -I/usr/local/include/libgnomecanvas-2.0 -I/usr/local/include/orbit-2.0 -I/usr/local/include/gnome-vfs-2.0 -I/usr/local/lib/gnome-vfs-2.0/include -I/usr/local/include/bonobo-activation-2.0 -I/usr/local/include -DPREFIX=\"/usr/local\" -DSYSCONFDIR=\"/usr/local/etc\" -DDATADIR=\"/usr/local/share\" -DLIBDIR=\"/usr/local/lib\" -DPIXMAPSDIR=\""/usr/local/share/pixmaps"\" -g -O2 -MT gnomad2.o -MD -MP -MF ".deps/gnomad2.Tpo" -c -o gnomad2.o gnomad2.c; \
then mv -f ".deps/gnomad2.Tpo" ".deps/gnomad2.Po"; else rm -f ".deps/gnomad2.Tpo"; exit 1; fi
gnomad2.c:26:35: libgnomeui/libgnomeui.h: No such file or directory
gnomad2.c: In function `create_select_jukebox_dialog':
gnomad2.c:103: error: `GNOME_STOCK_BUTTON_OK' undeclared (first use in this function)
gnomad2.c:103: error: (Each undeclared identifier is reported only once
gnomad2.c:103: error: for each function it appears in.)
gnomad2.c:104: error: `GNOME_STOCK_BUTTON_CANCEL' undeclared (first use in this function)
gnomad2.c:105: warning: assignment makes pointer from integer without a cast
gnomad2.c:122: error: invalid type argument of `->'
gnomad2.c:125: error: invalid type argument of `->'
gnomad2.c: In function `about_box':
gnomad2.c:199: warning: assignment makes pointer from integer without a cast
gnomad2.c: In function `scan_jukebox':
gnomad2.c:226: error: `GNOME_STOCK_BUTTON_CANCEL' undeclared (first use in this function)
gnomad2.c:227: warning: assignment makes pointer from integer without a cast
gnomad2.c:232: error: invalid type argument of `->'
gnomad2.c: In function `set_jukeboxowner_dialog':
gnomad2.c:269: error: `GNOME_STOCK_BUTTON_OK' undeclared (first use in this function)
gnomad2.c:270: error: `GNOME_STOCK_BUTTON_CANCEL' undeclared (first use in this function)
gnomad2.c:271: warning: assignment makes pointer from integer without a cast
gnomad2.c:282: error: invalid type argument of `->'
gnomad2.c:288: error: invalid type argument of `->'
gnomad2.c: In function `add_to_dialog':
gnomad2.c:295: error: invalid type argument of `->'
gnomad2.c: In function `information_dialog':
gnomad2.c:313: error: `GNOME_STOCK_BUTTON_OK' undeclared (first use in this function)
gnomad2.c:314: warning: assignment makes pointer from integer without a cast
gnomad2.c: In function `main':
gnomad2.c:478: error: `GnomeProgram' undeclared (first use in this function)
gnomad2.c:478: error: `gnomad' undeclared (first use in this function)
gnomad2.c:507: error: `LIBGNOMEUI_MODULE' undeclared (first use in this function)
gnomad2.c:508: error: `GNOME_PARAM_POPT_TABLE' undeclared (first use in this function)
gnomad2.c:509: error: `GNOME_PROGRAM_STANDARD_PROPERTIES' undeclared (first use in this function)
gnomad2.c:531: warning: assignment makes pointer from integer without a cast
make[1]: *** [gnomad2.o] Error 1
make[1]: Leaving directory `/root/progz/gnomad/gnomad2-2.6.2/src'
make: *** [all-recursive] Error 1


could be becaues i got the rest of them (dependencies) to barley install..? fuck it this zen is for windows only as far as i'm concerned.. if i try neutrino.. it says glib says the version on ur compuer is 2.6.2 but FOUND 2.4.2!..... and quits... so fuck that shit =\
 
Old 08-15-2005, 04:52 PM   #7
gilesrsmith
LQ Newbie
 
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
I am pretty new to linux and am using ubuntu, i have gnomad2 working but it won't recognise my zen xtra. if it is connected it get : "could not open jukebox" and if it isn't i get "no jukebox connected to USB bus" so it knows it is there but can't read it.

any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I wonder if there's any way to install Linux on a Zen Xtra. EOHooligan Linux - General 2 03-12-2005 11:35 PM
Zen Micro Gnomad2 problems gungner Linux - Hardware 0 02-24-2005 03:10 PM
the zen browser and some weird lib problems kersten78 Slackware 6 01-08-2005 08:21 AM
Nomad Zen Xtra Straterra Linux - Hardware 3 04-13-2004 09:57 AM
hotplugging with creative nomad zen jukebox terence Linux - Hardware 0 02-13-2004 04:03 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration