LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-08-2006, 09:44 PM   #1
claudeyu
LQ Newbie
 
Registered: Jun 2006
Posts: 4

Rep: Reputation: 0
No soundcard detected on my onboard Riptide PCI Audio Controller chip


I was running Mandrake Linux 2006 distrbution(free) consisting of 3 disks
>> without great problem except without
>> sound. Dual-boot option with Window Xp Prof smoothly. But after
>> installed it gives no sound in Linux. But there
>> is no sound problem in Window Xp Prof.
>> I need your advice.
>>
>>
>> I am giving you the following info:
>>
>>
>> My desktop specs:
>>
>> HP Pavilion Celeron 466Mhz 128MB DIMM
>> sound hardware on board
>> video graphic onbaord
>> Hdd 40GB
>>
>> $lsmod
>>
>> indicated no snd-x drivers installed
>>
>>
>>
>> $cat /proc/asound/version
>>
>> showed Alsa version installed
>> Advanced Linux found Architecture Driver Version 1.0.9b
>>
>>
>>
>>
>> $ cat / proc/asound/cards
>>
>>
>> ---showed no sound card----
>>
>>
>>
>> When Linux bootup, building processes showed 2 errors in [FATAL] flags
>>
>> 1. Starting ALSA version 1.0.9b: (riptide) start servicce sound
>> (Y)/(N)/(C) ? (Y)
>> Loading sound module(snd-riptide) FATAL: Module snd-riptide not found
>> Fatal: Error running install command for snd-riptide [Fatal]
>>
>>
>> Alsactl: save-state:1163:No soundcards found...
>>
>> Can't open /root/tmp/asound.state-tmp: No such file or directory [Fatal]
>>
>>
>>
>>
>>
>> Tried using Mandrake Control Center auto-hardware detection showed sound
>> information as:
>>
>> Name: Riptide Audio Device
>> showed driver used: snd-riptide
>> However, Linux returned with error while initialising the sound driver:
>>
>> Device /dev/dsp can't be opened( no such file or directory)
>>
>> When inspecting /dev there sn't any dsp file existed.
>>
>>
>>
>> $lspci |grep -i audio
>> showed audio controller Rockwell International Riptide PCI Audio
>> Controller
>>
>>
>>
>> I have also tried to download; alsa-driver-0.4.1e.tar.gz
>> alsa-lib-0.4.1d.tar.gz and alsa-utils-0.4.1.tar.gz and followed
>> instruction to install.
>> But met error while installing alsa-lib-0.4.1d ./configure :
>> configure:error:install alsa-driver-v0.30pre5+package first...
>> However i tried to look for v0.30 on your ftp site not found this
>> version.
>>
>>
>>
>> Furthermore, i could not locate the exact manufcaturer of soundcard in
>> your Alsa sound card driver pages so cannot really load the right
>> driver. What should I do?
>>
>>More info:

#lspcidrake -v/fgrep AUDIO
returned: Rockwell SemiconductorsSystem/Master Riptide PCI Audio
Controller(Multimedia Audio)

#grep sound-slot/etc/modprobe.conf
returned: alias sound-slot-0 snd-riptide

#/sbin/lsmod
returned: snd-riptide not loaded but only snd-0


#chkconfig --list sound
returned: sound service is configured to be run in init-level 3 sound 3:ON

#chkconfig --list alsa
returned: alsa 3:ON

#find /lib/modules/ -name snd-riptide\*
it returned nothing. I saw there is only 2.6.12-12mdk in that directory.

In addition, I used #modprobe snd-riptide
returned : Module snd-riptide not found

>>
>> Lastly the bottom line is the system could not detect a soundcard.--- it
>> always showed no soundcard found.
>>
>> Pls suggest ways of fixing this problem and thanks in advance.

>>
>>

Last edited by XavierP; 06-11-2006 at 02:07 PM.
 
Old 06-11-2006, 02:07 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Moved: This thread is more suitable in Linux-Hardware and has been moved accordingly to help your thread/question get the exposure it deserves.
 
  


Reply

Tags
detect, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marvell Yukon 88E8036 pci-e fast ethernet controller not being detected in Fedora 3 ozzie_penguin Linux - Laptop and Netbook 2 01-02-2006 03:06 PM
Getting CD audio through PCI soundcard NOT motherboard soundcard HalfDiminished Debian 0 01-11-2005 06:59 AM
PCI soundcard not detected (emu10k1, linux 2.6.9, slackware) Ben2210 Linux - Hardware 0 11-06-2004 12:36 PM
Slackware 10.0 and AK75-EC VIA PCI Audio Controller Zxn Linux - Newbie 1 07-12-2004 10:44 PM
Audio driver for Gigabyte GA8IK1100's onboard sound chip? TMMO Linux - Newbie 1 08-10-2003 04:59 PM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration