LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound with a CM8738 sound card -- alsa installed (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-with-a-cm8738-sound-card-alsa-installed-172224/)

istar80 04-19-2004 05:42 PM

No sound with a CM8738 sound card -- alsa installed
 
Hello,

I have installed Mandrake 9.2 on an 800 MHz PC and pretty much configured everything but sound -- I can't get a single sound, either out of the CD player or the operating system :( .

As far as I can tell, mandrake has detected my sound card (C- Media CM8738) and is using the alsa emulation driver, snd-cmipci. Here's what I get from mcc (HardDrake) :

Manufacturer: C-Media Electronics Inc

Alternative drivers: cmpci

Bus: PCI

Port ID Number: 13f6:111

Channel Position: 0:d:0

Description: CM8738

Module: snd-cmipci

Medium Class: MULTIMEDIA_AUDIO

When I hit "Module Configuration" I am confronted with a window where I have to fill in some parameters: index, id, enable, mpu_port, fm_port and soft_ac3 , in case it rings a bell :) . Am I supposed to fill these in manually? If yes, where can I find the appropriate specifications for my card?

I have downloaded the latest version (1.0.4)of ALSA drivers, libs and utilities from the alsa-project webpage and installed everything by the book. I then ran alsaconf and got a message that my sound card was properly installed, unmuted all volumes in alsamixer and restarted my PC, but still no sound. (Also, the startup messages report initializing alsa 0.9.6, even though I installed alsa 1.0.4. Weird...)

Could someone pls help me? This is getting very frustrating. I had previously installed Mandrake 9.2 on an old laptop and Red Hat 9 on another desktop PC, both with success AFA sound is concerned - without as much as a manual configuration. So, I'm somewhat of a newbie.

Could it be that my sound card is not supported? The alsa project page says it is. So... anyone with the same problem?

Thanks in advance.

keldorne 06-17-2005 02:02 PM

reply
 
hi, i'm french so sorry if i speak badly
i've the same sound card that you, i found a driver in http://telecharger.com i read the readme it says you have to recompilate the fichier and replace ... i don't know explictions.
Who could help me


All times are GMT -5. The time now is 01:00 AM.