LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   no sound when playing cd from drive (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-when-playing-cd-from-drive-261548/)

dr_zayus69 12-01-2004 09:09 PM

no sound when playing cd from drive
 
im running fedora core 2 and the program that autoruns the music cds will not play the sound for the cds. I checked the preferences for the player and it is pointed to the right drive. Does anyone have a clue how i might fix this?

ringwraith 12-01-2004 11:21 PM

YOu might include the name of the app you are dealing with. Can you set the input and output for the app? As an example in xmms I have to set the input to digital audio extraction.

ror 12-01-2004 11:25 PM

Do you have the wire going from your CD drive to your sound card?

dr_zayus69 12-01-2004 11:52 PM

Quote:

Originally posted by ringwraith
YOu might include the name of the app you are dealing with. Can you set the input and output for the app? As an example in xmms I have to set the input to digital audio extraction.
I th ink the app is just called CD Player. Im using Gnome in Fedora Core 2. The configure page of the app is pretty bare. you bascailly chose the location of the drive. Pick a theme and can check boxes tthat deal with ejecting the disc.

walker 12-02-2004 10:34 AM

CDPlayer for Gnome & KSCD for KDE couldn't extract digital audio from cd so if the drive where you inserted the cd isn't plugged to motherbord cd-in connector via audio cable you'll never ear nothing.
(How have correctly reply ror "Do you have the wire going from your CD drive to your sound card?")
This is the first issue to check!!

Sometimes could be the system that use the wrong driver for your audio device!
Start xmms (you should have it installed) and try to play an mp3.
Sorry I've forgot that fedora doesn't support mp3 playing!
Try with an .ogg file (A free compressed format) or install xmms-mp3 plugin for the xmms release you've got!

If you can hear it the system use the correct driver and we fall back to the first question!
"Do you have the wire going from your CD drive to your sound card?"

If you're scare to open your case to verify this or you're not able to do this I don't know what to tell you!

I'll repeat it another time! CDPlayer & KSCD could play only analogic audio input!!
I'd be very happy to know why by KDE or Gnome developers!!

Ther's a third way leave let fuc.... the integreted player and use xmms to play cd
simple by installing the xmms-cdread plugin.

Let me know what you want to do and i'll teach you hou to configur the plugin properly.

cheers
Walker

dr_zayus69 12-02-2004 02:26 PM

i use mplayer, but i just installed xmms. I haven't checked to see if it is hooked up to the motherboad but i will then post back. When i changed the drives i don't remember an audio cord plugged in it. It was just the ribbon and the power supply. I don't really care for the CD Player autoplaying and didn't see a preference to switch that off. is there a way to config that?

walker 12-02-2004 04:42 PM

If you want to play cd in Linux with CDPlayer or KSCD you need absolutely to connect cd drive to cd-in on mobo for the reason have explained before.

If you've installed xmms-cdread plugin do this:

right click over xmms then select Option | Preferences | I/O Audio plugin then select the input plugin named CD Audio Player (libcdaudio.so) (sorry but I don't use english locale so it should be a little different but this part - (libcdaudio.so) - don't change!) then click Configure

you should see two tabs the first one named Device

in the first line insert /dev/cdrom or /dev/scd0 (it depends on the driver your system us ide or ide-scsi)
or whatever is your cd device named

in the other line the mount point of cd device for example /mnt/cdrom

then check extract digital audio

if you've got another cd drive choose add device (or however its named the button to add another device) and repeat the steps above - device name and mount point of the second unit - then save config with OK button the plugin config windows closes than in preferences windows click Apply and OK to save.

Now you could play all the music you want using right click over xmms | Play file in a directory | choose from the tree that appears the mount point of the device where you've inserted the cd to play.

To turn off autoplay in Nautilus (I suppose you use it as file manager) I don't now exactly how you can do, I use IceWM instead of Gnome or KDE (I prefer light weigth wm!!) but you can try with gnome configuration utility.

Let me now!
walker
hope to be helpful

walker 12-02-2004 05:03 PM

Just a note!
I don't want to force no one to use xmms simply it's the only way to play cdda in Linux even if you've got more than one cd drive (mobo has only one cd-in plug) and in this way you don't need at the same time to open the case.
cheers
walker

dr_zayus69 12-02-2004 05:09 PM

thanks i followd your directions and that did the trick. When i opend the box i didn't find a audio cable so i am going to look into getting one of those cuz i assume it will come in handy

walker 12-02-2004 05:15 PM

If you use xmms to play cd you don't need an audio cable anymore!
For the reason it extracts direct digital audio by itself!!
:D

ror 12-02-2004 06:02 PM

But surely that ties up more system resources?

cyber-worx 12-02-2004 09:17 PM

Just a note: mplayer can play straight from the disk also (ie without the cable): probs slightly less system overhead.


All times are GMT -5. The time now is 05:50 AM.