LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 07-16-2012, 05:25 PM   #1
Hunty6
LQ Newbie
 
Registered: Jul 2012
Posts: 10

Rep: Reputation: Disabled
No sound using flash? (Linux Mint 13 (MAYA))


I've been stuck with this problem for 2 days now, and I have had it before. I do not have sound coming from flash (so youtube videos, most likely) and can't seem to find how to fix it. I've been messing with the alsa settings, I've tried the mixer too, nothing is muted.

I had this problem on Kubuntu 11.10 too, where it would stop randomly and wouldn't come back until I rebooted my computer. At least I could get sound on there.

Now i'm running Mint 13 (Maya) and it seems like my sound's gone for good. Seems like it's a problem with flash, and that it's a common problem for Asus users (which is my case).

I am running an Asus G51J.

Here's my lspci output (I have 2 sound devices) :

Code:
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GT215 [GeForce GTS 360M] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
06:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
06:00.1 System peripheral: Ricoh Co Ltd Memory Stick Host Controller (rev 01)
06:00.2 System peripheral: Ricoh Co Ltd Device e852 (rev 01)
06:00.3 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 PCIe IEEE 1394 Controller (rev 01)
07:00.0 Ethernet controller: Atheros Communications Inc. AR8131 Gigabit Ethernet (rev c0)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
 
Old 07-17-2012, 10:13 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
which sound device do you want?

you can create an "index" to force it to index=o for your preferred device or blacklist the naughty sound module

2) post the output to

aplay -l

also run

alsamixer

post the image of it

then press F6 to select the other device and post it as well
 
Old 07-17-2012, 12:50 PM   #3
Hunty6
LQ Newbie
 
Registered: Jul 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Any device that will give me sound I believe there is no difference as the only use I make out of it is watch videos and listen to music, so the Intel one could be good.

Here's what you asked for :

Code:
maxime@maxime-G60JX ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC663 Analog [ALC663 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC663 Digital [ALC663 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1 Subdevice #0: subdevice #0

and the alsa mixer pictures:
Capture.png

Capture-1.png

Thanks a lot for replying
 
Old 07-17-2012, 07:04 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
ok how do you get sound out?

if headphone....the first image shows auto-mute ......that means if you had speakers as well....they are supposed to mute when you plug in headphones

so if you use internal speaker or external speaker leader....for the moment ....go to automute and press the up or down arrow to "disable" or turn off auto-mute function.....the exact word may differ for you....but you know what I mean ok

also keep the world simple.....go back to second device and press m to mute all spdif devices please

2) on your panel you have a speaker icon.....whats the icon between it and the green tick icon?

3) if you have an hdmi cable.....I believe you need to turn off then on the spdif.....works for some

if you have normal 3.5 mm speaker external leader ....then turn off spdif in second device and on first device

if you have spdif out...it should work already

4) if the speaker cable goes into the line jack....first image shows line out is muted so try unmuting it

5) if you are using an internal speaker.....internal speaker is showing as muted and volume down so press m and page up to raise pls

I am not sure why you have TWO internals but if you want to hear any sound its worth trying all?

good luck
 
Old 07-18-2012, 12:04 PM   #5
Hunty6
LQ Newbie
 
Registered: Jul 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by aus9 View Post
ok how do you get sound out?

if headphone....the first image shows auto-mute ......that means if you had speakers as well....they are supposed to mute when you plug in headphones

so if you use internal speaker or external speaker leader....for the moment ....go to automute and press the up or down arrow to "disable" or turn off auto-mute function.....the exact word may differ for you....but you know what I mean ok

also keep the world simple.....go back to second device and press m to mute all spdif devices please

2) on your panel you have a speaker icon.....whats the icon between it and the green tick icon?

3) if you have an hdmi cable.....I believe you need to turn off then on the spdif.....works for some

if you have normal 3.5 mm speaker external leader ....then turn off spdif in second device and on first device

if you have spdif out...it should work already

4) if the speaker cable goes into the line jack....first image shows line out is muted so try unmuting it

5) if you are using an internal speaker.....internal speaker is showing as muted and volume down so press m and page up to raise pls

I am not sure why you have TWO internals but if you want to hear any sound its worth trying all?

good luck
Alright, so I disabled automute, muted all spdif on the 2nd device. I am not currently using an HDMI cable, but I might use one and will need an audio output to my TV. My computer's a laptop, so I am using the built-in speakers on it. The Icon between the sound icon and the update manager icon is the bluetooth one.

As I said, I have no problem using alsa, and even tho my sound is all the way up on the lines I get no sound out of my speakers but only when I am using flash. Also, my mic isn't muted, my mic sound is, so that means if I turn the volume up on the ''internal'' at the end of the first pictures, all it does is give me sound from my microphone.

The problem isn't in the sound settings, it's something related to flash, I am pretty sure.
 
Old 07-23-2012, 10:07 PM   #6
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
I can verify this. all settings are fine. it is only the browser that doesnt have sound. It is not my computer, so i am unable to troubleshoot immediately, but im going to install mint 13 on another computer here and see if i can sort it out. im only responding to let the OP know he is not alone.
 
Old 07-24-2012, 05:00 AM   #7
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
edong23

well it some ways thats good that someone has the same problem.

so relative to you, have you attempted at any stage to install or (is already installed) pulseaudio?

b) have you tried any different web browsers?

c) I am not trying to force you, but you can download firefox and not install it, and run it from your home directory

I ask in case this is not a sound issue per se.....but a package issue by the maintainer not symlinking the plugins

2) So can you post where your plugin are pls....I am on debian and use non-free adobe but that will change soon

/usr/lib/browser-plugins/libflashplayer.so
 
Old 07-24-2012, 07:00 AM   #8
dhruvats
LQ Newbie
 
Registered: Jun 2012
Location: Bangalore,India
Distribution: Linux Mint 13 XFCE,Windows XP
Posts: 29

Rep: Reputation: Disabled
I remember reading somewhere about the need for installing a pulse-audio package for enabling sound with Flash. Not sure though.
 
Old 07-24-2012, 09:30 AM   #9
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
hmm ok well in a new web page show us your version of flash pls

aboutlugins

if you are using non-free you may need to go to
http://www.adobe.com/software/flash/about/

2) you may have just the lib file installed and not pulse configured.....fingers crossed

what does

Code:
dpkg -l | grep pulse*
show pls....command can run as local user

---------- Post added 24-07-12 at 22:30 ----------

hmm ok well in a new web page show us your version of flash pls

aboutlugins

if you are using non-free you may need to go to
http://www.adobe.com/software/flash/about/

2) you may have just the lib file installed and not pulse configured.....fingers crossed

what does

Code:
dpkg -l | grep pulse*
show pls....command can run as local user
 
Old 07-24-2012, 09:31 AM   #10
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
grrr double post thats

Code:
about:plugins
in case it displays smileys
 
Old 07-25-2012, 12:16 AM   #11
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
ok.. i figured it outish. We arent certain which step did it, so ill give you the jist of all of them. first make sure these packages are installed:

pulseaudio libao4 paprefs libpulse-mainloop-glib0 pulseaudio-module-jack pavucontrol pulseaudio-module-hal pulseaudio-module-x11 gstreamer0.10-pulseaudio pulseaudio-utils libasound2-plugins paman pulseaudio-module-gconf libgconfmm-2.6-1c2 libpulse-browse0 pavumeter libglademm-2.4-1c2a pulseaudio-esound-compat libpulse0 libpulse-dev pulseaudio-module-bluetooth pulseaudio-module-zeroconf

we then uninstalled whatever the default flash player was, and installed the "official" one, which was the adobe-flash-installer.

once this was done, create a file called /etc/asound.conf and paste this into it:
Code:
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
after this, delete the ~/.pulse folder, it will be recreated.
then sound worked in firefox. now then, im not certain which steps are not needed and being as this computer is 80 miles away from me, it is difficult for me to poke further, however, ill watch this thread and if this doesnt work, let me know and ill gain access again and we can look further. good luck!

--edit--
before trying sound in firefox/flash, killall -9 pulseaudio it will restart.

Last edited by edong23; 07-25-2012 at 12:18 AM. Reason: add something
 
Old 07-26-2012, 09:30 PM   #12
Hunty6
LQ Newbie
 
Registered: Jul 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks a lot for at least trying to fix the problem! Looks like I've got some of these packages missing, as it says some of them have been declared obsolete but another one is replacing it...

Any chances you could give me some shell commands or anything to try and do that workaround (I am not very experienced with linux yet)

Thanks
 
Old 07-27-2012, 05:00 AM   #13
dhruvats
LQ Newbie
 
Registered: Jun 2012
Location: Bangalore,India
Distribution: Linux Mint 13 XFCE,Windows XP
Posts: 29

Rep: Reputation: Disabled
There is pretty stable alternative to Adobe Flash player in Linux.
It is called Lightspark.
Home Page: http://lightspark.github.com/

How to install in Ubuntu:
http://www.unixmen.com/lightspark-0-...nt13-fedora17/

Lightspark looks promising for day to day use for viewing flash.

Before installing, make sure that the Adobe Flash plugin is not in use or better uninstall it using:
1. In Terminal,go to folder, '/usr/lib/browser/mozilla/plugins' i.e.,
Quote:
cd /usr/lib/browser/mozilla/plugins
2. Remove the file "libflashplayer.so" i.e.,
Quote:
sudo rm libflashplayer.so
3. Then install Lightspark using the steps mentioned in the second link above.

Last edited by dhruvats; 07-27-2012 at 05:06 AM.
 
Old 07-27-2012, 05:37 AM   #14
dhruvats
LQ Newbie
 
Registered: Jun 2012
Location: Bangalore,India
Distribution: Linux Mint 13 XFCE,Windows XP
Posts: 29

Rep: Reputation: Disabled
Ignore my previous post if you want to still use Adobe Flash itself.
Go through this link :http://forums.linuxmint.com/viewtopic.php?f=196&t=96208
Install the libasound2 package using
Quote:
sudo apt-get install libasound2-plugins
After installing restart the Firefox and check.

In general, the Adobe Flash player performance in Linux is not up to the mark as compared to Windows. My laptop with Nvidia card easily overheats up to 110-120c where 120c is my NVIDIA card's threshold temperature.
 
Old 07-27-2012, 08:43 AM   #15
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
@Hunty6:

just break them up into multiple "apt-get install bla bla" commands. that should help you. we had the same problem. when you see the offending package, skip it or do what it says to install the alternative. give it a shot.

@dhruvats:

i believe this issue is different. running ff in a terminal shows no errors. the issue is with pulse for certain.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux Mint 13 “Maya” Xfce RC released! LXer Syndicated Linux News 0 07-01-2012 06:31 AM
LXer: A Beginner's Guide to Linux Mint 13 Maya LXer Syndicated Linux News 0 06-21-2012 12:20 PM
LXer: Linux Mint Maya vs. Windows 8! LXer Syndicated Linux News 0 06-03-2012 08:30 PM
linux mint 13 maya cannot connect to internet! pablo.b Linux - Newbie 4 05-28-2012 04:51 PM
LXer: Linux Mint 13 Will Be Named Maya LXer Syndicated Linux News 0 04-19-2012 05:30 PM


All times are GMT -5. The time now is 08:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration