LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound through inboard HDMI on Fedora 12 with proprietary NVIDIA video driver (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-through-inboard-hdmi-on-fedora-12-with-proprietary-nvidia-video-driver-824449/)

rcx11 08-05-2010 05:31 PM

No sound through inboard HDMI on Fedora 12 with proprietary NVIDIA video driver
 
Under Fedora 12, I have installed the proprietary NVIDIA graphics driver successfully and am now attempting to use the onboard HDMI output. (The board has HDMI and VGA out built in.) I am getting a clear picture on the TV screen, although the edge of the screen output hangs off all edges of the physical screen. The HDMI audio output is being detected, but no sound come out of the TV when I switch the sound output from the Analog Sterio Duplex to HDMI Output in the Sound Preferences. Any suggestions, and what further information is required?

aus9 08-05-2010 06:55 PM

hi

I do not have your hw but wonder if its a index issue as you are likely to have more than one sound device?

http://sidux.com/index.php?module=Wi...MultipleAlsaEn

and general checks
http://sidux.com/index.php?module=Wikula&tag=NoSound

rcx11 08-06-2010 04:48 PM

I ran the checking commands from the associated links you gave:

$ cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0x80000000 irq 21

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 2: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

Any suggestions?

John VV 08-06-2010 05:36 PM

did you also REINSTALL all of mesa ( including the -devel's ?
Code:

yum search mesa
yum install mesa*

there are about 10 packages
the nvidia.run driver OVERWRITES the mesa that fedora uses

this is very well documented
also did you blacklist the open nouveau driver( this is a MUST for the .run and akmod-nvidia )
see the fedora nvidia install guide
"F13, F12 & F11 Nvidia driver guides"
http://forums.fedoraforum.org/showthread.php?t=204752

as to sound ??
are you using "pulse-audio" ? the fedora default?
you might need to uninstall it and install alsa
see the fedora docs
http://docs.fedoraproject.org/en-US/index.html

rcx11 08-11-2010 10:43 AM

I just ran "yum install mesa*". I knew nothing about ./NVIDIA* overwritting some files. Nouveau is blacklisted as well as having nomodeset in the list of kernel startup arguments. What should I do now?

Can you be more specific on the audio issues? How do I check on which I'm using? Where exactly do I look in the docs?

John VV 08-11-2010 01:50 PM

Quote:

knew nothing about ./NVIDIA* overwritting some files
it is plastered all over the fedeoraforum
there are two regular posters that this IS A VERY BIG issue for so it is mentioned all the time ( I am one of them )

rcx11 08-14-2010 02:19 PM

What I meant is that I knew nothing about this before the statement here. I never looked at the fedoraforum. I only needed to figure out the "nomodeset' argument prior to now. Anyway, could someone please answer the previously mentioned questions?

aus9 08-18-2010 05:09 AM

hi

well you haven't answered if you are using pulse either ok?

It appears you have only one sound device, do you agree?

2) according to my eyesight I can not see your hw in
http://www.kernel.org/doc/Documentat...figuration.txt

maybe we need to look at your results for

Code:

lsmod | grep snd
3) in the meantime can you consider running this script can posting link?

also you can double post on other forums that are not LQ domain

http://www.alsa-project.org/alsa-info.sh

rcx11 08-20-2010 10:24 AM

One of my previous questions was how to check whether or not I'm using pulse audio. I don't know/remember where it's stated.

Output:

Code:

# lsmod | grep snd
snd_hda_codec_nvhdmi    3198  1
snd_hda_codec_realtek  197437  1
snd_hda_intel          20081  2
snd_hda_codec          59881  3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              4868  1 snd_hda_codec
snd_seq                42765  0
snd_seq_device          5031  1 snd_seq
snd_pcm                60824  2 snd_hda_intel,snd_hda_codec
snd_timer              15424  2 snd_seq,snd_pcm
snd                    46298  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore              4863  1 snd
snd_page_alloc          6057  2 snd_hda_intel,snd_pcm

The URL for my alsa-info.sh output is http://www.alsa-project.org/db/?f=d3...6f0a4c77d20b9b

aus9 08-21-2010 09:29 PM

hi

your alsa link shows pulse is running......
!!Sound Servers on this system
!!----------------------------

Pulseaudio:
Installed - Yes (/usr/bin/pulseaudio)
Running - Yes

aRts:
Installed - Yes (/usr/bin/artsd)
Running - Yes

Jack:
Installed - Yes (/usr/bin/jackd)
Running - No


2) and arts running as well....hmmm is that a KDE system?

I suggest you stop arts and pulse and lets get basic alsa fixed first?

I don't know know how you stop services in Fedora but do a search for
asound* and post the results pls

b) kde control panel should have a setting to stop arts

3) If you have kde4 you should have phonon and it needs a backend called
phonon-backend-xine

there are some images here that might assist in configuring phonon
http://sidux.com/index.php?module=Wikula&tag=SndServer

4) your modules for sound appear to be

snd_hda_codec_nvhdmi
snd_hda_codec_realtek
snd_hda_intel
snd_hda_codec


but I am thinking without knowing that maybe you don't need the snd_hda_codec as it appears you have
!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Realtek ALC883


but I am not sure....you could blacklist it and see if you get sound

5) so ignoring the fact that you will stop arts and maybe pulse pls post snapshots of the following command

alsamixer -c 0

this should show the underlying alsa mixer settings before pulseaudio did its stuff in your /etc/alsa/pulse-default.conf


All times are GMT -5. The time now is 12:30 PM.