LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound (SoundMax Integrated Digital Audio) (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-soundmax-integrated-digital-audio-118454/)

giill 11-21-2003 04:19 AM

No sound (SoundMax Integrated Digital Audio)
 
Hi,

I can't get any sound from my laptop. I have installed Mandrake 9.2.
My laptop is a compaq presario 700:
- AMD Duron 900Mhz
- 384Mo Ram
- graphic: S3 Graphic Twister K
- Audio : SoundMax Integratet Digital Audio

Mandrake has "found" 2 drivers by default for my soundcard (via82xxx if I remember well, and another one), but it doesn't work. In fact I've tried to watch a DVD, connecting a headphone to hear the sound. And when I put the sound on max, I heared the sound, but not very very loud...
I've tried to modify the sound computer configuration, but I didn't find anything interesting.
Thanks for your help.

bencl5 11-21-2003 03:11 PM

it's possible you might need to install alsa... another question though, are you able to adjust the volume in a mixer or do you get that nice wonderful error (can't load /dev/mixer).. if you don't mind, maybe try going to the command line, and typing lsmod to list your modules. then post your results on here.

bencl5 11-21-2003 03:13 PM

it's possible you might need to install alsa... another question though, are you able to adjust the volume in a mixer or do you get that nice wonderful error (can't load /dev/mixer).. if you don't mind, maybe try going to the command line, and typing lsmod to list your modules. then post your results on here. it's possible you might have a standard OSS module installed that basically lets you listen to one sound at a time... eitherway, i would do some research on alsa Advanced Linux Sound Architechure and see how you can install that for mandrake.

giill 11-22-2003 01:55 AM

Here is the result of lsmod for sound:

[root@localhost pingui]# lsmod
Module Size Used by Not tainted
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-oss]
snd-seq 42544 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 0
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-via82xx 15360 0
snd-pcm 79588 0 [snd-pcm-oss snd-via82xx]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-ac97-codec 45720 0 [snd-via82xx]
snd-mpu401-uart 4704 0 [snd-via82xx]
snd-rawmidi 17760 0 [snd-mpu401-uart]
snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-page-alloc 9044 0 [snd-via82xx snd-pcm]
snd 41380 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6340 0 [snd]

Hammett 11-22-2003 05:40 AM

I had the same problem, but not with a laptop. What i did is disable de PnP in the BIOS settings and then i was able to hear the sound. BUT i had to plug the speakers to the micro slot instead of the Out one....(really strange).

Hope it helps

HeRCuLeSX 11-22-2003 11:04 AM

Look .. when you download the NEW version of Alsa Drivers you need to downlaod the tools too -- and you know how to comile it...
1) go to the ALSA DRIVER and OPEN the terminal their -- and type
./configure --with-isapnp=yes
make
su
password
make install
after that type : ./snddevices ... Raise the volume and Reboot your machine
its gonna work perfectly


All times are GMT -5. The time now is 03:40 PM.