LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound on MDK9.1 with snd-via82xx chip (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-on-mdk9-1-with-snd-via82xx-chip-133426/)

tryynanen 01-10-2004 11:56 AM

No sound on MDK9.1 with snd-via82xx chip
 
Dear All

Last thursday I got new PC, first one without Windows :) And here is some bases:
Motherboard Asus A7V8X-X with intergrated sound "card" snd-via82xx

Ok, now the problem:

I have now Mandrake 9.1 distribution and there is no sound at all. There are following settings:
snd-via82xx : VIA Technologies|VT8233 [AC97 Audio Controller] [MULTIMEDIA_AUDIO] (vendor:1106 device:3059 subv:1043 subd:80a1)

Alsa :
alsa 0:off 1:off 2:on 3:on 4:on 5:on 6:off


And then default:
alias sound-slot-0 snd-via82xx

Volume -settings.. :

vol 21, 21
pcm 24, 24
speaker 21, 21
line 21, 21, P
mic 21, 21, R
cd 24, 24, P
pcm2 21, 21
igain 21, 21, P
line1 14, 14, P
phin 21, 21, P
phout 14, 14
video 17, 17, P


When look the /sbin/lsmod -place, there is following information :
Module Size Used by Not tainted
udf 90464 0 (autoclean)
sg 34636 0 (autoclean)
autofs4 11540 2 (autoclean)
ipt_TOS 1592 12 (autoclean)
ipt_LOG 4280 5 (autoclean)
ipt_REJECT 3640 4 (autoclean)
ipt_state 1080 11 (autoclean)
iptable_mangle 2712 1 (autoclean)
ip_nat_irc 3280 0 (unused)
ip_nat_ftp 4016 0 (unused)
iptable_nat 21048 2 [ip_nat_irc ip_nat_ftp]
ip_conntrack_irc 4304 1
ip_conntrack_ftp 5200 1
ip_conntrack 27264 4 [ipt_state ip_nat_irc ip_nat_ftp iptable_nat ip_conntrack_irc ip_conntrack_ftp]
iptable_filter 2348 1 (autoclean)
ip_tables 14648 9 [ipt_TOS ipt_LOG ipt_REJECT ipt_state iptable_mangle iptable_nat iptable_filter]
snd-seq-oss 31104 0 (unused)
snd-seq-midi-event 5640 0 [snd-seq-oss]
snd-seq 42608 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43556 1
snd-mixer-oss 14488 0 [snd-pcm-oss]
snd-via82xx 14092 1
snd-ac97-codec 40160 0 [snd-via82xx]
snd-pcm 77536 0 [snd-pcm-oss snd-via82xx]
snd-timer 18376 0 [snd-seq snd-pcm]
snd-mpu401-uart 4396 0 [snd-via82xx]
snd-rawmidi 17600 0 [snd-mpu401-uart]
snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-page-alloc 7732 0 [snd-via82xx snd-pcm]
snd 40868 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-via82xx snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6276 0 [snd]
nfsd 74256 0 (autoclean)
af_packet 14952 1 (autoclean)
ip_vs 83192 0 (autoclean)
sr_mod 16920 0 (autoclean)
floppy 55132 0
via-rhine 15056 1 (autoclean)
mii 3832 0 (autoclean) [via-rhine]
nls_iso8859-15 4092 1 (autoclean)
nls_cp850 4316 1 (autoclean)
vfat 11820 1 (autoclean)
fat 37944 0 (autoclean) [vfat]
supermount 15296 2 (autoclean)
ide-cd 33856 0
cdrom 31648 0 [sr_mod ide-cd]
ide-scsi 11280 0
scsi_mod 103284 3 [sg sr_mod ide-scsi]
ehci-hcd 18568 0 (unused)
usb-uhci 24652 0 (unused)
usbcore 72992 1 [ehci-hcd usb-uhci]
rtc 8060 0 (autoclean)
ext3 59916 2
jbd 38972 2 [ext3]

This is my problem, if you can help me I would be one of the happiest man of the world :)

bibilit 01-10-2004 01:09 PM

Did you try playing a cd ?? ( have you that small wire from cd player to mobo ?? )

Have you Alsa installed ? ( are aumix/alsamixer/kmix muted ?? )

Did you modified /etc/modules.conf ??

Let me know... i have the same sound system and have sound !!

tryynanen 01-11-2004 02:49 AM

I have not try play cd on the drive and I did not find alsa on command prompt.. alsamixer were found. I did not modified modules.conf

How about the system, did it work immediatly after installation or did you make any xtra configuration?

Cheers!

bibilit 01-11-2004 03:33 AM

At boot, use "esc" to have more information ( you should see the Alsa name somewhere and some information concerning via-snd82xx)... i have it so you should have it too.

You can alsa use Konsole and use "dmesg" command line to have more information.

You probably have to modify modules.conf to have things working properly (to modify you should be root !! ). By now you should only have snd-slot 0..

snd-via82xx.

Have a look at cvs.sourceforge.net and look for Alsa there is a real good configuration guide.

Let me know ( try to play a cd ).

macewan 01-11-2004 09:47 AM

http://www.opensound.com/download.cgi


it's free to try. see if it works. VERY MUCH worth the $20 to save time and energy to start listening to music right away.

while I highly encourage exploration with linux systems it's still good to know that sound is $20 away if really needed ;)

faheyd 01-13-2004 02:03 AM

Take a look at this and read the documents very carefully.
http://www.viaarena.com/?PageID=294#mandrake


All times are GMT -5. The time now is 04:20 PM.