LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   no sound on debian 64bit (2.6.12-1) (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-on-debian-64bit-2-6-12-1-a-375545/)

karlarsch23 10-21-2005 04:28 PM

no sound on debian 64bit (2.6.12-1)
 
hi!

i just set up my dual xeon 3,4 ghz 64-bit debian system (kernel 2.6.12-1-em64t-p4-smp).
my soundcard is a SOUNDBLASTER AUDIGY 2 ZS which should be ALSA-supported.

alsconf said:
Running update-modules...
Architecture-specific modutils configuration for x86_64 not found, using defaults
Loading driver...

Setting default volumes...

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.
--------------------------------------------------------------

when i play a soundfile in XMMS i see the equalizer jumping around but i cant hear any sound (the same with every audio-playing prog, haha).
but in the gnome-audio-level-tool i found: change device: SigmaTel STAC9750,51 (OSS-Mixer). i dont know if this is relevant to this problem!?

please help me! i really need sound on this workstation!


thx, karlarsch :-)

ps: here is the output of /sbin/lspci:

0000:00:00.0 Host bridge: Intel Corporation E7525 Memory Controller Hub (rev 0c)
0000:00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 0c)
0000:00:03.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A1 (rev 0c)
0000:00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 0 c)
0000:00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Contro ller (rev 02)
0000:00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller ( rev 02)
0000:01:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
0000:02:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A ( rev 09)
0000:02:00.1 PIC: Intel Corporation 6700/6702PXH I/OxAPIC Interrupt Controller A (rev 09)
0000:02:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B ( rev 09)
0000:02:00.3 PIC: Intel Corporation 6700PXH I/OxAPIC Interrupt Controller B (rev 09)
0000:03:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
0000:03:06.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (re v 04)
0000:03:06.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04 )
0000:04:04.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID
0000:05:00.0 VGA compatible controller: nVidia Corporation NV45GL [Quadro FX 340 0/4400] (rev a2)
0000:06:00.0 Multimedia video controller: Internext Compression Inc iTVC15 MPEG- 2 Encoder (rev 01)
0000:06:02.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

Que_273 11-17-2005 04:41 AM

1) Alsa mutes output by default so check your volume control for muting (as well as volume).
somehow my system sets up the volumes/mutes after booting. I can't remember how I got it to save though...

2) To make sure you are using Alsa, check the xmms output plugin. It might be set to OSS.

my system loads the oss modules but doesn't use them most of the time. I keep them in case I run into a app that doesn't support Alsa.

I hope these simple checks help a bit.

karlarsch23 11-17-2005 05:26 AM

THX - i am a idiot!

a channel for surround sound was muted ( i saw it in the alsa mixer of the shell)

thx to all of u !


All times are GMT -5. The time now is 11:05 PM.