LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-13-2012, 04:52 AM   #1
shams
Member
 
Registered: Jan 2004
Posts: 400

Rep: Reputation: 30
Unhappy No sound in the debian wheezy?


There was sound the in the debian wheezy but i reinstalled the wheezy and now there is no sound and the players like smplayer and mplayer cannot play any video, these are the information i provide:

Quote:
#lspci | grep audio
02:01.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Quote:
#cat /proc/asound/cards
0 [CMI8738 ]: CMI8738-MC6 - C-Media CMI8738
C-Media CMI8738 (model 39) at 0x0, irq 22
Quote:
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738-MC6 [C-Media PCI IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
Quote:

#speaker-test
speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 192 to 2097152
Period size range from 64 to 699051
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
0 - Front Left
Time per period = 30.115545
0 - Front Left
Time per period = 30.115036
0 - Front Left
Time per period = 30.129845
0 - Front Left
Time per period = 30.133851
0 - Front Left
Time per period = 30.122867
0 - Front Left
Time per period = 30.117779
0 - Front Left
The speaker-test just continue in the above messages.
In the alsamixer the card and chip is pulseaudio and threre is only two volumes Master and Caputre, here is the alsamixer screenshot:

alsamixer.png
 
Old 12-13-2012, 05:44 AM   #2
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Open up alsamixer again. Hit cmd 6 then select your card. See if the graphic at the bottom of the bar has a set of MM's. Hit M to unmute.


If you started out from scratch with a new system you need to make sure the needed codecs and plugins are installed.


http://wiki.debian.org/MultimediaCodecs


Hope this helps.
 
Old 12-13-2012, 09:35 AM   #3
shams
Member
 
Registered: Jan 2004
Posts: 400

Original Poster
Rep: Reputation: 30
Thanks for the reply i select the C-media CMI8738 and there was all other controls visible in the alsamixer here is the screenshot:
alsamixer2.png
But when i restart the pc then card is again the pulseaudio whith the only one master control in the alsamixer.

Last edited by shams; 12-13-2012 at 09:59 AM.
 
Old 12-14-2012, 05:33 AM   #4
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Do you have sound when you select the C-Media ?
 
Old 12-14-2012, 10:01 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Pulse audio lacks a few configuration files for a few cards. My delta 44 required the addition of 2 extra files created just for it.

/usr/share/pulseaudio/alsa-mixer/profile-sets/via-ice1712.conf
/etc/udev/rules.d/ice1712-pulseaudio-workaround.rules

I cut and pasted these for the most part from another page.
http://www.kevinsookocheff.com/2010/...ice1712-cards/

Obviously your card is not a delta 44 and requires different files and options. Not sure if that helps but it should give you something to look for.

-----

Alternatively stop running pulseaudio.

In /etc/pulse/client.conf change or add "autospawn = no" to prevent pulseaudio from automagically restarting when you stop it or kill it. Then switch between using and NOT using pulseaudio.

$ nano /etc/pulse/client.conf
$ pulseaudio --start
$ pulseaudio --kill

For some reason --stop doesn't seem valid, kind of lame imo. I'd recommend using pulseaudio even though I'm not a fan of it. Your openjdk and other things are likely configured for it, and fail to do certain things if you don't use pulseaudio. Like in the game runescape all you get is the musak tracks and none of the sound effects if you don't use pulseaudio. Be sure to add the user to the audio group and the pulse, pulse-access groups.

$ groups
<user> cdrom audio video games pulse pulse-access

That being said pulseaudio does suck, it lacks many things many would consider deal breakers. If you run pulse, even pulse over jack for a software synth you will have a high latency because the sounds will be resampled before actually being outputted. So having the option to opt out of pulseaudio is a good one.

Other tricks are to rename your .asoundrc file if you have one. This should force things to use alsa natively. You can also have different versions of .asoundrc with the renaming trick depending on how you use your soundcard. One for pulse, one for alsa, one for jack, and so on. You might also try purging the .pulse folder and restarting pulse.

$ rm -rf .pulse*
$ pulseaudio --kill
$ pulseaudio --start

Hope this helps.
 
Old 12-14-2012, 10:15 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Make sure your sound levels are set which you seemed to have done. You can save your levels with alsa-ctl

# alsa-ctl store

And they should be restored at the next boot. It's saved to /var/lib/alsa/asound.state. If you have another mixer application that your prefer that saves settings like aumix, you may want to delete that asound.state file so your settings will be restored. The debian boot sequence will restore mixer settings from asound.state if it exists and bypass aumix settings when both files / settings exist. I'm not a fan of 100% volume settings, a lot of cards distort noticeably when > 90%. Just saying.
 
Old 12-15-2012, 07:10 AM   #7
shams
Member
 
Registered: Jan 2004
Posts: 400

Original Poster
Rep: Reputation: 30
In reply of jv2112 there was no sound when i select the C-media in alsamixer but the problem is when i select the opions in alsamixer and gstreamer-properties after reboot the changes is discard, this is a command use to play a file with maplayer and get errors if some one can help:

Quote:
#mplayer -ao alsa:device=CMI8738-MC6 20051210-w50s.flv

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 20051210-w50s.flv.
Detected file format: FLV format (libavformat)
[flv @ 0xb5ebed00]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (vp6f), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO: [VP6F] 360x288 0bpp 25.000 fps 266.2 kbps (32.5 kbyte/s)
Clip info:
audiodelay: 0
canSeekToEnd: 1
creationdate: Fri Feb 03 11:52:46 2006

Load subtitles in .
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffvp6f] vfm: ffmpeg (FFmpeg VP6 Flash)
==========================================================================
==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 22050 Hz, 2 ch, s16le, 40.0 kbit/5.67% (ratio: 5000->88200)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
[AO_ALSA] alsa-lib: pcm.c:2217snd_pcm_open_noupdate) Unknown PCM CMI8738-MC6
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa:device=CMI8738-MC6'
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 360x288 => 360x288 Planar YV12
V: 0.0 0/ 0 ??% ??% ??,?% 0 0
[VD_FFMPEG] DRI failure.
V: 16.9 0/ 0 14% 2% 0.0% 0 0

Last edited by shams; 12-15-2012 at 10:18 AM.
 
Old 12-15-2012, 12:30 PM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Code:
[AO_ALSA] alsa-lib: pcm.c:2217snd_pcm_open_noupdate) Unknown PCM CMI8738-MC6
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa:device=CMI8738-MC6'
Did you typo this? -MC6? perhaps -CM6? Or is that what you named it in .asoundrc? In either case it cannot find it.

And if you're setup for pulse it should be "-ao pulse" on the mplayer command. And/or those default settings in /etc/mplayer/mplayer.conf

Will it work if you do something like this?

$ pulseaudio --kill
$ mv ~/.asoundrc ~/.zzzasoundrc
$ mplayer -ao alsa:device=hw,0 <media_file>

And don't forget to move .asoundrc back to it's former name. With adjustments if that somehow works for you. Because if it does work, then it is NOT a driver issue. It is a system configuration issue. Note that mplayers syntax is a bit odd as it's not hw:0 like we would use with anything that is alsa. And where 0 is the number of the device you want to use (as listed in /proc/asound/cards) which may not be 0.

For some things you can have a single line in .asoundrc if 0 is not your primary audio device.

~/.asoundrc
Code:
defaults.pcm.card 1
But some things will always use the 0 device no matter what you do. Which is the primary motivation behind aoss, artsdsp, esddsp, padsp, and whatever audio savior of the week we're going with this week. Re-indexing your card numbers is possible with a little customization of /etc/modprobe.d/

Last edited by Shadow_7; 12-15-2012 at 12:33 PM.
 
Old 12-15-2012, 08:09 PM   #9
shams
Member
 
Registered: Jan 2004
Posts: 400

Original Poster
Rep: Reputation: 30
Thanks for reply i don't have ~./asoundrc file and i search and didn't find asound package for wheezy and libasound2 is installed, this is the output of your command:

Quote:
#mplayer -ao alsa:device=hw,0 20051210-w50s.flv

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 20051210-w50s.flv.
Detected file format: FLV format (libavformat)
[flv @ 0xb5e90d00]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (vp6f), -vid 0
[lavf] stream 1: audio (mp3), -aid 0
VIDEO: [VP6F] 360x288 0bpp 25.000 fps 266.2 kbps (32.5 kbyte/s)
Clip info:
audiodelay: 0
canSeekToEnd: 1
creationdate: Fri Feb 03 11:52:46 2006

Load subtitles in .
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffvp6f] vfm: ffmpeg (FFmpeg VP6 Flash)
==========================================================================
==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 22050 Hz, 2 ch, s16le, 40.0 kbit/5.67% (ratio: 5000->88200)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
AO: [alsa] 22050Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 360x288 => 360x288 Planar YV12
A: 0.4 V: 0.0 A-V: 0.404 ct: -0.003 0/ 0 ??% ??% ??,?% 1 0
[VD_FFMPEG] DRI failure.
A: 0.4 V: 0.5 A-V: -0.036 ct: -0.018 0/ 0 ??% ??% ??,?% 7 0

Exiting... (Quit)
The command cannot play the media and stop on error [VD_FFMPEG] DRI failure.
 
Old 12-17-2012, 04:01 AM   #10
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Well DRI is how hardware accelerated things access the "VIDEO" hardware. You might try -vo x11 or -vo gl_nosw (had to do this instead of xv on newer things).

$ mplayer -vo help

Should list your options for video output. You could always try -vo null to see if the audio element functions right. And -vo aa or -vo caca are always fun in a terminal. Remnants of a era long gone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Debian Linux vs. Debian kFreeBSD With Squeeze & Wheezy LXer Syndicated Linux News 0 12-12-2012 11:00 PM
No sound with ES1983S Maestro-3i PCI Audio in debian wheezy? shams Linux - Hardware 2 10-16-2012 02:27 AM
[SOLVED] No sound with gnome debian wheezy cr33fr3r1d3r Linux - Desktop 8 10-14-2012 01:51 AM
Logitech Z305 under Debian KDE Wheezy - IEC958 issue (sound over USB) infoslaw Linux - Hardware 0 03-10-2012 05:05 PM
[SOLVED] Debian Wheezy no sound KGyST Linux - Software 7 03-04-2012 04:51 AM


All times are GMT -5. The time now is 12:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration