LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-03-2012, 03:07 AM   #1
sekelsenmat
Member
 
Registered: Apr 2005
Location: São Paulo - Brazil
Distribution: Mageia Linux 1
Posts: 353

Rep: Reputation: 30
No sound in headphones in notebook


Hello,

I have Mageia 1 installed in a new Toshiba notebook of this model:

toshiba satellite L750 12Z
http://ce.computers.toshiba-europe.c...UCT_ID=1112775

Upon connecting headphones in the notebook nothing happens. No sound comes from the headphones and the computer sound plays as usual.

I tryed to use alsoconf and alsamixer but nothing helped =(

The results of lspci:

[kasia@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation Sandy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Sandy Bridge PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation Cougar Point HECI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 1 (rev b4)
00:1c.5 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 6 (rev b4)
00:1c.6 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 7 (rev b4)
00:1d.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Cougar Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Cougar Point 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation Cougar Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation Device 0dec (rev a1)
01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)
08:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
09:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)

Any ideas?

It doesn't even have to automatically make the main sound muted, I would be happy already if sound comes out of the headphone =/

thanks,
 
Old 03-03-2012, 08:10 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
In many Linux distros it doesn't automatically mute the speakers when you plug in headphones, so that's not overly significant. You said you've used alsamixer, you've tried unmuting all the channels available and turning up their volume? Is there a 'headphone' channel?
 
Old 03-04-2012, 12:13 AM   #3
sekelsenmat
Member
 
Registered: Apr 2005
Location: São Paulo - Brazil
Distribution: Mageia Linux 1
Posts: 353

Original Poster
Rep: Reputation: 30
Yes, I tried unmutting all channels and turning their volume up and there is no "headphone" channel. My alsamixer shows as following:

3 views: Playback, Capture and All
2 sound cards: HDA Intel PCH and HDA NVidia

HDA Intel PCH:
Card: PulseAudio
Chip: PulseAudio
Playback: 1 Channel called "Master" at 100%
Capture: 1 channel "Capture"
F5 All: just shows both channels

HDA NVidia:
Chip: Nvidia GPU 14 HDMI/DP
Playback: 4 channels: S/PDIF which is zero and I can't change with the arrows and "S/PDIF 1", "S/PDIF 2", "S/PDIF 3" which are all "MM"
Capture: Nothing

If the NVidia thing is my headphone then I am missing how to turn its volume up, but I think that not, since it says it is something for HDMI ... no idea however.
 
Old 03-04-2012, 02:22 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
According to this, http://forums.linuxmint.com/viewtopic.php?f=49&t=82526 , providing a 'model=ideapad' option to the snd-hda-intel kernel module may be a fix.
 
Old 03-04-2012, 08:47 AM   #5
sekelsenmat
Member
 
Registered: Apr 2005
Location: São Paulo - Brazil
Distribution: Mageia Linux 1
Posts: 353

Original Poster
Rep: Reputation: 30
Thanks a lot =) Mageia has no such file /etc/modprobe.d/alsa-base.conf, but I simply created it, added the line:

options snd-hda-intel model=ideapad

Rebooted, and the headphone works perfectly =) It even auto-mutes the main sound.
 
Old 05-26-2012, 06:34 PM   #6
methomas
LQ Newbie
 
Registered: May 2012
Location: Bogota, Colombia
Distribution: Zorin OS 5.2
Posts: 1

Rep: Reputation: Disabled
Greetings sekelsenmat,

I am a newbie having just install linux this morning.

Everything is working find except the headphones.


Thanks a lot =) Mageia has no such file /etc/modprobe.d/alsa-base.conf, but I simply created it, added the line:

options snd-hda-intel model=ideapad

Rebooted, and the headphone works perfectly =) It even auto-mutes the main sound.




Can you explain to me, a newbie, how you created (/etc/modprobe.d/alsa-base.conf) file?

Thanks,

M E
 
Old 05-26-2012, 08:59 PM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Try this:
Press the Alt&F2 keys and then type:
Code:
sudo echo "options snd-hda-intel model=ideapad" >> /etc/modprobe.d/alsa-base.conf
and press enter.
It is probably easiest to reboot your computer to get the change to be recognised.

For further information on working as the root user have a look at this. http://www.zoringroup.com/forum/view...php?f=6&t=1941
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound out with headphones thusithniranjan Linux - Newbie 1 10-14-2011 11:42 AM
No sound on speakers, sound on headphones and no system sounds EricTRA Linux Mint 2 10-12-2010 10:39 AM
sound but no headphones flury Linux - Laptop and Netbook 1 05-29-2007 11:28 AM
Back Panel - No Sound, Headphones - Sound GNewbie Ubuntu 2 03-19-2007 11:15 PM
No sound from headphones:( in 6.10 sagar.1986 Ubuntu 6 02-18-2007 07:27 PM


All times are GMT -5. The time now is 08:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration