LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-30-2008, 06:04 PM   #1
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Rep: Reputation: 15
no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" (reposted)


I am reposting this because I did not get anywhere under the Fedora thread. Hopefully this will work. I am very frustrated with this issue. new system/ No sound!!

I have read many threads and still not sure what to do. This is a newly built and loaded computer and after upgrades. I have onboard sound MCP55 HDA intel. I am trying to use the spdif optical out. I get nothing. I have an other computer same FD8 OS but it has a audigy z-2 sound card running spdif out (not optical) and it works just fine. If you can help please do. I am out of ideas and not sure what to look for to correct the issue?

Code:
    [root@GraysNew ~]# uname -a
Linux GraysNew 2.6.24.3-50.fc8 #1 SMP Thu Mar 20 13:39:08 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
When I run system-config-soundcard I get this in the scsrun.log. First big clue is the "PULSEAUDIO: Unable to connect: Connection refused"
Why I don't know?

Code:
 ------- System Config Soundcard Log --------
Sun Mar  2 09:53:30 EST 2008

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
*** PULSEAUDIO: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused
ProbeCards, method =  hal
--------- Card 0 --------
Active 1
Vendor: nVidia Corporation
Model: MCP55 High Definition Audio
Driver: snd-hda-intel
Here is my aplay -L listing (note the null on the digital out)

Code:
 
     [root@GraysNew ~]# aplay -L
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Digital
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)
Here is my amixer list:

Code:
 [root@GraysNew ~]# amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 49088 [75%] [on]
  Front Right: Playback 49088 [75%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [off]
  Front Right: Capture 65536 [100%] [off]
Here is the asound version:


Code:
[root@GraysNew ~]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42 2007 UTC).
Here is my asound.conf file:

Code:
 [root@GraysNew ~]# cat /etc/asound.conf
#Generated by system-config-soundcard
#If you edit this file, don't run system-config-soundcard,
#all your changes here could be lost.
#SWCONF
#DEV 1
defaults.pcm.card 0
defaults.pcm.device 1
defaults.ctl.card 0
Here is my sysconfig/hwconf listing for audio:


Code:
class: AUDIO
bus: PCI
detached: 0
driver: snd-hda-intel
desc: "nVidia Corporation MCP55 High Definition Audio"
vendorId: 10de
deviceId: 0371
subVendorId: 10de
subDeviceId: c55e
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  f
pcifn:  1
Code:
 [root@GraysNew ~]# cat /proc/asound/pcm
00-02: ALC882 Analog : ALC882 Analog : capture 2
00-01: ALC882 Digital : ALC882 Digital : playback 1 : capture 1
00-00: ALC882 Analog : ALC882 Analog : playback 1 : capture 2 
Here is my lspci -vn:
Code:
 [root@GraysNew ~]#  clr; lspci -v |grep -iC 10 audio 
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
        Subsystem: nVidia Corporation Unknown device c55e
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
        Memory at cfff0000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Not sure what to make of this:
Quote:
Subsystem: nVidia Corporation Unknown device c55e
My lsmod output:

Code:
      [root@GraysNew ~]# lsmod |grep snd
snd_usb_audio          95169  0
snd_usb_lib            24001  1 snd_usb_audio
snd_rawmidi            28865  1 snd_usb_lib
snd_hda_intel         361577  4
snd_seq_dummy          11461  0
snd_seq_oss            37313  0
snd_seq_midi_event     15041  1 snd_seq_oss
snd_seq                56673  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15061  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45889  0
snd_mixer_oss          22721  2 snd_pcm_oss
snd_pcm                80201  3 snd_usb_audio,snd_hda_intel,snd_pcm_oss
snd_timer              27721  2 snd_seq,snd_pcm
snd_page_alloc         16465  2 snd_hda_intel,snd_pcm
snd_hwdep              16073  2 snd_usb_audio,snd_hda_intel
snd                    60137  17 snd_usb_audio,snd_rawmidi,snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              15073  2 snd
Here is a listing of installed alsa software:

Code:
[root@GraysNew ~]# clr; yum list installed |grep alsa
/root
alsa-lib.x86_64                          1.0.15-1.fc8           installed
alsa-lib.i386                            1.0.15-1.fc8           installed
alsa-lib-devel.x86_64                    1.0.15-1.fc8           installed
alsa-lib-devel.i386                      1.0.15-1.fc8           installed
alsa-oss.x86_64                          1.0.14-3.fc8           installed
alsa-oss-devel.i386                      1.0.14-3.fc8           installed
alsa-oss-devel.x86_64                    1.0.14-3.fc8           installed
alsa-oss-libs.x86_64                     1.0.14-3.fc8           installed
alsa-oss-libs.i386                       1.0.14-3.fc8           installed
alsa-plugins-jack.x86_64                 1.0.15-2.fc8           installed
alsa-plugins-oss.x86_64                  1.0.15-2.fc8           installed
alsa-plugins-pulseaudio.x86_64           1.0.15-2.fc8           installed
alsa-plugins-samplerate.x86_64           1.0.15-2.fc8           installed
alsa-plugins-upmix.x86_64                1.0.15-2.fc8           installed
alsa-plugins-vdownmix.x86_64             1.0.15-2.fc8           installed
alsa-tools.x86_64                        1.0.12-4.fc7           installed
alsa-utils.x86_64                        1.0.15-1.fc8           installed
alsamixergui.x86_64                      0.9.0-0.3.rc1.fc8.2    installed
bluez-utils-alsa.x86_64                  3.20-6.fc8             installed
Here is a listing of my pulseaudio installed software:
Code:
  
akode-pulseaudio.x86_64                  2.0.2-4.fc8            installed
alsa-plugins-pulseaudio.x86_64           1.0.15-2.fc8           installed
kde-settings-pulseaudio.noarch           3.5-36.fc8.1           installed
pulseaudio.x86_64                        0.9.8-5.fc8            installed
pulseaudio-core-libs.x86_64              0.9.8-5.fc8            installed
pulseaudio-esound-compat.x86_64          0.9.8-5.fc8            installed
pulseaudio-libs.i386                     0.9.8-5.fc8            installed
pulseaudio-libs.x86_64                   0.9.8-5.fc8            installed
pulseaudio-libs-devel.i386               0.9.8-5.fc8            installed
pulseaudio-libs-devel.x86_64             0.9.8-5.fc8            installed
pulseaudio-libs-glib2.x86_64             0.9.8-5.fc8            installed
pulseaudio-libs-glib2.i386               0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.i386            0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.x86_64          0.9.8-5.fc8            installed
pulseaudio-module-bluetooth.x86_64       0.9.8-5.fc8            installed
pulseaudio-module-gconf.x86_64           0.9.8-5.fc8            installed
pulseaudio-module-jack.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-lirc.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-x11.x86_64             0.9.8-5.fc8            installed
pulseaudio-module-zeroconf.x86_64        0.9.8-5.fc8            installed
pulseaudio-utils.x86_64
Help would be greatly appreciated.
Legolas
 
Old 03-30-2008, 06:23 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Sorry about the other thread, I got distracted...
Quote:
This is a newly built and loaded computer and after upgrades.
Did you have sound before the upgrades? (Did it pass the sound test?)

http://www.fedoraforum.org/forum/sho...d.php?t=177587
... have you checked against this thread?

The above info suggests that your card is recognized and active, the correct driver is being used. You seem to have the alsa and pulseaudio packages. But there's much more. Work your way through the howto and tell me where you get stuck.
 
Old 03-30-2008, 11:42 PM   #3
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Thank you Simon

To your first question: This is a new computer from assembled parts "Newegg" all new components and fresh FD 8 installed and then the regular updates after installation. I have never had sound or any indication of sound and would get the "sound server not connected and sent to Null output" or something like that every time I booted up.

Currently
I am very happy but not completely finished. I followed the guide as you provided. It was great!! For the first time I can see "PCM" in my receiver window which means that the sound card has made connection!!! Unfortunately it gets disconnected in about 2-5 minutes or disappears and reappears. I can hear sound coming out of my receiver when I complete a command or such in a terminal so I know sound is available when the "PCM" led is lit up.

However, two things. I do not have the "svn" versions of the pulseadio files as listed in the howto, but I think I have all required:
Code:
[root@GraysNew ~]# rpm -qa pulse*
pulseaudio-libs-glib2-0.9.8-5.fc8
pulseaudio-module-zeroconf-0.9.8-5.fc8
pulseaudio-esound-compat-0.9.8-5.fc8
pulseaudio-libs-zeroconf-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8
pulseaudio-libs-zeroconf-0.9.8-5.fc8
pulseaudio-libs-devel-0.9.8-5.fc8
pulseaudio-core-libs-0.9.8-5.fc8
pulseaudio-module-jack-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8
pulseaudio-module-gconf-0.9.8-5.fc8
pulseaudio-module-bluetooth-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-module-lirc-0.9.8-5.fc8
pulseaudio-core-libs-0.9.8-5.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-libs-devel-0.9.8-5.fc8
pulseaudio-module-x11-0.9.8-5.fc8
And secondly I am using KDE which means I had to do some set up in Gnome and work my way through some Gnome menus.

I am not sure what to check now. Currently the PCM connection is gone in the receiver and no sound but the Pulseaudio managers shows that I am still connected.

Last edited by Legolas327; 03-30-2008 at 11:51 PM.
 
Old 03-31-2008, 12:34 AM   #4
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
It is late EST and I have to go to work tomorrow. One last note. I didn't do any thing different but reboot a couple of times but now the "PCM" is solid in the receiver and I can play music out of Amarok. Yeah.. the only thing is that the Pulseaudio shows me as disconnected???? I have something fighting something else for control of the audio output which is oh so much better than I had before but I don't know what? I don't know which server is connected now?

Gray
 
Old 03-31-2008, 05:52 AM   #5
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
What makes you think there is a conflict?

Check you are not using OSS anywhere. (Like in any media-player settings.)
Double-check you have enabled pulseaudia as per the howto.

Look through your logs, you may have an irq conflict (not unlikely on a hybrid system).

The point, partly, of pulseaudio is that different apps can call on the server without having to compete. You'd be running some sort of player, and the system sounds. You could try disabling the system sounds to see if the conflict goes away.
 
Old 04-01-2008, 10:21 PM   #6
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Thank you Simon. I don't want you think that I went away. I just had to do quite a bit to my system. Ummm... basically I did all that you asked. That howto is wonderful but as stated before I was getting unstable connection. After trying various things I finally started crashing and locking up any media player that I tried. So I had the bright Idea of reinstalling Alsa and Pulseaudio. Oh boy LOL I basically removed KDE and Gnome applications that were Dependant on alsa by accident. After reloading all of those (approximately 320) I went through the Howto walk through again exactly step by step. I now have sound playing great through Rhythmbox and system sounds.

I am trying to figure out why Xine (which I absolutely love) is not working? It was one of the programs removed so I reinstalled Xine and all of the codex files but it fails to operate properly. I get a black blank screen and it locks up and I have to use the kill command on it.

So far things that work are: Rhythmbox and Kmplayer
Thinks that fail and lock up the system are: xine, Mplayer, and Amarok.

I am a little gun shy at this point to mess up what I have working.

Any ideas what I need to do to get my Xine working again?

Last edited by Legolas327; 04-01-2008 at 11:46 PM.
 
Old 04-02-2008, 03:22 PM   #7
dnguyen
LQ Newbie
 
Registered: Jan 2007
Location: US
Distribution: FC6
Posts: 5

Rep: Reputation: 0
My newly upgraded Fedora 8 has no sound too. I am using Dell Optiplex desktop, with Intel soundcard. Only the "Soundcard Detection" tool in System->Administration can play a test sound. Other softs like vlc, rythmbox, or skype (as someone reported working) failed. Everything is fine with previous Fedora 7, and there is no hardware change at all, the only wrong move so far is upgrading to Fedora 8.
Anyone has the same problem?
 
Old 04-02-2008, 06:10 PM   #8
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
I am looking for solutions to xine engine applications failing: This is a list of the xine installed rpms:

Code:
[gray@GraysNew ~]$ yum list installed |grep xine
gxine.x86_64                             0.5.11-14.fc8          installed
gxine-mozplugin.x86_64                   0.5.11-14.fc8          installed
totem-xine.x86_64                        2.20.1-1.lvn8          installed
totem-xine-devel.x86_64                  2.20.1-1.lvn8          installed
totem-xine-galago.x86_64                 2.20.1-1.lvn8          installed
totem-xine-lirc.x86_64                   2.20.1-1.lvn8          installed
totem-xine-mozplugin.x86_64              2.20.1-1.lvn8          installed
xine.x86_64                              0.99.5-1.lvn8          installed
xine-lib.x86_64                          1.1.11-1.fc8           installed
xine-lib.i386                            1.1.11-1.fc8           installed
xine-lib-arts.x86_64                     1.1.11-1.fc8           installed
xine-lib-devel.x86_64                    1.1.11-1.fc8           installed
xine-lib-extras.x86_64                   1.1.11-1.fc8           installed
xine-lib-extras-nonfree.x86_64           1.1.11-1.lvn8          installed
xine-plugin.x86_64                       1.0-5.fc8              installed
I have tested Xine without the Pulseaudio connected and it works just fine. If I try to use xine with Pulse audio connected it locks xine up and disconnects pulseaudio. I have read many posting on issues with Xine and Pulseaudio and the one solution provided in this posting http://www.pulseaudio.org/wiki/PerfectSetup is to place the following statement into the .xine/config file:

Code:
...
audio.driver:pulse (or polypaudio or esd depending on xine version)
...
I did this but no change.

The odd thing is that I have a 32bit 386 setup working just fine with Fedora 8 and all video and sound applications. I did none of the Pulseaudio setup and it has worked with just fine with all sounds and applications. I ran the pulseaudio -vv command and it tested good. I don't have any of the Pulseaudio controls shown below installed.

Code:
* PulseAudio Volume Control
    * PulseAudio Volume Meter
    * PulseAudio Manager
    * PulseAudio Device Chooser
    * PulseAudio Preferences

At this point I am considering removing the Pulseaudio completely if I can get AlSA to work with out it. The reason I have not is that since I did a new install directly from the Fedora 8 dvd and the Fedora 8 team are all excited about Pulseaudio and I am sure they did detail testing before releasing that I have something uniquely buggy with my system. I can start all over again from scratch (total reload) but I seriously hate to that.

Any Ideas?

Gray

Last edited by Legolas327; 04-03-2008 at 08:45 AM. Reason: more information
 
Old 04-04-2008, 08:39 AM   #9
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
http://www.mail-archive.com/alsa-use.../msg17829.html
... seen this.

Apologies for making you do the work here - I'm snowed.
 
Old 04-04-2008, 12:54 PM   #10
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Hi Simon. Thanks for the reference. I have great sound through the optical spidif cable which I did not have before I started this thread and am connected via PCM but my issue now is getting anything with the xine engine to not crash when trying to connect or conflict with the psuedoaudio server. There are a few posting on how to make the xine engine to work with pulseaudio work but I did not get any change in results.

I also think that I may have messed up some things on the base Fedora 8 platform when I removed Asla and Pulseaudio and reinstalled. Because of this doubt and knowing the amount of system (KDE and Gnome) applications that were removed and reloaded I think it best to do a reload, get to this functioning position, then analyze where I am. I have increased my knowledge ten fold (ok double) so don't think it will be difficult to get back to where I am now on a clean installed system.

Gray
 
Old 04-21-2008, 08:11 AM   #11
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
I have been off of this posting awhile but been very busy trying everything suggested here and reading many other sites. When I left this posting last I was able to play sound out of my computer for applications that did not use the Xine engine ( xine and a few other xine type of applications). After trying many of the suggestions supplied by other sites I ended up not having any sound again. Fearing that I had messed up my basic set up I reloaded Fedora 8 from the beginning all over again and did exact step by step instructions per this site:

http://www.fedoraforum.org/forum/showthread.php?t=177587


Which worked well before but somehow I could not get sound to work again.

In frustration I loaded up Ubuntu Gutsy 7.10 and with in five minutes I have sound in all application. Of course Ubuntu does not use the Pulseaudio server.


I am giving up on the pulseaudio. Way too much trouble!!!
I would like to use Fedora 8 or 9 when it comes out but I tried removing the pulseaudio applications on a clean installation and setting everything to use just the alsa server but failed.

Any suggestions on how to use Fedora 8 or 9 with out pulseaudio?

Gray
 
Old 04-22-2008, 02:45 AM   #12
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
You can remove the alsa-plugins-pulseaudio package and enable ESD (or artsd). It's supposed to be a drop-in, but I suspect it may be a couple of releases before it is seamless.

How to disable pulseaudio
Fedora Pulse-audio Howto

Last edited by Simon Bridge; 04-22-2008 at 02:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba + CUPS "Access denied, unable to connect" error lirik Linux - Networking 10 10-13-2011 01:09 PM
no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" using onboard Optical spdif Legolas327 Fedora 12 07-27-2009 08:58 PM
winxp says "unable to connect..." to server attached printer linuxlimbo Linux - Networking 1 09-20-2006 10:39 PM
Common problems explained: "kernel panic - not syncing", "unable to mount..." sundialsvcs Linux - Newbie 2 03-01-2006 12:17 PM
Unable to connect get's error "NO CARRIER" niju_nn Linux - Hardware 4 01-27-2004 01:28 PM


All times are GMT -5. The time now is 08:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration