LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-11-2007, 07:48 AM   #16
funalien
LQ Newbie
 
Registered: Oct 2007
Location: Vilnius, Lithuania
Distribution: Debian Etch 4
Posts: 11

Original Poster
Rep: Reputation: 0

I tryed to install alsa from source, but it writes that I can't install additional ALSA driver, while I have build-in kernel. So, I installed alsa from .deb packages from repo.
 
Old 10-11-2007, 08:34 AM   #17
Matz
Member
 
Registered: Oct 2006
Distribution: Kubuntu 9.04, Debian Etch
Posts: 178

Rep: Reputation: 31
Quote:
Originally Posted by funalien View Post
I tryed to install alsa from source, but it writes that I can't install additional ALSA driver, while I have build-in kernel. So, I installed alsa from .deb packages from repo.
???? What does it means? If you can't install an additional driver why should you be able to install it from repository? Can you post the exact output you get? Unless you fixed your issue by installing from repo

@Jack

Maybe from alsa website it is not entirely clear that you first have to download the sources from http://www.alsa-project.org/main/index.php/Main_Page. Download the latest version of alsa-driver, alsa-lib, and alsa-utils (latest version is 1.0.14)

Then unzip the sources into proper directories. The suggestion from the alsa page is
Code:
       
cd /usr/src
mkdir alsa
cd alsa
cp /downloads/alsa-* .
(/download is the directory where you are supposed have downloaded the sources)

..then follow the instruction from "Now unzip and install the alsa-driver package:"
 
Old 10-12-2007, 02:44 AM   #18
Jack_The_Nimble
LQ Newbie
 
Registered: Oct 2007
Distribution: Debian, Ubuntu, Gentoo, whatever I feel like that day....
Posts: 16

Rep: Reputation: 0
I'm having the same problem as Funalien, my output is as follows

Code:
debian-Killa:/usr/src/alsa/alsa-driver-1.0.15rc3# ./configure
 --with-cards=intel8x0 --with-sequencer=yes ; make ; make ins
tall
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included..
. yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-1
.0.15rc3
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exis                                        t.
Please install the package with full kernel sources for your                                         distribution
or use --with-kernel=dir option to specify another directory                                         with kernel
sources (default is /usr/src/linux).
make all-deps
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.15                                        rc3'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.15r                                        c3'

Please, run the configure script as first...

if [ -L /include/sound ]; then \
                rm -f /include/sound; \
                ln -sf /usr/src/alsa/alsa-driver-1.0.15rc3/in                                        clude/sound /include/sound; \
        else \
                rm -rf /include/sound; \
                install -d -m 755 -g root -o root /include/so                                        und; \
                for f in include/sound/*.h; do \
                        install -m 644 -g root -o root $f /in                                        clude/sound; \
                done \
        fi
install: cannot stat `include/sound/*.h': No such file or dir                                        ectory
make: *** [install-headers] Error 1
Edit: I understand what this is saying, that I just need to use the --with-kernal=directory, but I can't find the thing... I know that is the most ridiculous thing you've ever heard, but I don't know where it is. Funalien and myself are both using Debian Etch and he is probably having the same problem I am with this, so if you could just tell where the kernal is, obviously not /usr/src/linux, I'm sure the problem will be resolved.

Last edited by Jack_The_Nimble; 10-12-2007 at 02:50 AM.
 
Old 10-14-2007, 04:22 AM   #19
Matz
Member
 
Registered: Oct 2006
Distribution: Kubuntu 9.04, Debian Etch
Posts: 178

Rep: Reputation: 31
You likely need to install linux-headers. Also install "build-essential"
Code:
apt-get install linux-headers-`uname -r` build-essential
and then try again
 
Old 10-15-2007, 11:46 PM   #20
Jack_The_Nimble
LQ Newbie
 
Registered: Oct 2007
Distribution: Debian, Ubuntu, Gentoo, whatever I feel like that day....
Posts: 16

Rep: Reputation: 0
Okay, I got the sound working the other day if funalien is still out there this is what I did. I started by compiling a new kernel because there was no file in the root directory linking my kernel, this could be because I chose to have a separate partition for my boot files, there is a great how to at http://newbiedoc.sourceforge.net/system/kernel-pkg.html that you how to use the Debian tools, these really help. Then once you compile your kernel the alsa compilation will run smoothly. ll you have to do is run alsaconf and roll and, alsaconf should see your card this time so just unmute everything and you'll have sound.
 
Old 01-31-2008, 08:15 AM   #21
LoxDon
LQ Newbie
 
Registered: Jan 2008
Location: South Florida
Distribution: openSUSE
Posts: 3

Rep: Reputation: 0
Possible Hardware Conflict?

I am new to openSUSE (trying to abandon Windows). I had similar audio problems after trying several fixes. Then, I noticed a problem with a memory buffer size in the startup log. I have Phoenix BIOS and went to BIOS Setup:Advanced Chipset Features. I changed the iGPU Frame Buffer Control to [MANUAL] and increased the Frame Buffer Size[128M]. It may be coincidence but my sound worked OK even after several re-boots. I then installed the NVIDIA video drivers and lost my sound again. Suspecting a hardware conflict, I disabled 3D acceleration and my sound works again. It may be coincidence but it's worth trying increasing your BIOS frame buffer size and disabling 3D acceleration.

New info: Automatic software update installed a new kernal and killed my sound. Now, I cannot turn 3D-acceleration off or install my original alsa drivers because of conflicts. This is too much for one day; I think I will go mow the grass and think about it for a while.

More Info: I have a conflict between alsa-driver-kmp-default and x11-video-nvidiaG01. After the new kernel was installed, I had no sound. Installing alsa driver deleted nvidia, installed a new kernal, and I had sound. Installing nvidia video deleted alsa driver, installed a new kernel, and I lost sound again.

After re-installing alsa, running alsaconf, sax2 -r, and turning up the volume I have sound after several re-boots (wav, mp3, midi, kar, avi, divx, & dvd all work.) I lost some of my video capabilities but I can get 1280x1024 with no 3D which is all I need.

Software update wants to install a new security update (kernel 4943-0) but I think I will wait for a while. I am not quite ready to compile & maintain the kernel myself...

Last edited by LoxDon; 02-03-2008 at 10:06 AM. Reason: More Info:
 
  


Reply

Tags
debian, realtek, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound - SUSE 10.1/Realtek AC97 epsilon72 Linux - Hardware 2 03-15-2007 02:24 PM
Realtek ac97 5.1 surround sound not working paintballpimp765 Suse/Novell 6 02-14-2007 05:51 PM
No Sound:Debian Etch with VT8233/A/8235/8237 AC97 Audio Controller tadellos Debian 2 12-21-2006 12:47 AM
realtek ac97(sound card) Kolem Linux - Hardware 7 12-11-2006 07:01 AM
Realtek AC97 Sound Issues.. Cliekid Fedora 0 11-16-2004 05:53 PM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration