LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   No sound in Debian Etch 4 with Realtek Ac97 (http://www.linuxquestions.org/questions/linux-hardware-18/no-sound-in-debian-etch-4-with-realtek-ac97-590280/)

funalien 10-08-2007 10:01 AM

No sound in Debian Etch 4 with Realtek Ac97
 
Hi all,
I have a problem with sound in Debian Etch. Some time ago I installed Debian, and the sound hasn't been working since that time. I have a built-in soundcard Realtek AC97.

I tried to run "alsaconf", but nothing changed after this. At the end it only displays "Thanks, now you'll hear a sound", but still no sound.
I have been reading posts about this problem, however I have found any helpful tips.

Here can be found more information about the causes sound not to being heard.

dmesg:


Code:

# lsmod|grep snd
snd_intel8x0          30620  0
snd_ac97_codec        83360  1 snd_intel8x0
snd_ac97_bus            2688  1 snd_ac97_codec
snd_pcm_oss            39200  0
snd_mixer_oss          15552  1 snd_pcm_oss
snd_pcm                68996  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21316  1 snd_pcm
snd                    47524  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              9568  1 snd
snd_page_alloc          9928  2 snd_intel8x0,snd_pcm


Code:

# lspci -vv
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
        Subsystem: EPoX Computer Co., Ltd. Unknown device 1008
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0 (500ns min, 1250ns max)
        Interrupt: pin A routed to IRQ 185
        Region 0: I/O ports at d800 [size=256]
        Region 1: I/O ports at dc00 [size=128]
        Region 2: Memory at e2002000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


kaz2100 10-08-2007 03:03 PM

Hya,

AC97 may (or may not) need options. Read kernel document (Documentation/sound/ALSA-Configuration-txt)

Happy Penguins!

funalien 10-09-2007 10:28 AM

Any other suggestions?

jeenam 10-09-2007 11:55 AM

Is the volume unmuted or turned up? Use 'alsamixer' to adjust the volume.

After the volume level is set use 'alsactl store' to save the settings.

funalien 10-09-2007 12:37 PM

Yes, sound in alsamixer have been always turned to 100%

Matz 10-09-2007 02:51 PM

Follow the suggestion made by kaz2100. In the ALSA home page you find detailed instruction for installing ALSA latest source
This is likely to fix your issue.

If compiling the source is too difficult for you, you can find a .deb version of alsa source to install, for example

http://debian.mirror.inra.fr/debian/...0.14-2_all.deb

Hope this helps

Jack_The_Nimble 10-10-2007 01:54 AM

What type of computer do you use? I have a gateway mx3228 laptop and am having the exact same problem with the same sound card. Just to let you know others are having the same problem. As for the things I've tried: various and sundry combinations of mute and unmute in alsa mixer, alsaconf, and various options under KDE control center. If anything has worked for you please help. As far as alsaconf goes it recognizes two separate sound cards, neither of which are mine. I'm heading over to the alsa home page to read their stuff now. Thanks for the expedient reply.

funalien 10-10-2007 10:41 AM

Quote:

What type of computer do you use? I have a gateway mx3228 laptop and am having the exact same problem with the same sound card. Just to let you know others are having the same problem. As for the things I've tried: various and sundry combinations of mute and unmute in alsa mixer, alsaconf, and various options under KDE control center. If anything has worked for you please help. As far as alsaconf goes it recognizes two separate sound cards, neither of which are mine. I'm heading over to the alsa home page to read their stuff now. Thanks for the expedient reply.
I use a desktop computer with nvidia with REALTEK AC97 soundcard intergrated into motherboard. As I've alredy said, anything hasn't worked since I have installed linux. In windows is everything OK with sound. Unfortunatelly I haven't got the answer to this problem, yet.

funalien 10-10-2007 11:33 AM

While I was installing official Realtek sound drivers based on ALSA, a message was shown. It writes me to select my soundcard (snd_mpu_401 and legacy Probe legacy ISA).

If I select snd_mpu_401, then it's written
Code:

Loading driver...
FATAL: Error inserting snd_mpu401 (/lib/modules/2.6.18-5-k7/kernel/sound/drivers/mpu401/snd-mpu401.ko): No such device
FATAL: Error running install command for snd_mpu401
Setting default volumes...


ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
aplay: main:550: audio open error: Device or resource busy

What can I do?

Jack_The_Nimble 10-10-2007 11:56 AM

To be honest I just installed etch myself having not used Linux in about a year and everything is still real foggy. I'm looking for help just like you. Where did you get the driver for AC 97?

funalien 10-10-2007 01:14 PM

I have downloaded driver from this site

Jack_The_Nimble 10-10-2007 01:48 PM

Which link did you use, I see that the drivers available are for the 2.2 and the 2.4 kernal, it is unlikely, yet possible, that they are not supported in the 2.6 kernal that Etch uses. Was the driver you downloaded was binary, source or a .deb package?

Matz 10-11-2007 02:08 AM

funalien, did you try to compile the alsa source? Follow the instruction you find in this page and if you have problems report them here

Jack_The_Nimble 10-11-2007 02:32 AM

I know I'm not Funalien, but I'm having a problem too.... I am trying to compile the alsa module but I get stuck, on the how to after you type " modinfo soundcore " and it gives you the output it says to type ./configure. I was in my /home directory when I did this, so as I'm sure you can guess it did nothing. What directory should I be under? Here's the output from mondinfo:

debian-Killa:/home/jamison# modinfo soundcore
filename: /lib/modules/2.6.18-5-686/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.18-5-686 SMP mod_unload 686 REGPARM gcc-4.1
depends:
debian-Killa:/home/jamison# ./configure
bash: ./configure: No such file or directory

funalien 10-11-2007 05:11 AM

Quote:

Which link did you use, I see that the drivers available are for the 2.2 and the 2.4 kernal, it is unlikely, yet possible, that they are not supported in the 2.6 kernal that Etch uses. Was the driver you downloaded was binary, source or a .deb package?
Yes, you are right! I have downloaded the driver's source for 2.6 kernel. However, I think it is not causes hardware not to be found.
Now I'll try to compile alsa driver manually from source.
Quote:

funalien, did you try to compile the alsa source? Follow the instruction you find in this page and if you have problems report them here
No, I don't. So I will try now.


All times are GMT -5. The time now is 01:08 PM.