LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-31-2008, 03:30 PM   #1
ottovox
LQ Newbie
 
Registered: Oct 2008
Location: Seattle
Distribution: Ubuntu 8.10
Posts: 5

Rep: Reputation: 0
No sound: HDA Intel ALC882 A/D - Ubuntu 8.10 fresh install


Hello,

I have a clean install of Ubuntu 8.10, and sadly, no sound. I've tried just about everything I've run across related to Intel sound/linux issues. Here are my specs, and below that, what I've tried thus far. Any help would be appreciated:

DETAIL OF lspci -vv
-------------------

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: ASUSTeK Computer Inc. Device 8237
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 16 bytes
Interrupt: pin A routed to IRQ 19
Region 0: Memory at cddf8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

DETAIL OF aplay -l
------------------

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC882 Analog [ALC882 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC882 Digital [ALC882 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

DETAIL OF cat /proc/asound/card0/codec#* | grep Codec
-----------------------------------------------------

Codec: Realtek ALC882

I have confirmed that my speakers are plugged into the right port, power is on, alsamixer is set to 100% for playback, sound preferences are all set to ALSA.

I've run the following:
gksudo gedit /etc/modprobe.d/alsa-base

...and added the following line as I've seen suggested on many forums:

options snd-hda-intel model=3stack

I've also tried substituting 3stack with ALC882, and many other options. I save the file. I reboot. Nothing.

I also reinstalled all the packages related to ALSA.

Kernal
---------

2.6.27-7-generic

Can anyone tell me what I may be omitting and/or doing wrong?

Thanks,
Ottovox

Last edited by ottovox; 10-31-2008 at 03:34 PM.
 
Old 11-01-2008, 06:59 PM   #2
Corbie85
LQ Newbie
 
Registered: Nov 2008
Posts: 1

Rep: Reputation: 0
Unhappy no sound as well - new user

I'm a relatively new user to linux and I also have no sound now that I updated to 8.10. Here is my info from lspci -vv

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Toshiba America Info Systems Device ff01
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 22
Region 0: Memory at dc440000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel


aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


Any help or advice would be greatly appreciated. Thank you!


Corbie
 
Old 11-01-2008, 10:20 PM   #3
jgil
LQ Newbie
 
Registered: Apr 2005
Location: New Zealand
Posts: 1

Rep: Reputation: 0
No sound: HDA Intel ALC882 A/D - Ubuntu 8.10 fresh install

Hi

This is what I found and it works for me
go to synaptic,settings,updates then open up back backport repo.
then install gnome-alsamixer and open gnome-alsamixer and adjust the settings

John
 
Old 11-02-2008, 01:49 AM   #4
ottovox
LQ Newbie
 
Registered: Oct 2008
Location: Seattle
Distribution: Ubuntu 8.10
Posts: 5

Original Poster
Rep: Reputation: 0
still no dice.

Hi John,

Thanks for the advice, but no luck.

I opened up Synaptic Package Manager/Settings/Repository/Updates - and selected backports. I updated the package list, installed the earlier gnome alsamixer. I also have the most recent version of alsamixer installed.

Again, I've made sure all playback faders are unmuted, and I've set the System/Preferences/Sound to autodetect (also tried all the other options as well to no avail). I have a dual boot, and sound on Windows works fine, so I know my speakers work.

Are you also using the ALC882? Was there anything else you did to get it to function?

Thanks...if anyone else has any advice, do tell. Been trying to solve this for about four days.

Cheers,
Ottovox
 
Old 11-02-2008, 07:44 PM   #5
xleqz
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
hi

I have the same hardware...
try this in your /etc/modprobe.d/alsa-base

options snd-hda-intel model=dell-m82

and restart you pc

if dont work, try all of this: http://pastebin.ca/1057656
 
Old 11-03-2008, 12:39 AM   #6
ottovox
LQ Newbie
 
Registered: Oct 2008
Location: Seattle
Distribution: Ubuntu 8.10
Posts: 5

Original Poster
Rep: Reputation: 0
...and the struggle continues (in silence)

Quote:
Originally Posted by xleqz View Post
hi

I have the same hardware...
try this in your /etc/modprobe.d/alsa-base

options snd-hda-intel model=dell-m82

and restart you pc

if dont work, try all of this: http://pastebin.ca/1057656
xleqz,

Thanks for the suggestions...I opened /etc/modprobe.d/alsa-base and tried dell-m82 to no avail...then I tried every single one of these...

3stack D945 3stack
5stack D945 5stack + SPDIF
intel-mac-v1 Intel Mac Type 1
intel-mac-v2 Intel Mac Type 2
intel-mac-v3 Intel Mac Type 3
intel-mac-v4 Intel Mac Type 4
intel-mac-v5 Intel Mac Type 5
macmini Intel Mac Mini (equivalent with type 3)
macbook Intel Mac Book (eq. type 5)
macbook-pro-v1 Intel Mac Book Pro 1st generation (eq. type 3)
macbook-pro Intel Mac Book Pro 2nd generation (eq. type 3)
imac-intel Intel iMac (eq. type 2)
imac-intel-20 Intel iMac (newer version) (eq. type 3)
dell-d81 Dell (unknown)
dell-d82 Dell (unknown)
dell-m81 Dell (unknown)

...one at a time, rebooting after each change. Still no sound. I'm just about completely stumped.

The only thing I've added in /etc/modprobe.d/alsa-base is the last line (in bold below)... Here's what the last several lines look like:

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel model=dell-m82

Anyone see anything weird or wrong in there? Any other ideas?

Thanks again for the suggestions...
Ottovox
 
Old 11-04-2008, 01:59 AM   #7
Kirenhob
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Hi !

I got a solution on my laptop Fujitsu with Ubuntu 8.10 :

sudo lspci -vv

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Fujitsu Siemens Computers Device 10ac
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 22
Region 0: Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Solution :
$sudo gedit /etc/modprobe.d/alsa-base
add that line :
options snd-hda-intel enable=1 index=0 model=fujitsu

save alsa-base, and do a :
$sudo /etc/init.d/alsa-utils restart

restart your computer

open the Volume Control, and check Speaker in the Preferences, and put the Speaker volume at its maximum

That's working here !
 
Old 11-05-2008, 11:06 AM   #8
click
LQ Newbie
 
Registered: Feb 2005
Distribution: Suse
Posts: 3

Rep: Reputation: 0
After I installed Ubuntu 8.10, I encountered with the sound problem with my TV card. Line-In was not working properly. I solved this issue by downloading the latest alsa driver. I recommend you to try the same, maybe it helps. Following link describes the steps very clearly.

https://help.ubuntu.com/community/HdaIntelSoundHowto
 
Old 11-09-2008, 08:18 AM   #9
Kirenhob
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Thank you Click !

I followed your link, have dowloaded and installed the new alsa-driver, lib and utils-1.0.18

I got only one warning after the alsa-driver make install :
"WARNING!!! The mixer channels for the ALSA driver are muted by default!!!
**************************************************************************
You would use some ALSA or OSS mixer to set the appropriate volume."

With :
$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Motorola Si3054
Codec: Realtek ALC880

I choose the "model=fujitsu"

and got no "azx_get_response timeout"... so no use of options "probe_mask=1 or 8"

In Volume Control, device is on "HDA Intel (Alsa mixer)" and all speaker and headphone are working.

On the recording side, I can blow into my microphone and hear that blowing in my headphone... but I can't get or hear other sounds... funny thing !
 
Old 11-21-2008, 09:04 PM   #10
noath
LQ Newbie
 
Registered: Nov 2008
Posts: 1

Rep: Reputation: 0
I registered here so I could also help everybody in the community.
Ok, here we go, I have a DELL Notebook D520 with the 82801G (ICH7 Family) Audio Device. Finally I got the sound working. Did just like Kinerhod said with a few quirks.

Solution :
$sudo gedit /etc/modprobe.d/alsa-base
add that line :
options snd-hda-intel enable=1 index=0 model=dell-m82

save alsa-base, and do a :
$sudo /etc/init.d/alsa-utils restart

restart your computer

open the Volume Control, and check Speaker in the Preferences, and put the Speaker volume at its maximum.

Hope it helps.
 
Old 12-07-2008, 03:20 AM   #11
sangelion
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
Thank you John,
It works on me
I have RealTex ALC883
Good Luck for all especially ottovox
 
  


Reply

Tags
intel, sound, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone problems with nForce 570 HDA w/ALC882 (long) TheOneKEA Linux - Hardware 8 12-02-2007 10:30 AM
Ubuntu Gusty Intel HDA....NO sound unless ACPI=off nate6874 Linux - Hardware 4 11-10-2007 03:17 PM
HDA intel Sound Card Sounds problems with intel sound card on Ubuntu zengingok Linux - Hardware 9 08-17-2007 10:52 AM
problems in HDA Intel Sound Card in Ubuntu Dapper zengingok Linux - Hardware 2 01-19-2007 03:24 PM
no sound; configuring hda-intel sound card in suse 10.1 crashes X MamaWombat Suse/Novell 1 05-30-2006 10:42 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration