LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-18-2009, 06:22 PM   #1
Nightspear
LQ Newbie
 
Registered: Mar 2009
Distribution: Ubuntu 8.10 (intrepid)
Posts: 20

Rep: Reputation: 0
No sound fron SB Audigy Sound card


I read the sticky on what to post with this but I couldn't get the /sbin/lspci log to come up
Quote:
mine@ubuntu:~$ /sbin/lspci
bash: /sbin/lspci: No such file or directory
mine@ubuntu:~$
and the dmseg is 13 pages long. I am quite new to a Linux based OS. Anyhow I can not get my Sandblaster Audigy to work in the Ubuntu 8.10 OS. I d/l all the codec with the following key and still no sound.

Quote:
~$ sudo wget http://www.medibuntu.org/sources.list.d/intrepid.list -O /etc/apt/sources.list.d/medibuntu.list && wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install -y ubuntu-restricted-extras non-free-codecs w32codecs totem-mozilla libdvdcss2
'
I checked the obvious and its all good. Speakers pluged in, turned up and have power. Master volume and program volume are turned up. So I turn to you gurus for more options.

If you need a log or anything please include details on how to retrieve it.
 
Old 03-18-2009, 07:20 PM   #2
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 86

Rep: Reputation: 15
You should see stuff in "dmesg", stuff below is for my E-MU 0404 PCI card - e.g:-
EMU10K1_Audigy 0000:02:07.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
ALSA sound/pci/emu10k1/emu10k1_main.c:812: emu1010: Special config.
ALSA sound/pci/emu10k1/emu10k1_main.c:851: emu1010: EMU_HANA_ID = 0x3f
ALSA sound/pci/emu10k1/emu10k1_main.c:870: emu1010: filename emu/emu0404.fw testing
EMU10K1_Audigy 0000:02:07.0: firmware: requesting emu/emu0404.fw
ALSA sound/pci/emu10k1/emu10k1_main.c:674: firmware size = 0xd67c
ALSA sound/pci/emu10k1/emu10k1_main.c:887: emu1010: Hana Firmware loaded
ALSA sound/pci/emu10k1/emu10k1_main.c:890: emu1010: Hana version: 1.1
ALSA sound/pci/emu10k1/emu10k1_main.c:895: emu1010: Card options = 0x1
ALSA sound/pci/emu10k1/emu10k1_main.c:897: emu1010: Card options = 0x1
ALSA sound/pci/emu10k1/emu10k1_main.c:936: emu1010: Card options3 = 0x1
ALSA sound/pci/emu10k1/emu10k1_main.c:219: Audigy2 value: Special config.
ALSA sound/pci/emu10k1/emufx.c:1522: EMU outputs on
ALSA sound/pci/emu10k1/emufx.c:1570: EMU2 inputs on

Also check what snd_* modules are loaded and that the mixer doesn't have the card muted.
 
Old 03-18-2009, 07:51 PM   #3
Nightspear
LQ Newbie
 
Registered: Mar 2009
Distribution: Ubuntu 8.10 (intrepid)
Posts: 20

Original Poster
Rep: Reputation: 0
sidboyce

I didnt see anything like your post in the log. I have attached it in and shrank it down with a smaller font. I hope this helps.
Attached Files
File Type: txt dmsg.txt (28.0 KB, 5 views)
 
Old 03-18-2009, 08:33 PM   #4
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 86

Rep: Reputation: 15
[ 18.455229] CA0106 0000:00:0a.0: PCI INT A -> Link[LNKC] -> GSI 5 (level, low) -> IRQ 5

[ 18.455275] snd-ca0106: Model 100a Rev 00000000 Serial 100a1102

So the card is detected, though dmesg seems to be set for sparse reporting. Can't find anything as to how to set verbose for it and /dev/dsp should be created. Also the fact that you are seeing the mixer controls suggests it's in working order.
I have a relative I've installed one of these ca0106-based cards for, but I can't get over that way for a few days to check how his mixer is set up. Quite often mixer controls are cryptic and take some messing with to get them to work. Best to turn all controls up fully and check nothing is ticked as muted.
 
Old 03-18-2009, 10:28 PM   #5
Nightspear
LQ Newbie
 
Registered: Mar 2009
Distribution: Ubuntu 8.10 (intrepid)
Posts: 20

Original Poster
Rep: Reputation: 0
Good to hear that it is detected. I appreciate all the help thus far sidboyce.I have already gone through the mixer and put all the controls to max level. I still have no sound. Honestly it is no hurry to get it set up. I have my mp3 player for music until all gets up and running. Although if there is anything you may need from my end just let me know.
 
Old 03-19-2009, 03:08 AM   #6
forestpixie
LQ Newbie
 
Registered: May 2007
Posts: 1

Rep: Reputation: 0
Possibly it is as simple as turning off the digital output if it has one. Double click the volume icon - go to the switches tab - check the Analog/Digital output is not enabled.
 
Old 03-19-2009, 03:52 AM   #7
gregvp
LQ Newbie
 
Registered: Dec 2006
Distribution: ARCH Linux
Posts: 12

Rep: Reputation: 2
Hi I have one of these Audigy Value cards with the CA0106 chip too.

In a terminal run 'alsamixer'. In alsamixer, use the left/right arrow keys to move around and the up/down ones to change settings. Press Tab to change the view from Playback to Capture to All and cycle.

On the Playback view: All four IEC958 things should be off -either [MM] or at 0. Set the 'Analog Front' at 45 or above. If you want to hear a mike or line-input source set the 'Capture Feedback' to 80. (Don't do this when recording, though - set it to 0 when recording input.)

Press Tab to get to the Capture view. Set 'Line in' or 'Mic' to 80 (leave unused inputs at 0 to reduce noise). Set 'Analog source' to 'Mic' or 'Line In', Set 'Digital source' to "i2s in" (IMPORTANT) and set 'shared mic/line in' according to what you have plugged in.

Edit: press Esc to get out of alsamixer - there is no "save settings" button or anything.

These settings should get you reasonable sound. Adjust to your taste.

Once you have it set up, do 'sudo alsactl store' to save the settings so that they will be restored on next boot-up -- although on my PC, KDE resets the settings when it starts up so I have to use alsamixer every time I startx :[

Edit 2: I found that alsamixer was the only thing that worked for me - KMix, alsamixergui, etc (all the GUI mixers) did not work.

Last edited by gregvp; 03-19-2009 at 04:14 AM. Reason: add vital instruction! :-)
 
Old 03-19-2009, 04:36 AM   #8
sovietpower
Member
 
Registered: Jun 2003
Distribution: Slackware64 14.1 and -current
Posts: 208

Rep: Reputation: 30
I also have a soundblaster audigy card, I use alsamixer to set the volumes and it works fine, although everytime I boot I have to reset the volume as there is a bug in the driver I think, I saw something in dmesg about it. Even using alsactl store does not fix this problem.
 
Old 03-19-2009, 05:01 AM   #9
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 86

Rep: Reputation: 15
My relative whose openSUSE box I setup only knows kmix and that works fine. I must check his box to see what kmix settings are. Mixer settings can seem like a black art at times or at least needing an audio engineer to interpret them.
One day I got curious and did a google search on IEC958 and discovered it was digital, there are also an array of input sources, sometimes difficult to figure out which needs to be selected, so some trial and error selections have to be done.
Perhaps one day some one with the knowledge will put out a detailed explanation of these settings so we will be able to interpret them for any sound card we come across.
 
Old 03-19-2009, 08:12 AM   #10
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Hi Nightspear.

I see that you have an onboard soundcard as well (VIA 82xx). Would you post the output of:
cat /proc/asound/cards

That will show us, and you , how the cards are ordered. You may find that the onboard card is set as card0, and the audigy one as card1. The pcspkr module that shows in your dmesg output can also be problematic, and may need to be dealt with.

Output also please for: lsmod | grep snd

No need to prefix with /sbin, as lspci, lsmod, lsusb, etc, have all been moved to different locations in Intrepid.

Are you using Ubuntu, or Kubuntu Intrepid 8.10 ?

Nigel. aka farpoint.
 
Old 03-19-2009, 03:41 PM   #11
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 86

Rep: Reputation: 15
Oops, I didn't pick those 2 up and was under the impression only one sound card was installed and searched only for Audigy in dmesg - makes a world difference as we don't know which sound card is card 0. If card 0 is the Via and card 1 is the Audigy, that explains a whole lot.
 
Old 03-20-2009, 09:19 AM   #12
Nightspear
LQ Newbie
 
Registered: Mar 2009
Distribution: Ubuntu 8.10 (intrepid)
Posts: 20

Original Poster
Rep: Reputation: 0
Sorry it took so long for me to reply, had a few things I needed to take care of. anyhow here is the log you requested Farpoint.
Quote:
mine@ubuntu:~$ cat /proc/asound/cards
0 [V8235 ]: VIA8233 - VIA 8235
VIA 8235 with VIA1612A at 0xb800, irq 5
1 [CA0106 ]: CA0106 - CA0106
Audigy SE [SB0570] at 0xa000 irq 5
mine@ubuntu:~$
my Audigy is in the "1" slot. I had completely forgotten about the on-board due to it not being not used in like forever.

Quote:
mine@ubuntu:~$ lsmod | grep snd
snd_ca0106 40480 1
snd_seq_dummy 10884 0
snd_via82xx 32536 3
gameport 19468 1 snd_via82xx
snd_ac97_codec 111652 2 snd_ca0106,snd_via82xx
snd_pcm_oss 46848 0
snd_mixer_oss 22784 1 snd_pcm_oss
snd_seq_oss 38528 0
snd_pcm 83204 4 snd_ca0106,snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_mpu401_uart 15360 1 snd_via82xx
snd_seq_midi 14336 0
snd_seq_midi_event 15232 2 snd_seq_oss,snd_seq_midi
snd_rawmidi 29824 3 snd_ca0106,snd_mpu401_uart,snd_seq_midi
snd_seq 57776 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29960 2 snd_pcm,snd_seq
snd_seq_device 15116 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 63268 20 snd_ca0106,snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_pcm,snd_mpu401_uart, snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ac97_bus 9856 1 snd_ac97_codec
soundcore 15328 1 snd
snd_page_alloc 16136 3 snd_ca0106,snd_via82xx,snd_pcm
mine@ubuntu:~$
Added a screenshot of system for verification of OS
Attached Images
File Type: jpg sys screen.jpg (24.8 KB, 3 views)

Last edited by Nightspear; 03-20-2009 at 10:47 AM. Reason: missed some requested info
 
Old 03-20-2009, 10:31 AM   #13
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Hi Nightspear.

Ok. You've got 2 choices then. Either get your audio apps to use hw1, rather than the default hw0, Or better, set some options lines at the bottom of /etc/modprobe.d/alsa-base, so as to re-order the cards, as below.

options snd-ca0106 index=0
options snd-via82xx index=1

Reboot, then rerun: cat /proc/asound/cards , and hopefully the audigy (ca0106) will now be card0.

If you have no intention to ever use the onboard soundcard, you may be able to disable it in the BIOS, and may find that the audigy card is automatically set as card0. Just a thought, but as I only have one soundcard on each of my 3 machines, I'm not sure of that.

You did not say if you are using Ubuntu, or Kubuntu. I asked because Ubuntu has pulseaudio installed, which may, or may not cause problems when you have 2 soundcards available.

If you keep both cards, but re-ordered, you can access them with alsamixer on the CLI, as below.

alsamixer -D hw:0 (which will shower mixer settings for the audigy card)
alsamixer -D hw:1 (mixer settings for the onboard VIA)

Let us know how you get on with the above.

Nigel. aka farpoint.
 
Old 03-20-2009, 11:12 AM   #14
Nightspear
LQ Newbie
 
Registered: Mar 2009
Distribution: Ubuntu 8.10 (intrepid)
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by farpoint View Post
Hi Nightspear.

Ok. You've got 2 choices then. Either get your audio apps to use hw1, rather than the default hw0, Or better, set some options lines at the bottom of /etc/modprobe.d/alsa-base, so as to re-order the cards, as below.

options snd-ca0106 index=0
options snd-via82xx index=1

Reboot, then rerun: cat /proc/asound/cards , and hopefully the audigy (ca0106) will now be card0.
I tried to set things the first way you suggested (see attachment of sound controls). Honestly I am still a beginner in linux so I am not exactly sure what I am changeing. I am not sure how to go about trying the second mod. I entered "/etc/modprobe.d/alsa-base" and received the no such file error. I then took off the "-base" and still got the same error.
Quote:
mine@ubuntu:~$ /etc/modprobe.d/alsa-base
bash: /etc/modprobe.d/alsa-base: Permission denied
mine@ubuntu:~$ /etc/modprobe.d/alsa
bash: /etc/modprobe.d/alsa: No such file or directory
mine@ubuntu:~$
I also tried to disable the on-board in bios but no such luck there either. I edited my last post for system details in the screen shot.
Attached Images
File Type: png Screenshot-Sound Preferences.png (46.8 KB, 5 views)

Last edited by Nightspear; 03-20-2009 at 11:19 AM.
 
Old 03-20-2009, 12:20 PM   #15
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Hi Nightspear.

Sorry. I should have given more detailed instructions, and please say whether you're using Ubuntu, or Kubuntu, as there are different editing apps for example, depending on whether you are using Ubuntu, or Kubuntu.

Back to the plot.

If you're using Ubuntu, with Gnome desktop, do the following. Open a terminal, and type:
sudo gedit
give your user password, and then gedit will open.
click on "Open", then click on File System on the newly opened window. then on the right, double click on etc, scroll down, and double click on modprobe.d, then double click on the alsa-base file.

OK so far?

Don't mess with the stuff that's in the file, as you are now working as root. Scroll down to the bottom of the file, Put the mouse cursor at the end of the last line, and do one left click with the mouse. Now press enter twice on the keyboard.

Now the mouse cursor should be at the beginning of a new line, with one empty line above. Now you can add the options lines, as below.

options snd-ca0106 index=0
press enter on the keyboard, when you have typed the above line (leave the spacebar alone, as you don't want whitespace between lines)

Now with the mouse cursor at the start of the next line, type:
options snd-via82xx index=1

Press enter again, then on Gedit's menu, click on "Save". There should be no complaints from Gedit. Now close Gedit, then exit Gnome's terminal.

Reboot the machine, which is the easiest way to go, and run:
cat /proc/asound/cards.

You should now see your audigy card set as card0

All the best.

Nigel. aka farpoint.
 
  


Reply

Tags
audigy, ca0106, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
Virtual surround sound (Audigy SE Sound Card) alan1s Linux - Newbie 3 08-09-2009 06:00 PM
Ubuntu Breezy No Sound on Audigy Sound Card rjcmi Ubuntu 14 03-10-2009 11:19 PM
Audigy sound card trackrat Mandriva 16 07-25-2004 12:38 AM
Can't get sound from Mandrake 9.1 with SoundBlaster Audigy 2 Sound Card... shortyzms Linux - Newbie 3 12-08-2003 05:36 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration