LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 03-28-2011, 05:13 PM   #1
langelgjm
LQ Newbie
 
Registered: Jan 2010
Location: Arlington, VA
Distribution: LinHES, Damn Small Linux
Posts: 1

Rep: Reputation: 0
No signal from Apple TV to DVI Monitor (Xorg does not get EDID information)


I inherited a 1st generation Apple TV and decided to crack it open and try to turn it into a MythTV frontend. After several attempts, I eventually got LinHES (formerly KnoppMyth, a bundled MythTV distribution based on Arch Linux) 6.04.00 installed on a new internal hard drive, and I use a USB stick with atv-bootloader, a linux bootloader for the Apple TV, to boot.

I want to use a 22" widescreen DVI monitor for output. The Apple TV has two video outputs: component, and HDMI. I bought an HDMI to DVI adapter, and I used that during my install attempts while attached to an 18" DVI monitor without any trouble.

However, if I attach the Apple TV to the 22" DVI monitor, I cannot get any output at all. No output during boot (either from the USB stick or LinHES), no X output, nothing. The monitor complains there is no signal. I know the monitor works - I've tested the DVI input with both another Mac and my other LinHES machine.

Even stranger, if I boot the Apple TV while attached to the 18" monitor, I get normal output (1280x1024). Then, if I unplug the DVI cable and plug it into the 22" monitor, I get output on the 22" monitor! But it is stretched, not the native 1680x1050 (I guess because the machine still thinks it's attached to the 18" monitor).

So I know the card works, I know the monitor works, and I know the card can actually display output on the monitor... during startup, X complains about not being able to read EDID information from the monitor. I don't know why. It can read the EDID from the 18" monitor. My other Linux machine reads the EDID from the 22" monitor just fine. I dumped the EDID on the other machine, and pointed xorg.conf to use the dumped file, but it hasn't made a difference. I've pasted my X log below.

Any thoughts?

Code:
X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.26-ARCH i686
Current Operating System: Linux appletv 2.6.28-LinHES #1 SMP PREEMPT Sun Nov 1 06:47:02 UTC 2009 i686
Build Date: 12 January 2009  10:25:53PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 28 08:41:15 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(**) Option "AutoAddDevices" "False"
(**) Not automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
   /usr/share/fonts/misc,
   /usr/share/fonts/100dpi:unscaled,
   /usr/share/fonts/75dpi:unscaled,
   /usr/share/fonts/TTF,
   /usr/share/fonts/Type1
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d59a0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 4.1
   X.Org XInput driver : 2.1
   X.Org Server Extension : 1.1
   X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 4

(--) PCI:*(0@1:0:0) nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] rev 161, Mem @ 0x21000000/0, 0x10000000/0, 0x20000000/0
(II) System resource ranges:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
   compiled for 1.5.3, module version = 2.1.0
   Module class: X.Org Font Renderer
   ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Server Extension
(II) NVIDIA GLX Module  96.43.14  Sun Nov  8 18:24:17 PST 2009
(II) Loading extension GLX
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.0.0
   ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Video Driver
(II) LoadModule: "kbd"

(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.3.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "mouse"

(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.3.0
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 2.1
(II) NVIDIA dlloader X Driver  96.43.14  Sun Nov  8 18:12:51 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) NVIDIA X compatibility module for ABI 4.0 built from git commit 98249dfa98b53a238b7d881beb5ec8b85f28ecd0 (server-1.5-branch)
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"

(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "1"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "CustomEDID" "DPF-0:/etc/X11/acer_x223w_edid.bin"
(**) NVIDIA(0): Option "UseDisplayDevice" "DFP-0"
(**) NVIDIA(0): Option "DPI" "100 x 100"
(**) NVIDIA(0): Option "ModeValidation" "NoDFPNativeResolutionCheck"
(==) NVIDIA(0): Using HW cursor
(**) NVIDIA(0): Enabling RENDER acceleration
(==) NVIDIA(0): Video key set to default value of 0x101fe
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-0
(II) NVIDIA(0): NVIDIA GPU GeForce Go 7300 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(II) NVIDIA(0): GPU Architecture: 0x40
(II) NVIDIA(0): GPU Implementation: 0x46
(II) NVIDIA(0): GPU Revision: 0xa3
(--) NVIDIA(0): VideoBIOS: 05.72.22.68.00
(--) NVIDIA(0): Found 2 CRTCs on board
(II) NVIDIA(0): Supported display device(s): DFP-0, TV-0
(II) NVIDIA(0): Bus detected as PCI Express
(II) NVIDIA(0): Detected PCI Express Link width: 2X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): VPES : 3
(II) NVIDIA(0): SPS  : 4
(II) NVIDIA(0):
(II) NVIDIA(0): Mode timing constraints for  : GeForce Go 7300
(II) NVIDIA(0): Maximum mode timing values   :
(II) NVIDIA(0):     Horizontal Visible Width : 8192
(II) NVIDIA(0):     Horizontal Blank Start   : 8192
(II) NVIDIA(0):     Horizontal Blank Width   : 4096
(II) NVIDIA(0):     Horizontal Sync Start    : 8184
(II) NVIDIA(0):     Horizontal Sync Width    : 504
(II) NVIDIA(0):     Horizontal Total Width   : 8224
(II) NVIDIA(0):     Vertical Visible Height  : 8192
(II) NVIDIA(0):     Vertical Blank Start     : 8192
(II) NVIDIA(0):     Vertical Blank Width     : 256
(II) NVIDIA(0):     Veritcal Sync Start      : 8191
(II) NVIDIA(0):     Vertical Sync Width      : 15
(II) NVIDIA(0):     Vertical Total Height    : 8193
(II) NVIDIA(0):
(II) NVIDIA(0): Minimum mode timing values   :
(II) NVIDIA(0):     Horizontal Total Width   : 40
(II) NVIDIA(0):     Vertical Total Height    : 2
(II) NVIDIA(0):
(II) NVIDIA(0): Mode timing alignment        :
(II) NVIDIA(0):     Horizontal Visible Width : multiples of 8
(II) NVIDIA(0):     Horizontal Blank Start   : multiples of 8
(II) NVIDIA(0):     Horizontal Blank Width   : multiples of 8
(II) NVIDIA(0):     Horizontal Sync Start    : multiples of 8
(II) NVIDIA(0):     Horizontal Sync Width    : multiples of 8
(II) NVIDIA(0):     Horizontal Total Width   : multiples of 8
(II) NVIDIA(0):
(--) NVIDIA(0): Connected display device(s) on GeForce Go 7300 at PCI:1:0:0:
(--) NVIDIA(0):     DFP-0
(--) NVIDIA(0): DFP-0: 165.0 MHz maximum pixel clock
(--) NVIDIA(0): DFP-0: Internal Single Link TMDS
(--) NVIDIA(0): DFP-0: Native FlatPanel Scaling is not supported
(--) NVIDIA(0): DFP-0: DFP modes are not limited to 60 Hz refresh rate
(--) NVIDIA(0):
(--) NVIDIA(0): --- EDID for DFP-0 ---
(--) NVIDIA(0):
(--) NVIDIA(0): No EDID Available.
(--) NVIDIA(0):
(--) NVIDIA(0): --- End of EDID for DFP-0 ---
(--) NVIDIA(0):
(II) NVIDIA(0): Mode Validation Overrides for DFP-0:
(II) NVIDIA(0):     NoDFPNativeResolutionCheck
(II) NVIDIA(0): Frequency information for DFP-0:
(II) NVIDIA(0):   HorizSync   : 30.000-82.000 kHz
(II) NVIDIA(0):   VertRefresh : 56.000-76.000 Hz
(II) NVIDIA(0):     (HorizSync from HorizSync in X Config Monitor section)
(II) NVIDIA(0):     (VertRefresh from VertRefresh in X Config Monitor
(II) NVIDIA(0):     section)
(II) NVIDIA(0):
(II) NVIDIA(0): --- Building ModePool for DFP-0 ---
(II) NVIDIA(0):
(II) NVIDIA(0): Native backend timings for DFP-0:
(II) NVIDIA(0):   640 x 480 @ 60 Hz
(II) NVIDIA(0):     Pixel Clock      : 25.18 MHz
(II) NVIDIA(0):     HRes, HSyncStart :  640,  656
(II) NVIDIA(0):     HSyncEnd, HTotal :  752,  800
(II) NVIDIA(0):     VRes, VSyncStart :  480,  490
(II) NVIDIA(0):     VSyncEnd, VTotal :  492,  525
(II) NVIDIA(0):     H/V Polarity     : +/+
(II) NVIDIA(0):
(II) NVIDIA(0):   Validating Mode "1680x1050":
(II) NVIDIA(0):     1680 x 1050 @ 60 Hz
(II) NVIDIA(0):     Mode Source: X Configuration file ModeLine
(II) NVIDIA(0):       Pixel Clock      : 146.00 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1680, 1784
(II) NVIDIA(0):       HSyncEnd, HTotal : 1960, 2240
(II) NVIDIA(0):       VRes, VSyncStart : 1050, 1053
(II) NVIDIA(0):       VSyncEnd, VTotal : 1059, 1089
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):     Mode is valid.
(II) NVIDIA(0):
(WW) NVIDIA(0): Unable to use mode "1680x1050" for DFP-0; cannot compute
(WW) NVIDIA(0):     backend DFP timings (mode is larger than native backend
(WW) NVIDIA(0):     640 x 480).
(II) NVIDIA(0):   Validating Mode "640x350":
(II) NVIDIA(0):     640 x 350 @ 85 Hz
(II) NVIDIA(0):     Mode Source: X Server
(II) NVIDIA(0):       Pixel Clock      : 31.50 MHz
(II) NVIDIA(0):       HRes, HSyncStart :  640,  672
(II) NVIDIA(0):       HSyncEnd, HTotal :  736,  832
(II) NVIDIA(0):       VRes, VSyncStart :  350,  382
(II) NVIDIA(0):       VSyncEnd, VTotal :  385,  445
(II) NVIDIA(0):       H/V Polarity     : +/-
(WW) NVIDIA(0):     Mode is rejected: VertRefresh (85.1 Hz) out of range
(WW) NVIDIA(0):     (56.000-76.000 Hz).
(II) NVIDIA(0):

[snip]

(II) NVIDIA(0):
(II) NVIDIA(0):   Validating Mode "1600x1200":
(II) NVIDIA(0):     1600 x 1200 @ 60 Hz
(II) NVIDIA(0):     Mode Source: VESA
(II) NVIDIA(0):       Pixel Clock      : 162.00 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1600, 1664
(II) NVIDIA(0):       HSyncEnd, HTotal : 1856, 2160
(II) NVIDIA(0):       VRes, VSyncStart : 1200, 1201
(II) NVIDIA(0):       VSyncEnd, VTotal : 1204, 1250
(II) NVIDIA(0):       H/V Polarity     : +/+
(WW) NVIDIA(0):     Mode is rejected: Mode (1600 x 1200) is too large for
(WW) NVIDIA(0):     user-requested virtual screen size (1680 x 1050).

[snip]

(II) NVIDIA(0):
(II) NVIDIA(0): --- Done building ModePool for DFP-0 ---
(II) NVIDIA(0):
(II) NVIDIA(0):
(II) NVIDIA(0): --- Modes in ModePool for DFP-0 ---
(II) NVIDIA(0): "nvidia-auto-select" :  640 x  480 @  75.0 Hz  (from: X Server, VESA)
(II) NVIDIA(0): "640x480"            :  640 x  480 @  75.0 Hz  (from: X Server, VESA)
(II) NVIDIA(0): "640x480_75"         :  640 x  480 @  75.0 Hz  (from: X Server, VESA)
(II) NVIDIA(0): "640x480_73"         :  640 x  480 @  72.8 Hz  (from: X Server, VESA)
(II) NVIDIA(0): "640x480d60"         :  640 x  480 @  60.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "640x480_60"         :  640 x  480 @  60.0 Hz  (from: VESA)
(II) NVIDIA(0): "576x432"            :  576 x  432 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "576x432d75"         :  576 x  432 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "576x432d75_0"       :  576 x  432 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "576x432d70"         :  576 x  432 @  70.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "576x432d60"         :  576 x  432 @  60.1 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "512x384"            :  512 x  384 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "512x384d75"         :  512 x  384 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "512x384d70"         :  512 x  384 @  70.1 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "512x384d60"         :  512 x  384 @  60.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "416x312"            :  416 x  312 @  74.7 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "416x312d75"         :  416 x  312 @  74.7 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "400x300"            :  400 x  300 @  75.1 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "400x300d75"         :  400 x  300 @  75.1 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "400x300d72"         :  400 x  300 @  72.2 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "400x300d60"         :  400 x  300 @  60.3 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "400x300d56"         :  400 x  300 @  56.3 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "320x240"            :  320 x  240 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "320x240d75"         :  320 x  240 @  75.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "320x240d73"         :  320 x  240 @  72.8 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): "320x240d60"         :  320 x  240 @  60.0 Hz DoubleScan  (from: X Server)
(II) NVIDIA(0): --- End of ModePool for DFP-0: ---
(II) NVIDIA(0):
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Requested modes:
(II) NVIDIA(0):     "1680x1050"
(II) NVIDIA(0):     "1280x960"
(II) NVIDIA(0):     "1280x720"
(WW) NVIDIA(0): No valid modes for "1680x1050"; removing.
(WW) NVIDIA(0): No valid modes for "1280x960"; removing.
(WW) NVIDIA(0): No valid modes for "1280x720"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): MetaMode "nvidia-auto-select":
(II) NVIDIA(0):     Bounding Box: [0, 0, 640, 480]
(II) NVIDIA(0):     DFP-0: "nvidia-auto-select"
(II) NVIDIA(0):         Size          : 640 x 480
(II) NVIDIA(0):         Offset        : +0 +0
(II) NVIDIA(0):         Panning Domain: @ 640 x 480
(II) NVIDIA(0):         Position      : [0, 0, 640, 480]
(**) NVIDIA(0): Virtual screen size configured to be 1680 x 1050
(II) NVIDIA(0):
(II) NVIDIA(0): Implicitly adding the following modes to X Screen 0 (these
(II) NVIDIA(0):     will be available via XRandR and XF86VidMode):
(II) NVIDIA(0):
(II) NVIDIA(0): "640x480_73"   :  640 x  480 @  72.8 Hz
(II) NVIDIA(0): "640x480d60"   :  640 x  480 @  60.0 Hz DoubleScan
(II) NVIDIA(0): "640x480_60"   :  640 x  480 @  60.0 Hz
(II) NVIDIA(0): "576x432"      :  576 x  432 @  75.0 Hz DoubleScan
(II) NVIDIA(0): "576x432d75_0" :  576 x  432 @  75.0 Hz DoubleScan
(II) NVIDIA(0): "576x432d70"   :  576 x  432 @  70.0 Hz DoubleScan
(II) NVIDIA(0): "576x432d60"   :  576 x  432 @  60.1 Hz DoubleScan
(II) NVIDIA(0): "512x384"      :  512 x  384 @  75.0 Hz DoubleScan
(II) NVIDIA(0): "512x384d70"   :  512 x  384 @  70.1 Hz DoubleScan
(II) NVIDIA(0): "512x384d60"   :  512 x  384 @  60.0 Hz DoubleScan
(II) NVIDIA(0): "416x312"      :  416 x  312 @  74.7 Hz DoubleScan
(II) NVIDIA(0): "400x300"      :  400 x  300 @  75.1 Hz DoubleScan
(II) NVIDIA(0): "400x300d72"   :  400 x  300 @  72.2 Hz DoubleScan
(II) NVIDIA(0): "400x300d60"   :  400 x  300 @  60.3 Hz DoubleScan
(II) NVIDIA(0): "400x300d56"   :  400 x  300 @  56.3 Hz DoubleScan
(II) NVIDIA(0): "320x240"      :  320 x  240 @  75.0 Hz DoubleScan
(II) NVIDIA(0): "320x240d73"   :  320 x  240 @  72.8 Hz DoubleScan
(II) NVIDIA(0): "320x240d60"   :  320 x  240 @  60.0 Hz DoubleScan
(II) NVIDIA(0):
(**) NVIDIA(0): DPI set to (100, 100); computed from "DPI" X config option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): kernel module enabled successfully
(II) NVIDIA(0): Memory mapped
(II) NVIDIA(0): Interrupts enabled
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) NVIDIA(0): DFP-0 assigned CRTC 0
(II) NVIDIA(0): First mode initialized
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Visuals set up
(II) NVIDIA(0): Pixmap depths set up
(II) NVIDIA(0): GLX visuals set up
(II) NVIDIA(0): Framebuffer set up
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): Default colormap initialized.
(II) NVIDIA(0): Palette loaded
(**) Option "dpms" "true"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) NVIDIA(0): Composite wrapper disabled.
(II) NVIDIA(0): Screen initialization complete
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(**) Option "Protocol" "auto"
(**) Option "Device" "/dev/psaux"
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(**) Mouse0: Device: "/dev/psaux"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(**) Option "Device" "/dev/psaux"
(**) Option "Device" "/dev/psaux"
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) config/hal: Adding input device Macintosh mouse button emulation
(EE) config/hal: NewInputDeviceRequest failed
And here is my xorg.conf. I've tried a bunch of different options in here, so this is just the current state, but nothing has made any difference.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Sun Nov  8 18:24:28 PST 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"

#    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
#    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AutoAddDevices" "False"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"

#    HorizSync       
#    VertRefresh   
#INSERT MODELINE
# 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
#   Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
    ModeLine       "1680x1050" 146.0 1680 1784 1960 2240 1050 1053 1059 1089
    Option         "DPMS" "true"
#    DisplaySize  203 153
EndSection

Section "Device"

#    Driver         "nvidia"
#END OPTIONS
#    Option "FlatPanelProperties" "Scaling = centered, Dithering = enabled"
#    Option "DigitalVibrance" "0"
#    Option "TransparentIndex" "0"
#    Option  "CursorShadowAlpha" "64"
#    Option  "CursorShadowXOffset"  "4"
#    Option  "UseEdidFreqs" "True"
#    Option  "NvAGP" "1"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DPI" "100 x 100"
    Option         "NoLogo" "1"
#INSERT HERE
    Option         "ConnectedMonitor" "DFP"
    Option         "UseDisplayDevice" "DFP-0"
    Option         "CustomEDID" "DPF-0:/etc/X11/acer_x223w_edid.bin"
    Option         "ModeValidation" "NoDFPNativeResolutionCheck"
#    Option "ModeValidation" "NoDFPNativeResolutionCheck, NoVirtualSizeCheck,NoMaxPClkCheck,NoHorizSyncCheck ,NoVertRefreshCheck,NoWidthAlignmentCheck"
    SubSection     "Display"

#    Modes "1680x1050_60.00"
        Viewport    0 0
        Virtual     1680 1050
        Depth       24
        Modes      "1680x1050" "1280x960" "1280x720"
    EndSubSection
EndSection
For reference:

Output of uname -a:

Code:
Linux appletv 2.6.28-LinHES #1 SMP PREEMPT Sun Nov 1 06:47:02 UTC 2009 i686 Genuine Intel(R) processor 1.00GHz GenuineIntel GNU/Linux
Relevant output of lscpi:

Code:
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
 
Old 03-29-2011, 06:06 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 219Reputation: 219Reputation: 219
Don't know if this is relevant, but on my desktop system, I need the line
Code:
	DisplaySize  432	270
in the monitor section (I put it right above the HorizSync and VertRefresh lines) in order for my monitor (which does not report an EDID) to display with its full resolution. The display size is in millimeters - I measured it with a ruler, then adjusted the numbers slightly to the proper aspect ratio.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to use the DVI port of Viewsonic VA1912wb Monitor; get "Analog - No Signal" Larry@taxonly.com Linux - Newbie 1 01-14-2011 11:20 PM
Incorrect resolution on external monitor w/ custom EDID (Fedora 13, GeForce GT 330M) ESC201 Linux - Software 0 08-03-2010 05:49 PM
EDID values differ from Monitor size and spec irj Linux - Newbie 0 10-07-2008 01:21 PM
VIDEO - Syncmaster 204B with Radeon driver on DVI connection blinking EDID DDC Debian_Poland Linux - Hardware 0 06-08-2008 06:09 AM
Getting Nvidia DVI output working without EDID xaos5 Linux - Hardware 2 03-02-2008 10:51 AM


All times are GMT -5. The time now is 08:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration