LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-03-2007, 12:03 AM   #1
hoofer
LQ Newbie
 
Registered: Jun 2005
Location: Brazil
Distribution: Slackware, Slamd64
Posts: 28

Rep: Reputation: 16
No mic on alsa (hda-intel)


I'm trying to get the sound working on my HP DV9000 laptop.
I'm using Slamd64 11.0 and the 2.6.21 kernel.
I've tried using the drivers that came with the kernel (1.0.11), and the latest stable (1.0.13), dev (1.0.14rc3), and hg from May 2nd. In all cases, I can play sounds, but the mics don't work (Both internal and external).
Here's the relevant output from lspci:
Code:
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
alsaconf picks this correctly, but that's it...

Anybody got this working?
 
Old 05-04-2007, 12:06 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
You can try adding
to your /etc/modules.d/alsa maybe something different in slamd
options snd-hda-intel position_fix=1
then
update-modules
 
Old 05-05-2007, 08:58 PM   #3
hoofer
LQ Newbie
 
Registered: Jun 2005
Location: Brazil
Distribution: Slackware, Slamd64
Posts: 28

Original Poster
Rep: Reputation: 16
I tried it, but it still doesn't work.
 
Old 06-05-2007, 02:36 PM   #4
hoofer
LQ Newbie
 
Registered: Jun 2005
Location: Brazil
Distribution: Slackware, Slamd64
Posts: 28

Original Poster
Rep: Reputation: 16
The latest alsa (1.0.14) fixed it
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with HDA Intel and Mic Input on OpenSuse 10.2 Ossah Linux - Hardware 1 04-28-2007 11:20 PM
ALSA + Intel HDA + Recording = bad squealing! alandd Linux - Hardware 5 12-29-2006 01:46 AM
Alsa and probing snd-hda-intel aikempshall Slackware 2 10-29-2006 05:28 AM
Alsa hda-intel Sigmatel Audio Amuro-Ray2020 Linux - Newbie 2 05-02-2006 07:19 AM
Intel HDA and ALSA problems SLaCk_KiD Linux - Software 0 09-22-2005 03:22 PM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration