LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-01-2007, 06:09 PM   #1
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
No input ALSA 1.0.14rc2 SUSE10.2


Quite a while ago I had OpenSUSE 10.1 running on my laptop (Dell XPS M1210) and I was able to use the sound card perfectly. When I updated to 10.2 I lost the ability to use the line in. After reading about some issues with earlier versions of the ALSA driver, I updated to 1.0.14rc2, but I still have the same problem. I've played around with both Kmix and alsamixer and also with the permissions on the sound device files, but I can never seem to get it to work properly.

Here's the output from the aadebug script on the ALSA Wiki:
Code:
ALSA Audio Debug v0.1.0 - Thu Mar  1 18:38:44 EST 2007
http://alsa.opensrc.org/aadebug
http://www.gnu.org/licenses/gpl.txt

Kernel ----------------------------------------------------
Linux linux-8ayi 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 i686 i686 i386 GNU/Linux

Loaded Modules --------------------------------------------
snd_seq_dummy           8068  0
snd_pcm_oss            47232  1
snd_mixer_oss          20992  1 snd_pcm_oss
snd_seq                56688  1 snd_seq_dummy
snd_seq_device         12556  2 snd_seq_dummy,snd_seq
snd_hda_intel          24856  5
snd_hda_codec         200064  1 snd_hda_intel
snd_pcm                81284  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              26116  3 snd_seq,snd_pcm
snd                    59784  15 snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
snd_page_alloc         14088  2 snd_hda_intel,snd_pcm

Proc Config -----------------------------------------------
CONFIG_SOUND=m
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_RTCTIMER=m
CONFIG_SND_SEQ_RTCTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VERBOSE_PRINTK=y
CONFIG_SND_DEBUG=y
# CONFIG_SND_DEBUG_DETECT is not set
# CONFIG_SND_PCM_XRUN_DEBUG is not set
CONFIG_SND_MPU401_UART=m
CONFIG_SND_OPL3_LIB=m
CONFIG_SND_OPL4_LIB=m
CONFIG_SND_VX_LIB=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_AC97_BUS=m
CONFIG_SND_DUMMY=m
CONFIG_SND_VIRMIDI=m
CONFIG_SND_MTPAV=m
CONFIG_SND_SERIAL_U16550=m
CONFIG_SND_MPU401=m
CONFIG_SND_AD1848_LIB=m
CONFIG_SND_CS4231_LIB=m
CONFIG_SND_ADLIB=m
CONFIG_SND_AD1816A=m
CONFIG_SND_AD1848=m
CONFIG_SND_ALS100=m
CONFIG_SND_AZT2320=m
CONFIG_SND_CMI8330=m
CONFIG_SND_CS4231=m
CONFIG_SND_CS4232=m
CONFIG_SND_CS4236=m
CONFIG_SND_DT019X=m
CONFIG_SND_ES968=m
CONFIG_SND_ES1688=m
CONFIG_SND_ES18XX=m
CONFIG_SND_GUS_SYNTH=m
CONFIG_SND_GUSCLASSIC=m
CONFIG_SND_GUSEXTREME=m
CONFIG_SND_GUSMAX=m
CONFIG_SND_INTERWAVE=m
CONFIG_SND_INTERWAVE_STB=m
CONFIG_SND_OPL3SA2=m
CONFIG_SND_OPTI92X_AD1848=m
CONFIG_SND_OPTI92X_CS4231=m
CONFIG_SND_OPTI93X=m
CONFIG_SND_MIRO=m
CONFIG_SND_SB8=m
CONFIG_SND_SB16=m
CONFIG_SND_SBAWE=m
CONFIG_SND_SB16_CSP=y
CONFIG_SND_SGALAXY=m
CONFIG_SND_SSCAPE=m
CONFIG_SND_WAVEFRONT=m
CONFIG_SND_AD1889=m
CONFIG_SND_ALS300=m
CONFIG_SND_ALS4000=m
CONFIG_SND_ALI5451=m
CONFIG_SND_ATIIXP=m
CONFIG_SND_ATIIXP_MODEM=m
CONFIG_SND_AU8810=m
CONFIG_SND_AU8820=m
CONFIG_SND_AU8830=m
CONFIG_SND_AZT3328=m
CONFIG_SND_BT87X=m
# CONFIG_SND_BT87X_OVERCLOCK is not set
CONFIG_SND_CA0106=m
CONFIG_SND_CMIPCI=m
CONFIG_SND_CS4281=m
CONFIG_SND_CS46XX=m
CONFIG_SND_CS46XX_NEW_DSP=y
CONFIG_SND_CS5535AUDIO=m
CONFIG_SND_DARLA20=m
CONFIG_SND_GINA20=m
CONFIG_SND_LAYLA20=m
CONFIG_SND_DARLA24=m
CONFIG_SND_GINA24=m
CONFIG_SND_LAYLA24=m
CONFIG_SND_MONA=m
CONFIG_SND_MIA=m
CONFIG_SND_ECHO3G=m
CONFIG_SND_INDIGO=m
CONFIG_SND_INDIGOIO=m
CONFIG_SND_INDIGODJ=m
CONFIG_SND_EMU10K1=m
CONFIG_SND_EMU10K1X=m
CONFIG_SND_ENS1370=m
CONFIG_SND_ENS1371=m
CONFIG_SND_ES1938=m
CONFIG_SND_ES1968=m
CONFIG_SND_FM801=m
CONFIG_SND_FM801_TEA575X_BOOL=y
CONFIG_SND_FM801_TEA575X=m
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDSP=m
CONFIG_SND_HDSPM=m
CONFIG_SND_ICE1712=m
CONFIG_SND_ICE1724=m
CONFIG_SND_INTEL8X0=m
CONFIG_SND_INTEL8X0M=m
CONFIG_SND_KORG1212=m
CONFIG_SND_MAESTRO3=m
CONFIG_SND_MIXART=m
CONFIG_SND_NM256=m
CONFIG_SND_PCXHR=m
CONFIG_SND_RIPTIDE=m
CONFIG_SND_RME32=m
CONFIG_SND_RME96=m
CONFIG_SND_RME9652=m
CONFIG_SND_SONICVIBES=m
CONFIG_SND_TRIDENT=m
CONFIG_SND_VIA82XX=m
CONFIG_SND_VIA82XX_MODEM=m
CONFIG_SND_VX222=m
CONFIG_SND_YMFPCI=m
CONFIG_SND_USB_AUDIO=m
CONFIG_SND_USB_USX2Y=m
CONFIG_SND_VXPOCKET=m
CONFIG_SND_PDAUDIOCF=m
CONFIG_SOUND_PRIME=m
CONFIG_SOUND_BT878=m
CONFIG_SOUND_EMU10K1=m
# CONFIG_SOUND_FUSION is not set
CONFIG_SOUND_ES1371=m
CONFIG_SOUND_ICH=m
CONFIG_SOUND_TRIDENT=m
# CONFIG_SOUND_MSNDCLAS is not set
# CONFIG_SOUND_MSNDPIN is not set
CONFIG_SOUND_VIA82CXXX=m
CONFIG_SOUND_OSS=m
CONFIG_SOUND_TRACEINIT=y
CONFIG_SOUND_DMAP=y
# CONFIG_SOUND_AD1816 is not set
CONFIG_SOUND_AD1889=m
CONFIG_SOUND_ADLIB=m
CONFIG_SOUND_ACI_MIXER=m
CONFIG_SOUND_CS4232=m
CONFIG_SOUND_SSCAPE=m
CONFIG_SOUND_VMIDI=m
CONFIG_SOUND_TRIX=m
CONFIG_SOUND_MSS=m
CONFIG_SOUND_MPU401=m
CONFIG_SOUND_NM256=m
CONFIG_SOUND_PAS=m
CONFIG_SOUND_PSS=m
CONFIG_SOUND_SB=m
CONFIG_SOUND_YM3812=m
CONFIG_SOUND_OPL3SA2=m
CONFIG_SOUND_UART6850=m
CONFIG_SOUND_AEDSP16=m
CONFIG_SOUND_TVMIXER=m
CONFIG_SOUND_KAHLUA=m

Modprobe Conf ---------------------------------------------
# remove this if sound is configured
#alias sound-slot-1 nvaudio

Proc Asound -----------------------------------------------
Advanced Linux Sound Architecture Driver Version 1.0.14rc2.
Compiled on Mar  1 2007 for kernel 2.6.18.2-34-default (SMP).
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdfebc000 irq 50
  0: [ 0]   : control
  1:        : sequencer
 16: [ 0- 0]: digital audio playback
 17: [ 0- 1]: digital audio playback
 24: [ 0- 0]: digital audio capture
 33:        : timer
cat: /proc/asound/hwdep: No such file or directory
00-01: STAC92xx Digital : STAC92xx Digital : playback 1
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2
Client info
  cur  clients : 2
  peak clients : 3
  max  clients : 192

Client   0 : "System" [Kernel]
  Port   0 : "Timer" (Rwe-)
  Port   1 : "Announce" (R-e-)
Client  14 : "Midi Through" [Kernel]
  Port   0 : "Midi Through Port-0" (RWe-)

Dev Snd ---------------------------------------------------
controlC0  pcmC0D0c  pcmC0D0p  pcmC0D1p  seq  timer

CPU -------------------------------------------------------
model name      : Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
cpu MHz         : 1000.000
model name      : Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
cpu MHz         : 1000.000

RAM -------------------------------------------------------
MemTotal:      1026444 kB
SwapTotal:     2048248 kB

Hardware --------------------------------------------------
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
 
Old 03-01-2007, 08:10 PM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Have you tried using the alsaconf command? You'll still need to do some fine-tuning after that.
 
Old 03-01-2007, 11:22 PM   #3
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jay73
Have you tried using the alsaconf command? You'll still need to do some fine-tuning after that.
Yes, I have tried that, but still no input. I do get output fine though.
 
Old 03-02-2007, 12:20 AM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Sorry, no clue. Are you sure line-in is not simply disabled? If you right-click on the volume control item, you can cross out / activate certain functions as well as show items that are not shown by default. Have you done that as well?
 
Old 03-02-2007, 08:35 AM   #5
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jay73
Sorry, no clue. Are you sure line-in is not simply disabled? If you right-click on the volume control item, you can cross out / activate certain functions as well as show items that are not shown by default. Have you done that as well?
Tried everything.
 
Old 03-02-2007, 09:53 AM   #6
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Weird. So you tried changing permissions on the audio devices already. Supposing you haven't changed too much yet, you could try adding yourself to the audio group instead. That way you would be absolutely sure that no file was overlooked. But that's all the advice I have left to offer I'm afraid.
 
Old 03-02-2007, 10:33 AM   #7
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jay73
Weird. So you tried changing permissions on the audio devices already. Supposing you haven't changed too much yet, you could try adding yourself to the audio group instead. That way you would be absolutely sure that no file was overlooked. But that's all the advice I have left to offer I'm afraid.
That's how I'm setup right now. First I chmoded all sound devices 777, after that didn't work I just reverted back to the original permissions and added myself to the audio group, but still no input.
 
Old 03-03-2007, 10:52 PM   #8
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Bump......
 
Old 03-05-2007, 03:59 PM   #9
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Anyone????
 
Old 03-20-2007, 01:34 PM   #10
rpg
Member
 
Registered: Dec 2002
Distribution: OpenSUSE
Posts: 58

Rep: Reputation: 15
same problem

Quote:
Originally Posted by pdeman2
Anyone????

I think I have the same problem as you. I have a Mandriva 2007.0 x86_64 system, and would like to use gramofile to record some old vinyl. I can't seem to get anything off of line-in. Other than line-in, the card (‎Indel ICH8 HD Audio DID) seems to work fine.

I'm not sure I can be of help other than to suffer with you, though --- I find the sound configuration stuff absolutely bewildering.

What are you using to test the line-in, by the way?
 
Old 03-20-2007, 05:21 PM   #11
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Well, I'm glad to see that someone else is having the same issue.
Quote:
Originally Posted by rpg
What are you using to test the line-in, by the way?
I've tried all sorts of stuff. Originally I was going to use it with Skype, but I never got that to work. For testing I've tried KRecord and also just about everything suggested on the ALSA site.
 
Old 03-20-2007, 05:37 PM   #12
rpg
Member
 
Registered: Dec 2002
Distribution: OpenSUSE
Posts: 58

Rep: Reputation: 15
I have been trying to use gramofile, but that does not seem to be compiled correctly for x86_64...

It's hard for me to tell what is going wrong, or if I have just had some switch set wrong. My last machine had this same problem --- it could record off the microphone input (I put my stereo's output into the microphone input to test), but could not get line in to work. Unfortunately, the sound recording off the microphone jack is very low quality...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa v1.0.14rc2 Not working with Intel 82801G on Redhat enterprise 4 RHEL4 utee Linux - General 3 02-28-2007 01:28 PM
audigy 2 problems with ALSA; no input; philipptr Linux - Newbie 5 07-06-2006 12:14 PM
Can't record video/sound from bttv input, maybe alsa/via8233 related... bruno buys Linux - Hardware 9 06-14-2005 11:31 PM
ALSA - I need Line-Input recording with SB Audigy outspoken Linux - Software 0 05-21-2005 10:53 PM
Alsa woes... winTV input wingtip Mandriva 0 12-28-2004 02:34 PM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration