LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-10-2009, 05:19 PM   #1
garydale
Member
 
Registered: Feb 2007
Posts: 122

Rep: Reputation: 22
no DMPS shutoff after re-installing ATI fglrx drivers


I'm running Debian Squeeze on a Gigabyte GA-MA790GP-UD4H (HD3300 graphics) mainboard with a quad-core Phenom II processor. This was an upgrade as the system had been running on an Asus board with a Phenom processor. I just swapped the board out, move the memory over and plugged everything in.

Everything worked except the video was a little slow. I decided to try the open source drivers but I could only get vesa to work so I reinstalled the fglrx drivers. This time the video is very fast and KDE has even decided to turn on some desktop effects that weren't used before. Everything is great except my monitor isn't suspending or shutting down after x minutes of inactivity. All that happens is the screen saver (blank screen) kicks in and requires a password.

My xorg.conf Monitor section contains the line
Option "DMPS"
I've also tried Option "DMPS" "true" but that didn't work either. KDE System Settings | Display | Power Control shows power management turned on, so it's not that. Rebooting hasn't helped.

Any ideas on what's wrong?
 
Old 08-10-2009, 05:58 PM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, one glaring error I see here....

it's dpms
/etc/X11/xorg.conf
Code:
    Option         "DPMS"
Cheers Glenn
 
Old 08-11-2009, 05:09 PM   #3
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
Unhappy still no DPMS shutdown

It doesn't seem to matter whether it's DPMS or dpms. I'm still not getting the monitor to shut down. And yes, I did restart X to ensure that the new option was picked up.

Thanks anyway.

Last edited by garydale; 08-11-2009 at 05:12 PM.
 
Old 08-11-2009, 07:45 PM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
I meant only to point out this typo.
Quote:
My xorg.conf Monitor section contains the line
Option "DMPS"
I've also tried Option "DMPS" "true" but that didn't work either.
You may find settings here (screwdriver and shifting-spanner icon)...systemsettings
"/usr/share/applications/kde4/systemsettings"

Settings for display power management (monitor icon)
Power Control.

And also Look and Feel, Desktop, screensaver

restart x to see the effects. (I hope)

Regards Glenn
 
Old 08-12-2009, 06:17 PM   #5
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
Unhappy No luck there either

Sorry, I didn't notice the transposition when I typed in the Options line.

As I mentioned, the Systems Settings | Display | Power Control has display power management active. I've turned it on and off several times in case it had lost the setting, but even after multiple attempts and several reboots, I still don't have DPMS working.
 
Old 08-12-2009, 06:54 PM   #6
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Is the acpi daemon running?

Code:
service acpid status
Code:
glenn@GamesBox:~$ service acpid status
acpid (pid  1267) is running...
glenn@GamesBox:~$
Other than that dpms also rely on the bios powersaving settings.

Do you have the latest kernel?

That's all I got.

regards and best wishes, Glenn
 
Old 08-12-2009, 08:36 PM   #7
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
I have the dpms line in 3 places (monitor, device and screen), won't hurt to try....
/etc/X11/xorg.conf
Code:
#GamesBox.GlennsPref.net
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse1" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "Module"
    Load           "dbe" # Double-Buffering Extension
    Load           "v4l" # Video for Linux
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "ExplorerPS/2"
    Option         "Device" "/dev/input/mice"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "MEA"
    ModelName      "1280x1024 @ 50 Hz"#"DV177/SB"
    HorizSync       31.5 - 64.3
    VertRefresh     50.0 - 70.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    VendorName     "GigaByte"
    BoardName      "GigaByte GeForce 9800gt (GTX+)"
    Driver         "nvidia"
    VideoRam        524288
    Option         "DPMS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "HWCursor"
    Option         "DPMS"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
One last thing. regards Glenn

Last edited by GlennsPref; 08-12-2009 at 08:38 PM.
 
Old 08-13-2009, 03:37 PM   #8
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
Thanks Glen. The service program is a Redhat thing. However the KDE system monitor shows acpid running.

I'm pretty sure that the BIOS has power saving enabled, but the Kernel should be ignoring/overriding the BIOS settings anyway.

I've got the latest Debian kernel (2.6.26-2-amd64) but I don't think I changed it anytime between when DPMS was working and when it stopped.

I'm running a few things on my computer right now. I'll check adding the Option "DPMS" to the other areas, although I've never seen it anywhere but in the monitor section before.

I've been reading some interesting stuff about xorg not doing much with the xorg.conf file anymore. It may be ignoring the Option "DPMS" line entirely. I've just tried running xset +dpms so I'll see if that does anything... Apparently it doesn't survive a reboot, but for now it will be good enough - if it works.
 
Old 08-13-2009, 05:15 PM   #9
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
Interesting. "xset +dpms" didn't work, so I tried "xset dpms force off" to see if it would turn the monitor off. It blanked the screen but that was all. The monitor didn't shut down.

I know the monitor does shutdown because I'm using a kvm and it turns off when I have it pointed to a different computer.

I'm contemplating a fresh install of Linux at this point. My system is running good except for this one point, but this is big one. Without the monitor shutting down, I'm generating too much heat and using too much power.
 
Old 08-13-2009, 07:06 PM   #10
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
You're right about xorg, it has matured and requires little hacking to make work now.

But you can still give the commands you want, some are obsolete and are ignored.

I found this old (2005) page that has some examples (and mentions xset too).

http://linuxreviews.org/howtos/power.../index.html.en

Debian and rpm based distros are slightly different, but mostly similar.

Filesystem differences being the most changed.

But with locate and find you can generally find the file required.

Do you have lm_sensors, smartd (smartmontools) or hddtemp installed?
Quote:
----------------------------------------------------------------------
More information on package lm_sensors3-3.0.3-2mdv2009.1.x86_64
* To use this package, you'll have to launch "sensors-detect" as root, and answer a few questions.
There is no need to modify startup files as shown at the end, all will be done for you.
* A special note for via686a and i2c-viapro: if you don t see the values, you probably have a PCI conflict.
It will be corrected in next kernel. Change the /etc/sysconfig/lm_sensors to use i2c-isa + via686a
(or i2c-viapro + another sensor)
----------------------------------------------------------------------
If so, you may need to run sensors-detect and/or re-run sensors -s (as root) to configure it for the new mobo chipset.
Quote:
lm_sensors - Utilities for lm_sensors​ 
This package contains a collection of user space tools for general SMBus access and hardware monitoring. SMBus, also known as System Management Bus, is a protocol for communicating through a I2C ('I squared C') bus. Many modern mainboards have a System Management Bus. There are a lot of devices which can be connected to a SMBus; the most notable are modern memory chips with EEPROM memories and chips for hardware monitoring.

Most modern mainboards incorporate some form of hardware monitoring chips. These chips read things like chip temperatures, fan rotation speeds and voltage levels. There are quite a few different chips which can be used by mainboard builders for approximately the same results.
See how you go, regards Glenn

Some (interesting) interactive system maps...
http://www.makelinux.net/system/
http://www.makelinux.net/kernel_map
 
Old 08-14-2009, 10:57 AM   #11
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
Thanks Glenn. Yes, I have all of those packages installed. I've come to the conclusion that it's probably a bug in the fglrx driver, since everything else seems OK.
 
Old 08-24-2009, 10:25 PM   #12
garydale
Member
 
Registered: Feb 2007
Posts: 122

Original Poster
Rep: Reputation: 22
resolved

Found the problem. Somehow the ACPID had been removed from my system. Reinstalling it gave me back the DPMS shutdown.
 
Old 08-24-2009, 10:49 PM   #13
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,529

Rep: Reputation: 238Reputation: 238Reputation: 238
Nice to know it got resolved. I was going to mention that on occassion when you make big changes to ATI's setup, you sometimes have to remove /etc/ati/amdpcsnd (but NOT amdpcsnd.default). In order to make the ATI drivers do as you expect. Otherwise running amdcccle might help setup advanced (or not) features.
 
  


Reply

Tags
ati, dpms, power, radeon


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help cant install ati-fglrx drivers adamzty Linux - Newbie 3 04-09-2007 12:04 AM
Slackware 10.2 and fglrx (ATI Drivers) cythrawll Slackware 7 10-18-2005 05:44 PM
Explanation please: ATI Drivers - fglrx and agpgart statguy Linux - Hardware 1 03-24-2005 10:53 AM
ATi fglrx drivers in Gentoo + kernel 2.6.10 vharishankar Linux - Distributions 1 03-08-2005 01:26 AM
ATI fglrx drivers being slow ben77 Linux - Hardware 2 10-01-2004 03:08 PM


All times are GMT -5. The time now is 11:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration