LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-14-2003, 02:58 AM   #1
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Rep: Reputation: 15
Nividia Driver Problems


I installed all of the nivida drivers correctly and configured my X86config file to get it up.


I get the flash screen for the nivida logo but I cant put on 3d accelration or select a higher resoultion.

how do I finsh the install so I can configure my card to do 3d accelration ?
 
Old 02-14-2003, 03:06 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
How do you know you don't have 3-D? Open a terminal and as root, type glxgears and see if you get a good frame rate (over 1,000 fps is OK).

What distro and how are you trying to change resolution?
 
Old 02-14-2003, 06:23 AM   #3
wapcaplet
Guru
 
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
If you followed NVidia's instructions, and you are now getting the logo when you start up XFree86, then it sounds like you've done everything you need to.

Check the log files:

/var/log/XFree86.0.log
/var/log/XFree86.9.log

See if there are any error lines (that begin with (EE)) which might say that 3d acceleration isn't working. If there aren't, and you followed the directions and edited your XF86Config file correctly, then you are probably good to go (unless 3D performance is really bad - what kind of video card do you have btw?)
 
Old 02-14-2003, 10:12 AM   #4
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Original Poster
Rep: Reputation: 15
I ran the commnads as you suggested and I got over 4000 on the gears so I think my 3d accell is on which answers my question.

I guess what I need to know is how to change my monitor rez on a gefource 4 ti 4200 runing red hat 8

thanks

-----------------------------------------------------
and I am trying to cheng my resoultion using display x

Last edited by subservant; 02-14-2003 at 10:13 AM.
 
Old 02-14-2003, 10:55 AM   #5
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 905

Rep: Reputation: 45
Quote:
Originally posted by subservant

I guess what I need to know is how to change my monitor rez on a gefource 4 ti 4200 runing red hat 8
Click on ``System Settings -> Display''. That'll bring up the graphical tool to tweak your X configuration. Or you can save your current /etc/X11/XF86Config off to the side and re-run ``X -configure''. Then edit the new file and add the nvidia options back in. The first method is easier if all you want to do is change the current resolution. You will have to restart your X session for the change to take effect.

Hope this helps,

Rick
 
Old 02-14-2003, 11:11 AM   #6
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Original Poster
Rep: Reputation: 15
well here is where I run in to trouble

in display their are only two monitor resoultions avable to me. And when I try to run Xconfig I get a message saying that XF86 is still running.

I have tryed to add the lines in my Xf86 config file and when I reboot starx runs in to problems and I have to roll back my settings.

 
Old 02-14-2003, 04:04 PM   #7
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 905

Rep: Reputation: 45
X is already running?

Quote:
Originally posted by subservant
in display their are only two monitor resoultions avable to me. And when I try to run Xconfig I get a message saying that XF86 is still running.

I have tryed to add the lines in my Xf86 config file and when I reboot starx runs in to problems and I have to roll back my settings.
Did you do an Ctrl-Alt-F7 to see if X is showing anything at all?

If it says that X is already running, then you could just kill that process. Find the PID from `ps -ef' and `kill -9 PID'. Then try startx again.

Rick
 
Old 02-14-2003, 06:01 PM   #8
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Original Poster
Rep: Reputation: 15
yes I fixed it

I was trouble shooting when I came across bogus values when I logged on in
in stright shell

Bogus Values returned
ID: none
Modle" None
Horz Sync : None
Vert Synce: None


this came up when I did redhat-config-xf86 and it turned thouse vales so what I ended up doing is adjusting the vert and hroz syncs by looking up my montor values *I have a gem 17 in LCD* and it fixed my problems

you all rock thanks for the support
 
Old 02-16-2003, 03:01 AM   #9
Tih8710
Member
 
Registered: Jan 2003
Location: Finland
Distribution: Debian, INSERT-Linux, Fedora
Posts: 121

Rep: Reputation: 15
A problem with Nvidia and Agpgart..

Hmm, I have a problem with Agp too, When I try to run X with agpgart enabled,
(Option "NvAgp" "X", the X either 1 or 2), the display goes f_cked up, I get strange ASCII-shit all over the screen, and end up rebooting..
It doesn't matter if I use nvidias built-in agpgart, or the one that I HAVE compiled as a module. Naturally when I try Nvidia's, I have the agpgart module that came with kernel unloaded...
The only way that my driver works is with "Option "NvAgp" "0", and I want to get it up and running...

(Getting only 2128.600 FPS whit a system of 1,4Ghz Athlon, 1Gig of Ram, udma HD and a G4 Ti 4200... Something Wrong? )
 
Old 02-16-2003, 05:50 PM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Go to
http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
and plug in your monitor's specs.


I only get 750 fps on an AMD Athlon 700 MHz with Geforce4 MX 420. When ever I right click on the glxgears window, my fps is near 1000.
 
Old 02-17-2003, 06:33 PM   #11
volcano2020
LQ Newbie
 
Registered: Feb 2003
Posts: 26

Rep: Reputation: 15
Hi Subservant,
Cna you please tell me how you fixed that problem you had with Nvidia. I got the same problem!
 
Old 02-17-2003, 06:35 PM   #12
volcano2020
LQ Newbie
 
Registered: Feb 2003
Posts: 26

Rep: Reputation: 15
I meant Can you please tell me in detail how you fixed it.
I have Suse 8.0 though but I guess the solution would be more or less the same! Thanx
 
Old 02-17-2003, 08:11 PM   #13
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Go into your X86Config-4 or X86Config file and setup your monitor. You can put what ever you want. Just make sure you put in the values correctly or your monitor may not display the pretty colors.

Here's what my X86Config-4 file looks like.
Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Hitachi, Ltd."
    ModelName "Hitachi CM771"
    HorizSync 31.0-96.0
    VertRefresh 50.0-160.0
    
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    BoardName "NVIDIA GeForce4 (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
Ignore XFDrake. I'm using Mandrake 9.

Do not forget to check your logs. Mine is located in /var/log.
 
Old 02-18-2003, 02:06 PM   #14
volcano2020
LQ Newbie
 
Registered: Feb 2003
Posts: 26

Rep: Reputation: 15
I installed the latest driver for my Nvidia Quadro4 900GLX graphics card. But:
When I enter load glx in that XF86Config file for 3D, it complains that the default color depth is 16. It allows up to 24 bit color depth without 3D acceleration. What is the maximum color depth you could have for 3D?
Also, It does not allow me to change back and forth from 3D acceleration if I use Nvidia driver and glx. the screen goes blank !!
 
Old 02-18-2003, 06:46 PM   #15
noir-gel
Member
 
Registered: Dec 2002
Posts: 51

Rep: Reputation: 15
at least...

Hi!!

Sorry... but I can't help you...
I would like to do it, but instead I have to ask you how did you configure Xconfig file, because I wasn't able to do it!!


:-(

THANKS :-)

.al.varo.castro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nividia drivers for Suse9.1 Shamgar Linux - Newbie 1 02-14-2005 03:45 PM
new nividia driver installation cykoburn Linux - Newbie 4 11-30-2004 10:32 PM
Help with Gentoo install and nic problems: nividia onboard dontcare Linux - Software 0 10-24-2004 07:01 PM
mozilla flash plugin problems /nividia graphic card wisdom Linux - Software 1 02-17-2004 09:00 PM
nividia driver compatibility SLaCk_KiD Linux - General 3 07-25-2003 06:35 PM


All times are GMT -5. The time now is 06:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration