LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   new monitor displays text, not GUI... (http://www.linuxquestions.org/questions/linux-hardware-18/new-monitor-displays-text-not-gui-85525/)

davejavu 08-25-2003 12:50 PM

new monitor displays text, not GUI...
 
I did a clean install of Red Hat and it was super fast and easy - auto detected every peripheral in my system without any trouble, including the monitor I was using in the office.

Then I went home and plugged into my home monitor. The boot process seems ok - displays a bunch of text - but when it switches into graphic mode, the screen goes black.

I'm a good dos/Win user, but a total newbie to Linux. Any command line I can use to get the box to recognize the monitor?Also, Red Hat gives a bunch of command line options during boot up - like grub. Which should I use?

Thanks!

makai_wi 08-25-2003 01:33 PM

Unlike windows, linux won't automaticly detect your monitor, that I know of. The problem is that your using a resolution / color depth / hurtz that your monitor can't handle and it is shutting off.

You can hit ctrl+alt+f1 to go to a command line logon, log in as root, then run xf86config, it might be a diffrent command. That should start the reconfigure of x, you're going to need to know what video card you have and what resolutions, color depths and hurtz levels your monitor can do, and a few other things like the keyboard layout and mouse type, etc... Let me know if you run into problems. And I probably have that command wrong, if it dosn't work I can look it up when I get home.

exodist 08-25-2003 06:38 PM

that is not completely true linux is in many cases ble to use edid info from monitor, not always however. I have my config file set with a wide range for vsync and hsync then the resolutions I want and color depths, I load X and it goes to the resolution I specified, then uses max refresh rates it can. then again I also use slack with a ton of customsation hacks along with a gf4 (nvidia drivers) and dual 17" monitors that can do 1024x768@85hz and have resolutions past 1600x1200 (don't know how mcuh higher to hard to see anything)

I check my log file (/var/log/X*.log (Can't remeber name I use tab completion to much)) and it has about 4 pages (if printed) of frequencies and possible combinatiosn that it eather checks as exceptible or unexceptible based off of info from card/monitors.

hope that helps, also 2 more things:

1) try checking your log (/var/log/X------.log) you can use less /file | more to see it (replace /file with path to log)

2) avoid using gui/automatic utilities to configure X 70% of the people that get X working only make it work after ditching the auto utilities and graphical ones. try typing xf86config and manually entering data. (menu hat you scroll through and select options)

davejavu 08-26-2003 12:31 PM

nearly there... permission denied!
 
Thank you! I was able to get this far:

[davejavu@localhost davejavu]$
-bash /etc/X11/XF86Config permission denied

Any idea why permission would be denied to edit this file ?
FYI - I am the admin for this machine and there are no other users! I logged in just fine...

I found that my monitor runs at 50/60hz, and I believe I'll be able to update that information once I get permission to edit the file.

I'm also trying to learn what "level 3" means. I got there, but have no idea "where" I was...

Graaaaaacias!

:newbie:

exodist 08-26-2003 02:26 PM

1) you need to be root user (if you are any user other than root you can become root by typing: "su -" enter then entering password when it asks. then you can edit file

2) level 3, I think you mean runlevel as in: entering runlevel 3

there are 6 runlevels in linux

0: shutdown mode, scripts to turn off computer

1: first set of startup scripts and initilisation

2: second set fo startup scripts

3: User mode (login and do what you need)

4: unused in most distros and is generally a copy of #3, however in slackware it is graphical login mode

5: Most distros use this for graphical login mode, slack does not use it

6: restart computer, shutdown scripts then reboot

you can change the default you boot to by editing the /etc/inittab
do not change it to 0 or 6

exodist 08-26-2003 02:28 PM

just looked at your last post again:
[davejavu@localhost davejavu]$
you are not loged in as root, you are a user.
you need to do a su - then enter root password.
hopefully you remember what you ade the root password be

davejavu 08-26-2003 05:57 PM

still denied!
 
I typed su - and was asked for my password, logged in, but was still denied access to the file.

When I typed the file name I got this:

[root@localhost root]#
-bash: /etc/X11/XF86Config: permission denied

Once I get permission to edit the file, do I need to type any command in front of the file name, like "edit" or "type", or should I just be typing the file name?

exodist 08-26-2003 06:36 PM

wait, you arn't trying to execute the file are you? (run it) that would give a similar error.
use your favorite editor, vi, emacs, whatever (do not use eather if you do not know how, otherwise good luck closing eather one)
it is a config file
if all else fails see if you have midnight commander (type mc) then cd to the directory and select the file then hit f4, I do not recommend midnight commander as an editor as it is after all a shell, but it does have an editor and is newbie safe.

makai_wi 09-02-2003 11:39 AM

*sigh* glad to see that some one knows more than I *still feeling the newb status*...

davejavu 09-02-2003 01:01 PM

Got it - THANKS!
 
Thanks friends. I realized that I needed to invoke some sort of editor to edit the file, which turned out to be vi (which isn't really all THAT hard to use). Now my monitor is happy, and I have a GUI, so I am happy. Thanks to everyone on this post for providing direction. The world has one less Windows user.

makai_wi 09-02-2003 01:55 PM

*chants* NANO NANO NANO!


All times are GMT -5. The time now is 02:22 PM.