LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   New MBoard changes SATA to IDE (http://www.linuxquestions.org/questions/linux-hardware-18/new-mboard-changes-sata-to-ide-386321/)

cov 11-25-2005 02:08 AM

New MBoard changes SATA to IDE
 
Hi,

A lightning strike killed my Shuttle SN85G4 V2 Motherboard.

I have managed to replace the motherboard, but it is with a V3 board.

Previously Grub booted up on /dev/sda1, but now the Serial ATA HD is on /dev/hde.

I have used systemrescueCD (http://www.sysresccd.org/ - an extremely useful solution) to boot the machine and have edited /boot/grub/menu.1st
file so that all referemces to /dev/sda are changed to /dev/hde

The /etc/fstab has been similarly ammended.

However the machine can't find /dev/hde1 or /dev/hde5 and just says:

'- exiting to /bin/sh
sh: can't access tty; job control turned off'

Any ideas?

DaveG 11-26-2005 03:58 AM

Check the BIOS settings. I had a similar issue after upgrading the BIOS on my SB75G2. There is a setting somewhere that determines how the SATA drives map in to the BIOS device numbering.

syg00 11-26-2005 04:12 AM

Agreed - sometimes "enhanced" mode, sometimes "legacy".
Just play around ... :D

cov 11-27-2005 02:08 AM

Thanks for that.

I've actually been in the bios but couldn't see anything that could help.

I'll have another look.....

syg00 11-27-2005 02:21 AM

In which case it probably means you don't have the appropriate kernel selections enabled - different chipset with the new mobo.

cov 11-27-2005 03:25 AM

Aaaargh!

This is a bit of a bummer. It's years since I recompiled a kernel.

Probably have to boot up in the rescue cd and chroot to /dev/hde1 and recompile from there....

DaveG 11-27-2005 10:19 AM

FYI on my SB75G2 (Phoenix AwardBIOS) the settings are under Integrated Peripherals -> OnChip IDE Device -> On-Chip Serial ATA. Options are Disabled, Auto, Combined Mode, Enhanced Mode or SATA only.

I think mine is set to Enhanced Mode. The SATA disk is /dev/sda under Linux, hd(0,0) under grub. My DVD is /dev/hdc, probably wired on the secondary IDE as a master.

After upgrading the BIOS the SATA mode got reset to Disabled!

Hope this helps.

cov 11-29-2005 07:00 AM

I'm afraid that I have 3 options on my Pheonix AwardBIOS:

Onboard IDE Device[Press Enter]
Onboard PCI Device[Press Enter]
Onboard SuperIO Device[Press Enter]

Pressing enter on 'Onboard IDE Device[Press Enter]'
leads to:
RAID Function Setup[Press Enter]
OnChip IDE Channel0[Enabled]
...[auto]
...[auto]
OnChip IDE Channel1[Enabled]
...[auto]
...[auto]
Serial-ATA 2(Internal PHY)[Enabled]

Can't see much as you describe...

Haven't had much luck recompiling the Kernel either :(

cov 12-07-2005 04:30 AM

Well this thing had me beat.

Can't see why it should change /dev/sda to /dev/hde.

Still, I used the installation disks, selected 'Repair' and it repaired it back to /dev/sda.

Not sure how, or why.


All times are GMT -5. The time now is 10:45 AM.