LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-09-2012, 11:36 PM   #1
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Rep: Reputation: 17
Networking problems: long "waiting for" while loading web pages


Hello,

I'm at my parents house where I've used my laptop before. I have set them up with an ADSL Netgear router. Behaviour is normal for my kid's netbooks in Windows (they love Roblox which is only available when they boot Windows). In the past, I've had no problem with my laptop, but now since a lot of updates and conversion from Gnome 2.x to 3.2 on my debian testing system, I sometime get very quick page loads, and at other time get very prolonged "waiting for [whatever web page]" and occasionally a connection reset.

Dmesg's have not been very helpful (at least to me) but here is what I've seen:

Code:
[215175.497075] wlan0: deauthenticating from a0:21:b7:6d:16:28 by local choice (reason=3)
[215175.523872] cfg80211: Calling CRDA to update world regulatory domain
[215176.810262] cfg80211: World regulatory domain updated:
[215176.810266] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[215176.810270] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[215176.810272] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[215176.810275] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[215176.810278] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[215176.810281] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[215183.895761] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[215186.938930] wlan0: authenticate with a0:21:b7:6d:16:28 (try 1)
[215186.940916] wlan0: authenticated
[215186.965854] wlan0: associate with a0:21:b7:6d:16:28 (try 1)
[215186.969546] wlan0: RX AssocResp from a0:21:b7:6d:16:28 (capab=0x411 status=0 aid=2)
[215186.969550] wlan0: associated
[215186.979867] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[215197.856041] wlan0: no IPv6 routers present
BTW, I have IPV6 ignored in Network Manager and have IPV6 disabled in Firefox.

How can I further diagnose why I'm having the problem? I can ping my router and the desired url with no problem to my heart's content.

It even does this with www.google.com. Sometimes it loads like a speed demon and other times it takes a long time "waiting for www.google.com"

Thanks,
Narnie
 
Old 04-10-2012, 12:25 AM   #2
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Rep: Reputation: Disabled
Linux has terrible wifi handling, timing out really fast
If it is a priopoitory driver your out of luck.
I find myself in Ubuntu haveing to turn Internet off and on agin then it's fine for another 5 minutes.
If you plug it into Ethernet (Internet cord you conect with your modem or wifi transmitter to get a physical connection) this problem is fixed but it Is a little slower.

Dought it had anything directly to do with gnome.

Last edited by Zssfssz; 04-10-2012 at 12:26 AM.
 
Old 04-10-2012, 08:33 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

Quote:
Originally Posted by Zssfssz View Post
Linux has terrible wifi handling, timing out really fast
Care to share your evidence for the above statement? No problem with any of my Gnu/Linux Wifi setups. Possibly you do not have your wifi or system configured properly?

Quote:
Originally Posted by Zssfssz View Post
If it is a priopoitory driver your out of luck.
I find myself in Ubuntu haveing to turn Internet off and on agin then it's fine for another 5 minutes.
Seems like you are experiencing issues with the systems setup/configuration.
Quote:
Originally Posted by Zssfssz View Post
If you plug it into Ethernet (Internet cord you conect with your modem or wifi transmitter to get a physical connection) this problem is fixed but it Is a little slower.
No way! Wireless is not going to be faster than a wired connection with present hardware. If you happen to have 10Mbps then of course if you compare 802.11g the speed difference can be noticed. A fast Ethernet is double the speed of 802.11b/g/n wireless. Fast Ethernet will surpass wireless in many ways, not just speed but security. Where wireless provides mobility at the sacrifice of security and speed. Especially when you have more than one user accessing the LAN.

Quote:
Originally Posted by Zssfssz View Post
Dought it had anything directly to do with gnome.
Why do you think Gnome has anything to do with the situation?
 
Old 04-10-2012, 10:06 AM   #4
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Rep: Reputation: Disabled
He said it happened when he upgraded gnome.
 
Old 04-10-2012, 11:35 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

Thanks, over looked that part.
 
Old 04-10-2012, 02:47 PM   #6
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by onebuck View Post
Hi,

Thanks, over looked that part.
I think when Gnome upgraded, it brought in a new network manager. This is why I was wondering the difference. I am using the ath9k module and the router is a Netgear ADSL router. Again, didn't have any issues with this when I first installed it. Net react times were just fine, as I experience at my home (with a Linksys router tied to a cable modem). Only having problems here.

Pings (of course using a different net protocal) seem fine:

Code:
# ping -c 4 google.com
PING google.com (74.125.227.69) 56(84) bytes of data.
64 bytes from dfw06s07-in-f5.1e100.net (74.125.227.69): icmp_req=1 ttl=49 time=31.7 ms
64 bytes from dfw06s07-in-f5.1e100.net (74.125.227.69): icmp_req=2 ttl=50 time=30.9 ms
64 bytes from dfw06s07-in-f5.1e100.net (74.125.227.69): icmp_req=3 ttl=49 time=31.7 ms
64 bytes from dfw06s07-in-f5.1e100.net (74.125.227.69): icmp_req=4 ttl=49 time=30.9 ms

--- google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 30.911/31.324/31.725/0.398 ms
also

Code:
# traceroute google.com
traceroute to google.com (74.125.227.64), 30 hops max, 60 byte packets
 1  192.168.0.1 (192.168.0.1)  1.104 ms  1.556 ms  1.531 ms
 2  99.184.103.254 (99.184.103.254)  17.291 ms  18.683 ms  20.043 ms
 3  dist2-vlan60.tul2ok.sbcglobal.net (69.152.80.131)  22.791 ms  24.217 ms  25.102 ms
 4  151.164.102.198 (151.164.102.198)  28.945 ms  28.927 ms  30.005 ms
 5  gar23.dlstx.ip.att.net (12.122.85.69)  46.534 ms  47.364 ms  49.844 ms
 6  12.249.214.22 (12.249.214.22)  69.311 ms  31.155 ms  31.047 ms
 7  72.14.233.65 (72.14.233.65)  34.074 ms  96.159 ms  96.110 ms
 8  209.85.250.199 (209.85.250.199)  38.431 ms  39.790 ms  41.718 ms
 9  dfw06s07-in-f0.1e100.net (74.125.227.64)  42.640 ms  44.056 ms  46.066 ms
What other parameters can I check to see where the issue is?
 
Old 04-10-2012, 04:06 PM   #7
jefro
Guru
 
Registered: Mar 2008
Posts: 11,747

Rep: Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445
Boot to a live cd/dvd/usb and see if it acts the same. I am not sure the gnome deal is causing it either.

When it fails can you try a speedtest site for more info?
 
Old 04-10-2012, 05:27 PM   #8
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by jefro View Post
Boot to a live cd/dvd/usb and see if it acts the same. I am not sure the gnome deal is causing it either.

When it fails can you try a speedtest site for more info?
Atheros driver is needed for wireless to work. If I remember right, that is not included on the disk, so that is a no-go. My folks don't have an ethernet cable I can use to install the driver on a live CD.

I did a Speedtest, but speed is not the problem. Once the http connection is established, it is as fast as would be expected from ADSL. Speedtest.net shows 3.95 bps down, .31 up, and ping of 56.

It is the "waiting for" that is the problem. It seems to resolve DNS fine, but then the actual connection between the server and the client is the problem I suspect. This is what it is "waiting for google.com," e.g..
 
Old 04-10-2012, 06:18 PM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

What is in '/etc/resolv.conf'?
 
Old 04-10-2012, 09:51 PM   #10
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Original Poster
Rep: Reputation: 17
[Psuedo-quasi solved]

This doesn't help figure out what is going on, but I throttled back the Netgear to 54mbp (it is a b/g/n wireless router). This seems to have done the trick. Still, would like to know what is going on. What if I had n-capable wireless gear and didn't want to throttle back. Would I just be stuck? Surely something could/can be done.

Regards,
Narnie
 
Old 04-10-2012, 09:57 PM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Try disabling IPv6 support. You may be looking for an IPv6 name server.
 
Old 04-10-2012, 10:29 PM   #12
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by jschiwal View Post
Try disabling IPv6 support. You may be looking for an IPv6 name server.
I mentioned above IPv6 is disabled in firefox and network manager, is there somewhere else I also need to disable it? In the kernel as in: ?

Code:
echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf
I tried that. Might have helps some, but I still had some time out. Just so I could learn something, what would disabling IPv6 have to do with throttling down my router from n/g/b to just g/b seeming to make it work?

Thanks,
Narnie

Last edited by narnie; 04-10-2012 at 11:10 PM.
 
Old 04-12-2012, 05:24 PM   #13
WizadNoNext
Member
 
Registered: Nov 2009
Posts: 125

Rep: Reputation: 9
General rule: host won't be looking for IPv6 DNS as long as it do not have proper IPv6 address! So, please do not speak about things, which you have no idea of!
802.11n could not be the problem here, as HT is dynamic property and it is switch on and off automatically (it is on ONLY if AP is capable AND when there are ONLY HT STAs connected, as soon as NON-HT STA capable will connect it is switched off by AP).
Good start to get some knowledge about root cause of problem is switching to wireless-tuned congestion control like westwood or veno
Code:
modprobe tcp-westwood
sysctl net.ipv4.tcp_congestion_control=westwood
Alternatively you can try yeah or illinois, but they are not tuned for wireless.

You should try to turn off slow_start_after_idle
Code:
sysctl net.ipv4.tcp_slow_start_after_idle=0
Slow start after idle means, that, if link was idle, then connection would be initiated with small congestion window (so bandwidth assosiated with one request/ACK would small).

To be honest I prefer yeah or illinois, but tend to stuck 802.11 networks, so I do not recommend it to you.

Secondly it would be great if you would turn 802.11 debugging on, so we would have real information on 802.11 connection state. This what you have provided is actually bit meaningless (I know - I had 802.11 debugging on).

P.S. firefox do not resolve hostnames, so IPv6 settings in firefox are meaningless. IPv4 is always resolved first and then IPv6 is resolved (even if IPv4 DNS is present) and, if IPv6 record is present, it is used. System do not resolve IPv6 DNS, if there is no IPv6 address on any interface.
 
1 members found this post helpful.
Old 04-12-2012, 10:37 PM   #14
narnie
Member
 
Registered: Jan 2010
Distribution: Linux Mint, Ubuntu Netbook Edition, et al
Posts: 106

Original Poster
Rep: Reputation: 17
Quote:
Secondly it would be great if you would turn 802.11 debugging on, so we would have real information on 802.11 connection state. This what you have provided is actually bit meaningless (I know - I had 802.11 debugging on).

P.S. firefox do not resolve hostnames, so IPv6 settings in firefox are meaningless. IPv4 is always resolved first and then IPv6 is resolved (even if IPv4 DNS is present) and, if IPv6 record is present, it is used. System do not resolve IPv6 DNS, if there is no IPv6 address on any interface.
I really didn't think it was a DNS issue, as pings were fine resolving the hosts with no problem and firefox never stuck at "connecting to ..." Thanks for the pointers. I am back at my house now, so will have to try these things when I'm at my folks next (they are in another state in the USA).

How do I turn on 802.11 debugging? I am a little shallow on understanding this level of networking (I understand the TCP/IP stack in theory, building firewalls with iptables, etc, but this we are discussing here is a bit over my head). Thanks for all the good suggestions, I will attempt them all when I can.

Narnie

Last edited by onebuck; 04-13-2012 at 09:17 AM. Reason: repair quote vb
 
Old 04-13-2012, 03:36 AM   #15
WizadNoNext
Member
 
Registered: Nov 2009
Posts: 125

Rep: Reputation: 9
Oh, 802.11 debugging isn't actually not networking thing, but kernel thing. You need to configure and compile new kernel. It would be best for you to keep original one and new one at the same time and use new one only at parents house.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache response "HTTP request sent; waiting for response" too long ALInux Linux - Server 1 07-19-2011 06:45 PM
[SOLVED] "loading slackware" take a long time mattca Slackware 20 03-25-2010 12:24 AM
RHEL install Vostro 400 - sys "Loading SCSI drivers" "loading ata_piix driver..." sreekr_news Linux - Newbie 11 01-21-2010 01:25 PM
Web browsers "waiting for" forever on almost all sites jdifslack Slackware 7 01-31-2008 10:29 AM
trouble w/ networking, not loading web pages thriller Red Hat 2 02-21-2005 06:26 AM


All times are GMT -5. The time now is 04:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration