LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-28-2008, 02:09 PM   #1
ferozaferoz
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Unhappy need Silan SC92031 PCI Fast Ethernet Adapter redhat rhel5 driver (2.6kernel)


Please help if you know on this ,

I need link for Silan SC92031 PCI Fast Ethernet Adapter for redhat rhel5.0 driver (2.6.x kernel). This nic works fine on win XP as REALTEK
8139D but on RHEL5 not working .

my lspci shows as follows,

01:02.0 Ethernet controller: Hangzhou Silan Microelectronics Co., Ltd. RTL8139D [Realtek] PCI 10/100BaseTX ethernet adaptor (rev 01)
 
Old 12-29-2008, 08:30 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
That card should run with the 8139too driver. That is a common card.

Is there a diver loaded? To find out, open a konsole, and run the command '/sbin/lsmod |grep 8139too' and post the results.

If it is loaded, then run '/sbin/ifconfig' and post the results.

If it is not loaded, then try to load it. As root, try 'modprobe 8139too' and see what happens. No news is good news, so if you appear to get no response, that is good. If you get a message, post it.

What have yo done to configure the interface?
 
Old 12-30-2008, 12:08 PM   #3
ferozaferoz
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your response.

My system has two cards one is working with 8139too driver in Redhat5, But the another that i recently bought not working with that tried all options but of no use . i have 8139cp module also in my linux that also didnt work for my new NIC card (Advik Lan card).This second new nic works fine with XP.I tried ndiswrapper also that i configured as wan0 interface ,intrestingly it works but if i remove the lan cable from working first nic, my wan0 (Nic2) not working seems nic2 not using nic cable . Whats the use of ndiswrapper driver ?.
 
Old 12-30-2008, 01:43 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Whats the use of ndiswrapper driver ?.
NdisWrapper is not a driver. It is a piece of code to interface between non-linux drivers ( windoze drivers ) and linux. Basically, you run the windoze driver, through Ndiswrapper, instead of a native linux driver. It was written to broaden the number of wireless cards that work with linux. A lot of card makers do not take the time to write linux drivers.

In some cases it is the only way to get some cards to work under linux.
 
Old 09-17-2010, 10:07 PM   #5
parkarnoor
Member
 
Registered: Apr 2010
Posts: 52

Rep: Reputation: 0
unable to ethernet card in ifconfig

Dear all,

i have Hangzhou silan micro. co. LTD.SC92031 pci fast ethernet card

as per instruction. i executed modprobe 8139too

and it loaded successfully. but next what to do.

i issued ifconfig but it is not listed there.

it is only lo

what to do for that

Thanks
 
Old 09-18-2010, 05:32 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
parkarnoor,

Try the command 'ifconfig eth0 up' This will try to activate the eth0 interface. Of course for it to work you have to have the correct driver loaded. The output will look something like this:

Quote:
ifconfig
eth0 Link encap:Ethernet HWaddr 00:1D:7D:20:F4:67
inet addr:192.168.1.26 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:829 errors:0 dropped:0 overruns:0 frame:0
TX packets:1035 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:619046 (604.5 KiB) TX bytes:191157 (186.6 KiB)
Interrupt:24 Base address:0xc000
Depending on your network configuration, it could just work, or you may have to do some more configuring. If you need more help, please post the OS you are running, and the output of the above command.
 
Old 09-18-2010, 08:59 AM   #7
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
the module for silan SC92031 isn't "8139too" nor "8139cp", it's "sc92031". but AFAIK you need a kernel > 2.6.20 to get that module already included, or compile it yourself
 
Old 09-18-2010, 10:06 AM   #8
parkarnoor
Member
 
Registered: Apr 2010
Posts: 52

Rep: Reputation: 0
it is not working

Yes dear i tried ifconfig...

it is not eth0 interface...

once it is shown i can issue ifconfig eth0 up or ifup eth0

when i issued lspci -v it is showing Silan SC92031 PCI fast ethernet adapter

physically on the card it is written RTL 8139D..

so i dont know how it loades 8139d module

currently i am googling internet for the right drivers

Thanks
 
Old 09-18-2010, 10:14 AM   #9
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
there isn't "8139d" module. you need "sc92031" module.
but you won't get it include on 2.6.18 kernel, which is the one redhat/centos 5 uses. probably you should compile the module yourself
 
Old 09-19-2010, 03:01 AM   #10
parkarnoor
Member
 
Registered: Apr 2010
Posts: 52

Rep: Reputation: 0
my linux kernel is 2.6.18-194.el5xen

Dear as listed in title i am using redhat 5.5 kernel 2.6.18-194.el5xen.

i downloaded kernel source RPM. also i downloaded sc92031 tar.gz package but i suspect it is is for 2.4.x

then i tried rpm -ivh ...src.rpm

but is giving error .i.e unable to locate %sources ...

after that i created redhat directory manually...and then i executed rpm -ivh again..

this time error was mockbuilder unable to find user ...(didnot remember full path)

once i am able to install kernel source rpm, i will try to follow instruction written in readme.txt of sc92031

but if you can provide me link to right source rpm file and command to install this rpm package ..i can check wheter sc92031 can be installed or not.

thanks
 
  


Reply

Tags
adapter, driver, ethernet, fast, ndiswrapper, pci, realtek, redhat, rhel5, sc92031


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
not able to install silan sc92031 pci ethernet adaptor on rhel 4 2.6.9-5.EL vibhorgupta Linux - Networking 4 07-02-2009 07:42 AM
no table to install silan sc92031 PCI Fast Ethernet Adapter on redhat enter linux 5 DINESHKUMARC Linux - Networking 1 09-16-2008 10:39 AM
can't load driver for Silan SC92031 PCI fast ethernet adapter on fedora 7 vishal_k Fedora 0 12-03-2007 08:14 PM
ethernet card SiS 900-Based PCI Fast Ethernet Adapter Not Detected pathan_azhar Linux - Networking 0 08-13-2006 04:15 AM
hardware compatible? CNet PRO200WL PCI Fast Ethernet Adapter krisjk2 Slackware 3 01-04-2006 07:41 PM


All times are GMT -5. The time now is 07:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration