LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-06-2010, 03:45 AM   #16
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15

Quote:
Originally Posted by NeilM View Post
I get;
cat: /etc/modprobe.d/sound: No such file or directory

**** List of CAPTURE Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 1: Intel ICH - MIC ADC [NVidia nForce2 - MIC ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0

I tried doing it again but nano asks to save the file under a diff name, when I say no it goes back to;
File name to write:
Are you really doing this as root? (or using sudo)
 
Old 01-08-2010, 03:43 PM   #17
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
As SU
 
Old 01-09-2010, 12:57 AM   #18
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeilM View Post
As SU
If you're really logged in as root I can see no explanation at all to why you would not be able to create the file. But just to make sure, try this. After you've switched to root using su, enter the command
Code:
whoami
If you get the output
Code:
root
well, then you're good to go. (Of course, the easiest way to see if you're root is to see if you have a # instead of a $ in the command prompt, at least on most distros but I'd use whoami just to make sure.)

Then (if you are in fact root) do what I described earlier
Code:
nano /etc/modprobe.d/sound
Add this line to the file:
Code:
options snd_mpu401 index=1
Save and exit using CTRL-x

check that you have the file and that it contains the correct line
Code:
cat /etc/modprobe.d/sound
Like I said, I can think of no reason why root would not be able to create the file.

best regards
CZ
 
Old 01-09-2010, 05:50 PM   #19
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
I get the comments as you have posted, redid the whole thing, Audio is still out on reboot
 
Old 01-10-2010, 05:16 AM   #20
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Ok, could you reboot the system without the webcam connected and run post the output of cat /proc/asound/modules? And when you do this, sound works fine, right?

It'll help us make *really* sure which module is in fact used by the onboard card. (That's why I in the original post included commands both with and without the webcam connected.)

/CZ
 
Old 01-10-2010, 11:41 AM   #21
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
0 snd_intel8x0
1 snd_mpu401

Without cam connected and yes all sound works fine.
 
Old 01-11-2010, 12:49 AM   #22
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeilM View Post
0 snd_intel8x0
1 snd_mpu401

Without cam connected and yes all sound works fine.
ok, now I'm confused. This is the same output that you have posted earlier, which I assumed was how it looked with the webcam connected?

Could you post the output when your webcam is connected? Also, do you by any chance have any other devices connected that use sound modules?
 
Old 01-11-2010, 10:34 AM   #23
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
cat /proc/asound/modules
With the cam installed while machine on is;

0 snd_intel8x0
1 snd_mpu401
2 snd_usb_audio

Sound and everything works fine. (until it reboots)
 
Old 01-12-2010, 12:40 AM   #24
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeilM View Post
cat /proc/asound/modules
With the cam installed while machine on is;

0 snd_intel8x0
1 snd_mpu401
2 snd_usb_audio

Sound and everything works fine. (until it reboots)
Ah, Try adding the following line to /etc/modprobe.d/sound:

options snd_usb_audio index=2

/CZ
 
Old 01-12-2010, 11:51 AM   #25
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
Ok did that, created allot of problems. On reboot the sound did work but the webcam was not recognized, when I unplugged and replugged then it worked. I also lost my internet connection, so I put it back to 1 instead of 2 and after several more reboots and playing with the network connection button I finally got back on the net.
 
Old 01-13-2010, 04:47 AM   #26
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeilM View Post
Ok did that, created allot of problems. On reboot the sound did work but the webcam was not recognized, when I unplugged and replugged then it worked. I also lost my internet connection, so I put it back to 1 instead of 2 and after several more reboots and playing with the network connection button I finally got back on the net.
Strange. I cannot for the life of me see how that would have any effect on the network. As for a network connection button, I don't know what it is. Anyway, try this in instead:

Code:
options snd_intel8x0 index=0
options snd_mpu401 index=1
options snd_usb_audio index=2
Basically, what you're doing is that you tell the system how to index all connected sound devices.

A word of advice is that you try to post information that help diagnose the problem. For example, you could have checked out how cat /proc/asound/modules looked when you had the problem. It might have given an indication of what was the cause of it. Also, in my first reply to you I asked that you post the output of the commands listed in the first post, with and without the webcam connected. Had you done so, I would have realized that snd_intel8x0 and snd_mpu401 was not used by the webcam at all and that would have saved some time. As a general rule, a bit too much information is better than a bit too little.

best regards
/CZ

Last edited by Count Zero; 01-16-2010 at 06:10 AM.
 
Old 01-13-2010, 04:03 PM   #27
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
I thought I had, trying to be specific.

Added the new script and I get sound, but the webcam is not recognized (tried Cheese and skype), webcam light is on.

cat /proc/asound/modules tels me this;
0 snd_intel8x0
1 snd_mpu401
2 snd_usb_audio

Unplugging and replugging in the webcame activates cheese and the video is a go, same as skype.
redoing cat /proc/asound/modules gives me the same;
0 snd_intel8x0
1 snd_mpu401
2 snd_usb_audio

I guess the good thing is the sound does not shut off now when the webcam is left in, but wont work till its "fresh pluged in"

Neil
 
Old 01-16-2010, 06:27 AM   #28
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Original Poster
Rep: Reputation: 15
Well, at loeast your system is a bit more robust now. Should you for whatever reason change webcam or stop using it you can just remove the last of the three lines. As for needing to re-connect it in order for it to be detected properly I have no no idea why that is so. Sorry.
 
Old 01-16-2010, 04:50 PM   #29
NeilM
Member
 
Registered: Apr 2004
Location: Alberta
Distribution: Debian
Posts: 32

Rep: Reputation: 0
Well I really appreciate your time u have taken to help me out.
Thanks!!!
 
  


Reply

Tags
debian, soundcard, webcam


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how is sound directed to multiple soundcards? belliott4488 Fedora 1 02-16-2007 12:49 PM
2 soundcards + usb webcam microphone zefo Linux - Hardware 1 11-20-2006 04:54 AM
multiple soundcards lead to ALSA problems?? timsch75 Slackware 8 03-13-2005 12:10 PM
using multiple soundcards Quis Linux - Hardware 1 02-02-2005 04:41 AM
Configure Two soundcards, ALSA...How? Outabux Debian 0 12-15-2004 12:48 PM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration