LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-15-2008, 11:15 AM   #1
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Rep: Reputation: 0
NDISWRAPPER / MODPROBE not auto-configuring Wireless WUSB300N Network Adapter at boot


I am having difficulties getting my Linksys WUSB300N to load at boot, configure, and connect. I am setting this up on my Frontend machine for Mythdora (will NOT have a keyboard attached).

Currently, the RC.Local and WPA_Supplicant.conf files HAVE BEEN configured (see below), but wont seem to work as the driver will NOT load at boot. I have it setup in /etc/modprobe.conf but get nothing. I have to manually load the driver using #modprobe ndiswrapper at each boot. Then, open Wireless Assistant and connect to network. It works for the time being but need this to auto-configure/connect at boot.



INSTALATION:
Used the driver supplied at http://www.atvnation.com/WUSB300N.tar. Modified /etc/modprobe.conf, WPA_SUPPLICANT.CONF, and RC.LOCAL.

/etc/modprobe.conf (configured)
TOP LINE --> alias wlan0 ndiswrapper



WPA_SUPPLICANT.CONF file:
# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
#
# home network; allow all valid ciphers
network={
ssid="mythtvbed1"
scan_ssid=1
key_mgmt=WPA-PSK
psk="Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B"
}

RC.LOCAL
#!/bin/bash

# This is a rc.local file that will allow your wireless card to
# startup correctly given the right driver and information below.
# Rename this to rc.local and replace or copy and paste to /etc/rc.d/rc.local

# Don't forget to edit your /etc/wpa_supplicant/wpa_supplicant.conf file to
# match your info here.

# Edit here to configure your wireless card
ESSID="mythtvbed1" ## Enter your SSID
CHANNEL="6" ## This usually is channel 6
IP="192.168.1.103" ## IP address of your wireless card
INTERFACE="wlan0" ## This maybe ath0 or wlan0
MODE="Managed" ## Leave this as is
GATEWAY="192.168.1.1" ## Enter your Gateway IP here
#########################################################################

if [ "$INTERFACE" = "wlan0" ];
then
/sbin/modprobe wlan
/sbin/modprobe ath_hal
/sbin/modprobe ath_pci
else
/sbin/modprobe ipw2100
/sbin/modprobe ipw2200
fi

# Set up the WiFi card
echo "Configuring ${INTERFACE}:"
/sbin/ifconfig ${INTERFACE} down
/sbin/ifconfig ${INTERFACE} ${IP} netmask 255.255.255.0 up
/sbin/iwconfig ${INTERFACE} mode ${MODE}
/sbin/iwconfig ${INTERFACE} channel ${CHANNEL} rate Auto
/sbin/iwconfig ${INTERFACE} essid ${ESSID}
/sbin/route add default gw ${GATEWAY} ${INTERFACE}
/sbin/ifup ${INTERFACE} up

sleep 1

# Edit wpa_supplicant.conf to match the info you gave here.
/usr/sbin/wpa_supplicant -Bw -c /etc/wpa_supplicant.conf -Dmadwifi -i${INTERFACE}

touch /var/lock/subsys/local
 
Old 03-15-2008, 11:35 AM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I don't understand what you have going on. You mention setting the interface wlan0 to use ndiswrapper but your wpa_supplicant is using madwifi option on its interface. You are loading atheros modules plus some others which I am guessing is a wired nic. With defining alias in modprobe to ndiswrapper it will use ndiswrapper and the wpa_supplicant needs to use -Dwext generic interface ID if ndiswrapper is anywhere being current. There use to another but for very old ndiswrapper modules.

First thing is define the network interfaces in this machine and how each are required to work.
Post output of the command /sbin/lspci -v
/sbin/lsmod
/sbin/lsusb -v

Is NetworkManager service running?
If so I would turn it off since you are defining the interfaces from what I can tell.

Brian
 
Old 03-15-2008, 12:14 PM   #3
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the FAST reply. I should mention I am a newbie... Will try and best explain the setup and answer your questions. The network device I am using is a WIRELESS Draft-N Adapter (WUSB300N); connects via USB. Motherboard: VIA EPIA M1000. As for Network Manager; not too sure how to check if it is running / turn off... Running Fedora 6 (I believe) with KDE. I installed WPA_Supplicant as suggested in the RC.LOCAL file I found after install of MythDora.

I am posting the outputs. Please let me know if you will need anything else... Thanks VERY much!



[root@localhost mythtv]# /sbin/lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
Subsystem: VIA Technologies, Inc. Unknown device aa01
Flags: bus master, 66MHz, medium devsel, latency 8
Memory at d0000000 (32-bit, prefetchable) [size=128M]
Capabilities: [a0] AGP version 2.0
Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
(prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: dc000000-ddffffff
Prefetchable memory behind bridge: d8000000-dbffffff
Capabilities: [80] Power Management version 2

00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host
Controller (rev 80) (prog-if 10 [OHCI])
Subsystem: VIA Technologies, Inc. IEEE 1394 Host Controller
Flags: bus master, medium devsel, latency 32, IRQ 5
Memory at de000000 (32-bit, non-prefetchable) [size=2K]
I/O ports at d000 [size=128]
Capabilities: [50] Power Management version 2

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at d400 [size=32]
Capabilities: [80] Power Management version 2

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller
Flags: bus master, medium devsel, latency 32, IRQ 5
I/O ports at d800 [size=32]
Capabilities: [80] Power Management version 2

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller
Flags: bus master, medium devsel, latency 32, IRQ 10
I/O ports at dc00 [size=32]
Capabilities: [80] Power Management version 2

00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) (prog-if
20 [EHCI])
Subsystem: VIA Technologies, Inc. USB 2.0
Flags: bus master, medium devsel, latency 32, IRQ 3
Memory at de001000 (32-bit, non-prefetchable) [size=256]
Capabilities: [80] Power Management version 2

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
Subsystem: VIA Technologies, Inc. Unknown device aa01
Flags: bus master, stepping, medium devsel, latency 0
Capabilities: [c0] Power Management version 2

00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
(prog-if 8a [Master SecP PriP])
Subsystem: VIA Technologies, Inc. Unknown device aa01
Flags: bus master, medium devsel, latency 32, IRQ 11
[virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
[virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
[virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
[virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
I/O ports at e000 [size=16]
Capabilities: [c0] Power Management version 2

00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
Subsystem: VIA Technologies, Inc. Unknown device aa01
Flags: medium devsel, IRQ 10
I/O ports at e400 [size=256]
Capabilities: [c0] Power Management version 2

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II]
(rev 74)
Subsystem: VIA Technologies, Inc. VT6102 [Rhine II] Embeded
Ethernet Controller on VT8235
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at e800 [size=256]
Memory at de002000 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] Power Management version 2

01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo
CLE266] integrated CastleRock graphics (rev 03) (prog-if 00 [VGA])
Subsystem: VIA Technologies, Inc. VT8623 [Apollo CLE266]
integrated CastleRock graphics
Flags: bus master, medium devsel, latency 32, IRQ 11
Memory at d8000000 (32-bit, prefetchable) [size=64M]
Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
[virtual] Expansion ROM at dd000000 [disabled] [size=64K]
Capabilities: [60] Power Management version 2
Capabilities: [70] AGP version 2.0



[root@localhost temp]# /sbin/lsmod
Module Size Used by
ndiswrapper 166356 0
via 44097 2
drm 78421 3 via
sunrpc 153469 1
nf_conntrack_netbios_ns 7105 0
ipt_REJECT 8641 1
nf_conntrack_ipv4 21709 9
xt_state 6593 9
nf_conntrack 62409 3
nf_conntrack_netbios_ns,nf_conntrack_ipv4,xt_state
nfnetlink 10841 2 nf_conntrack_ipv4,nf_conntrack
iptable_filter 7105 1
ip_tables 16389 1 iptable_filter
ip6t_REJECT 9537 1
xt_tcpudp 7233 30
ip6table_filter 6848 1
ip6_tables 17541 1 ip6table_filter
x_tables 18757 6
ipt_REJECT,xt_state,ip_tables,ip6t_REJECT,xt_tcpudp,ip6_tables
video 19909 0
sbs 19073 0
i2c_ec 9025 1 sbs
dock 13977 0
button 11857 0
battery 13893 0
asus_acpi 20445 0
backlight 10177 1 asus_acpi
ac 9157 0
ipv6 275585 23 ip6t_REJECT
lp 16265 0
snd_via82xx 31577 0
gameport 19401 1 snd_via82xx
snd_ac97_codec 93413 1 snd_via82xx
ac97_bus 6465 1 snd_ac97_codec
snd_seq_dummy 7877 0
snd_seq_oss 33601 0
snd_seq_midi_event 11201 1 snd_seq_oss
snd_seq 51249 5
snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 43617 0
snd_mixer_oss 19393 1 snd_pcm_oss
snd_pcm 75205 3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
via_ircc 24277 0
irda 118393 1 via_ircc
crc_ccitt 6337 1 irda
snd_timer 25157 2 snd_seq,snd_pcm
snd_page_alloc 13769 2 snd_via82xx,snd_pcm
snd_mpu401_uart 12609 1 snd_via82xx
via_rhine 28489 0
snd_rawmidi 26817 1 snd_mpu401_uart
snd_seq_device 11853 4
snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
i2c_viapro 12629 0
mii 9409 1 via_rhine
snd 53829 11
snd_via82xx,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu40 1_uart,snd_rawmidi,snd_seq_device
i2c_core 24897 2 i2c_ec,i2c_viapro
soundcore 11681 1 snd
pcspkr 7233 0
ohci1394 37488 0
ieee1394 294681 1 ohci1394
parport_pc 30053 1
parport 38537 2 lp,parport_pc
ide_cd 40673 0
serio_raw 10821 0
cdrom 37345 1 ide_cd
dm_snapshot 20849 0
dm_zero 6337 0
dm_mirror 25301 0
dm_mod 58509 10 dm_snapshot,dm_zero,dm_mirror
ext3 126537 3
jbd 60905 1 ext3
ehci_hcd 34125 0
ohci_hcd 23621 0
uhci_hcd 26833 0



[root@localhost temp]# /sbin/lsusb -v
Bus 003 Device 001: ID 0000:0000
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed hub
bMaxPacketSize0 64
idVendor 0x0000
idProduct 0x0000
bcdDevice 2.06
iManufacturer 3 Linux 2.6.20-1.2944.fc6 uhci_hcd
iProduct 2 UHCI Host Controller
iSerial 1 0000:00:10.2
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0002 1x 2 bytes
bInterval 255
Hub Descriptor:
bLength 9
bDescriptorType 41
nNbrPorts 2
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
bPwrOn2PwrGood 1 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0xc0
PortPwrCtrlMask 0xa6
Hub Port Status:
Port 1: 0000.0308 lowspeed power oc
Port 2: 0000.0100 power

Bus 004 Device 001: ID 0000:0000
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 1 Single TT
bMaxPacketSize0 64
idVendor 0x0000
idProduct 0x0000
bcdDevice 2.06
iManufacturer 3 Linux 2.6.20-1.2944.fc6 ehci_hcd
iProduct 2 EHCI Host Controller
iSerial 1 0000:00:10.3
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0004 1x 4 bytes
bInterval 12
Hub Descriptor:
bLength 9
bDescriptorType 41
nNbrPorts 6
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
TT think time 8 FS bits
bPwrOn2PwrGood 10 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0xc0
PortPwrCtrlMask 0xa6
Hub Port Status:
Port 1: 0000.0503 highspeed power enable connect
Port 2: 0000.0000
Port 3: 0000.0100 power
Port 4: 0000.0100 power
Port 5: 0000.0108 power oc
Port 6: 0000.0100 power

Bus 004 Device 002: ID 13b1:0029 Linksys
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x13b1 Linksys
idProduct 0x0029
bcdDevice 0.01
iManufacturer 1 MARVELL
iProduct 2 Wireless-N USB network adapter v1021
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 32
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 4 #02
bmAttributes 0x80
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 1

Bus 001 Device 001: ID 0000:0000
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed hub
bMaxPacketSize0 64
idVendor 0x0000
idProduct 0x0000
bcdDevice 2.06
iManufacturer 3 Linux 2.6.20-1.2944.fc6 uhci_hcd
iProduct 2 UHCI Host Controller
iSerial 1 0000:00:10.0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0002 1x 2 bytes
bInterval 255
Hub Descriptor:
bLength 9
bDescriptorType 41
nNbrPorts 2
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
bPwrOn2PwrGood 1 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0xc0
PortPwrCtrlMask 0xa6
Hub Port Status:
Port 1: 0000.0100 power
Port 2: 0000.0303 lowspeed power enable connect

Bus 001 Device 003: ID 1233:e007
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 8
idVendor 0x1233
idProduct 0xe007
bcdDevice 1.00
iManufacturer 1 HOLTEK
iProduct 2 USB Keyboard
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 59
bNumInterfaces 2
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xa0
Remote Wakeup
MaxPower 100mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 3 Human Interface Devices
bInterfaceSubClass 1 Boot Interface Subclass
bInterfaceProtocol 1 Keyboard
iInterface 0
HID Device Descriptor:
bLength 9
bDescriptorType 33
bcdHID 1.00
bCountryCode 0 Not supported
bNumDescriptors 1
bDescriptorType 34 Report
wDescriptorLength 65
Report Descriptors:
** UNAVAILABLE **
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0008 1x 8 bytes
bInterval 10
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 1
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 3 Human Interface Devices
bInterfaceSubClass 1 Boot Interface Subclass
bInterfaceProtocol 2 Mouse
iInterface 0
HID Device Descriptor:
bLength 9
bDescriptorType 33
bcdHID 1.00
bCountryCode 0 Not supported
bNumDescriptors 1
bDescriptorType 34 Report
wDescriptorLength 170
Report Descriptors:
** UNAVAILABLE **
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0008 1x 8 bytes
bInterval 10

Bus 002 Device 001: ID 0000:0000
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 1.10
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 0 Full speed hub
bMaxPacketSize0 64
idVendor 0x0000
idProduct 0x0000
bcdDevice 2.06
iManufacturer 3 Linux 2.6.20-1.2944.fc6 uhci_hcd
iProduct 2 UHCI Host Controller
iSerial 1 0000:00:10.1
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 9 Hub
bInterfaceSubClass 0 Unused
bInterfaceProtocol 0 Full speed hub
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0002 1x 2 bytes
bInterval 255
Hub Descriptor:
bLength 9
bDescriptorType 41
nNbrPorts 2
wHubCharacteristic 0x000a
No power switching (usb 1.0)
Per-port overcurrent protection
bPwrOn2PwrGood 1 * 2 milli seconds
bHubContrCurrent 0 milli Ampere
DeviceRemovable 0xc0
PortPwrCtrlMask 0xa6
Hub Port Status:
Port 1: 0000.0300 lowspeed power
Port 2: 0000.0300 lowspeed power
 
Old 03-15-2008, 01:31 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I would do the following for total automatic startup of networking.

As root run the two following commands.
/sbin/service NetworkManager stop
/sbin/chkconfig --level 345 NetworkManager off

Now I am guessing there is a wired ethernet interface but not sure if you have it configured or not. Post info from this command ' /sbin/ifconfig -a '. Now if the wired nic is eth0 then as root edit the file /etc/sysconfig/network-scripts/ifcfg-eth0 and edit the line to say ONBOOT=no

Next there should be a file /etc/sysconfig/network-scripts/ifcfg-wlan0
You need to edit it to look like this. This is based on info you provided.
Code:
# Home Static Setup
# STARTMODE='auto'
ONBOOT=yes
DEVICE=wlan0
MODE=Managed
WIRELESS=yes
ESSID=mythtvbed1
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.1.103
GATEWAY=192.168.1.1
RATE=auto
CHANNEL=6
Edit /etc/rc.local to look like this. You are loading things you don't need and more than likely don't have installed. Also I define the normal location of wpa_supplicant.conf file on Standard Fedora install. Confirm your wpa_supplicant.conf is there and you have configured for your wpa setup. If you have not then I can help if you provide the following items exact as they are. If upper case, lower case, or mixed case it has to match exactly to work.

For wpa setup I need to know the type, wpa, wpa2, unless you are doing wep plus the type of wpa modes like tkip eap an so forth. Plus your passphrase key. Unless you generated it yourself with the command /usr/sbin/wpa_passphrase.

/etc/rc.local
Code:
#!/bin/bash

# To start up wpa_supplicant encryption.
/usr/sbin/wpa_supplicant -Bw -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -i wlan0
And last I do assume you have loaded the 64bit inf windows driver into ndiswrapper. I would say you have since you can finally start the connection.

Brian
 
Old 03-15-2008, 02:54 PM   #5
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
The "mythbox" has a wired ethernet connection. Am keeping the port open until I can get wireless client working. From what I am reading, edit the eth0 config file to ONBOOT=no and that will turn it off at boot.


I have the DIR-655 DLink Wireless Router (Draft N). I would like to use WPA2 as both router and NIC card support. WPA-Enterprise(WPA, WPA2, both), Cipher Type(TKIP, AES, both). To set the password, I just use an online WPA2 generator... Here is an example: 1$IGqXuyvE$P4YG3eVDqfwdj9jRIBNxJ1
emulator to check settings for yourself if you like: http://support.dlink.com/Emulators/dir655/login.html

# dmesg
ndiswrapper: no version for "struct_module" found: kernel tainted.
ndiswrapper version 1.41 loaded (smp=yes)
usb 4-1: reset high speed USB device using ehci_hcd and address 2
ndiswrapper: driver netmw245 (Linksys, A Division of Cisco Systems,
Inc.,12/07/2006,1.0.5.1) loaded
wlan0: ethernet device 00:1c:10:e8:ec:5f using NDIS driver: netmw245,
version: 0x1000308, NDIS version: 0x500, vendor: '', 13B1:0029.F.conf
wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK;
AES/CCMP with WPA, WPA2, WPA2PSK
usbcore: registered new interface driver ndiswrapper
wlan0: no IPv6 routers present
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready



I installed wpa_supplicant using the YUM command:
#yum install wpa_supplicant
Location: /etc/wa_supplicant/wpa_supplicant.conf


Network Manger is either not running or has not been installed:# /sbin/service NetworkManager stop
NetworkManager: unrecognized service

# /sbin/chkconfig --level 345 NetworkManager off
bash: /sbin/chconfig: So such file or directory



# /sbin/ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:40:63:C9:16:16
inet addr:192.168.1.104 Bcast:192.168.1.255
Mask:255.255.255.0
inet6 addr: fe80::240:63ff:fec9:1616/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:55953 errors:0 dropped:0 overruns:0 frame:0
TX packets:3347 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3706493 (3.5 MiB) TX bytes:392184 (382.9 KiB)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2447 errors:0 dropped:0 overruns:0 frame:0
TX packets:2447 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2807334 (2.6 MiB) TX bytes:2807334 (2.6 MiB)

wlan0 Link encap:Ethernet HWaddr 00:1C:10:E8:EC:5F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:367 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29257 (28.5 KiB) TX bytes:4255 (4.1 KiB)



There is an ifcfg-eth0 but no wlan0 file...
Found ifcfg-lo in the directory

Contains:
DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback
 
Old 03-15-2008, 03:51 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
What it amounts to is you can only have one network interface up at a time with a defined gateway. lo does not matter.

So create and save the ifcfg-wlan0 file like I mentioned.
I have not seen current wpa_supplicant.conf file which I forgot to ask for. Post that so I know what you have. You need to use the wpa tool I mentioned to generate the key for the wpa_supplicant file.

Then in that file you define what you are going to use. Sounds like you want wpa2 which is where you define proto=RSN for wpa2. The easy setup is choose only one which most default store bought routers can only do one mode at a time as well as the cipher type.

For now I would leave your ifcfg-eth0 as is since that seems to be working but you need to rem out the /usr/bin/wpa_supplicant command from the /etc/rc.local and also set ONBOOT=no in your new ifcfg-wlan0

To test system once the ifcfg-wlan0 is set, the wpa_supplicant.conf is configured then you can issue these commands as root to bring the nics up and down.

/sbin/ifdown eth0
/sbin/ifup wlan0
/usr/sbin/wpa_supplicant -Bw -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -i wlan0

Now it should start negogitating a connection. It will scroll several lines but should after 5 secs roughly say connection established. You will need to leave this window open for now but if it works then setup /etc.rc.local to run the wpa_supplicant command. To see nic info run command ' /sbin/ifconfig -a ' and also ' /sbin/iwconfig wlan0 '

If not working then to bring the eth0 backup run these commands as root.
pkill wpa_supplicant
/sbin/ifdown wlan0
/sbin/ifup eth0

If having issues then post the contents of the files I ask.
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-wlan0
/etc/wpa_supplicant/wpa_supplicant.conf
/etc/rc.local
/etc/modprobe.conf

Brian
 
Old 03-15-2008, 10:12 PM   #7
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
It is still broke. Getting a Failure at boot; locptack interface (or somethin): does not seem to be present... Checked to see if the device was installed as Link light was not lighting: not installed...
Had to run modprobe ndiswrapper for driver to install.

Here is the output from the commands you requested I run:
[root@localhost temp]# /sbin/ifup wlan0
does not seem to be present, delaying initialization.
[root@localhost temp]# /usr/sbin/wpa_passphrase
usage: wpa_passphrase <ssid> [passphrase]

If passphrase is left out, it will be read from stdin
[root@localhost temp]# /usr/sbin/wpa_supplicant -Bw -c
/etc/wpa_supplicant.conf -Dwext -i wlan0
[root@localhost temp]# /sbin/ifdown eth0
[root@localhost temp]# /sbin/ifup eth0

Determining IP information for eth0... done.


I setup the Router to:
Security Mode: WPA-Personal
WPA Mode: WPA2
Cipher Type: AES
Group Key: 3600 sec (default)
Pre-Shared Key: Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B


eth0:
# VIA Technologies, Inc. VT6102 [Rhine-II]
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:40:63:C9:16:16
ONBOOT=no


wlan0:
# Home Static Setup
# STARTMODE='auto'
ONBOOT=yes
DEVICE=wlan0
MODE=Managed
WIRELESS=yes
ESSID=DLink
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.1.103
GATEWAY=192.168.1.1
RATE=auto
CHANNEL=6


rc.local
#!/bin/bash

# To start up wpa_supplicant encryption.
/usr/sbin/wpa_supplicant -Bw -c /etc/wpa_supplicant/wpa_supplicant.conf
-Dwext $


wpa_supplicant
# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel'
group
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
#
# home network; allow all valid ciphers
network={
ssid="DLink"
scan_ssid=1
key_mgmt=WPA-PSK

psk="Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B"
}


modprobe.conf
alias wlan0 ndiswrapper
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/$
 
Old 03-16-2008, 08:42 AM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Ok try this.
Edit ifcfg-wlan0 and change ONBOOT=no. So neither will start on boot.

I would also run this command to confirm you have the psk correct if you have not. I have not seen the phrase you used to gerenate to test it myself.

/usr/sbin/wpa_passphrase DLink “YOUR_WPA_PSK_PASSPHRASE”

I see you seemed to have changed your routers ESSID based on last post so command is set to work. Replace the contents inside the quotes with your clear key.

Next edit wpa_supplicant.conf to set encryption mode settings based on you using wpa2 and cipher AES
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
# update_config=1

network={
        ssid="DLink"
        #psk="orginal clear text key before generated here if you wish"
        psk="Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B"
	proto=RSN
}

# WPA for WPA
# RSN for WPA2
Once the changes are made run the following commands as root. Post output of each command.
[code]
/sbin/ifdown eth0
/sbin/ifdown wlan0
/sbin/modprobe ndiswrapper
/sbin/ifup wlan0
/usr/sbin/wpa_supplicant -dd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

Now you need to open another terminal session and run these commands and post output. Wait to see if wpa_supplicant connects.
/sbin/iwconfig
/sbin/ifconfig wlan0
/sbin/iwlist wlan0 scan

Brian

Last edited by Brian1; 03-16-2008 at 02:37 PM.
 
Old 03-16-2008, 12:23 PM   #9
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
I need clarifacation on the Password...

/usr/sbin/wpa_passphrase DLink “YOUR_WPA_PSK_PASSPHRASE”
7142537118a5eac3f542df05871e5bb93646327c835d8451b5863edf38c30698

Do I need to change the Password on the DLink Router to the above output?

Is this correct setup of wpa_supplicant
MODIFIED FILE:
/etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
# update_config=1

network={
ssid="Dlink"
#psk="Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B"
psk="7142537118a5eac3f542df05871e5bb93646327c835d8451b5863edf38c30698"
proto=RSN
}

# WPA for WPA
# RSN for WPA2


/usr/sbin/wpa_supplicant contains
ELF

Making sure the Cipher is correct... I am using AES. Have option for TKIP.

Last edited by cjtinant; 03-16-2008 at 12:26 PM.
 
Old 03-16-2008, 02:37 PM   #10
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I don't know if any changes are needed between AES and TKIP. I use WPA2 TKIP and what I wrote is what my wpa_supplicant.conf looks like.

Now if this is on the routers wpa2 key.
Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B

Then you use the command as you did to generate the psk.
Code:
/usr/sbin/wpa_passphrase DLink “Lt5JnOW8&h#JzIq>c{3!5(D'uR;x(G#Au2ux-/BOK/~`4Sl+f-mHT/b"2PL?F!B”
But I don't think all those characters are valid in at least linux wpa like ! and ` and also you have a quote near the end which is going to throw the creation off the of the key. The key is going to be incorrect because of the " indicated near the end of the key but the trailing characters crashes the command.

Now if I use the key you posted minus the !`and extra " it generates fine. So the key on the router needs to be without !`and the ". [code]
/usr/sbin/wpa_passphrase DLink "Lt5JnOW8&h#JzIq>c{35(D'uR;x(G#Au2ux-/BOK/~4Sl+f-mHT/b2PL?FB"

I get the following.
Code:
network={
        ssid="DLink"
        #psk="Lt5JnOW8&h#JzIq>c{35(D'uR;x(G#Au2ux-/BOK/~4Sl+f-mHT/b2PL?FB"
        psk=9dcf483734b5d417c81d0bcfd1581f971cb98e9c3b85bebd7deff3c77c65dae4
}
Place the whole section of network={ to the end } character in your wpa_supplicant.conf line and add the proto=RSN in the area like in other post.

So you should end up with wpa_supplicant.conf looking like this.
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
# update_config=1

network={
        ssid="DLink"
        #psk="Lt5JnOW8&h#JzIq>c{35(D'uR;x(G#Au2ux-/BOK/~4Sl+f-mHT/b2PL?FB"
        psk=9dcf483734b5d417c81d0bcfd1581f971cb98e9c3b85bebd7deff3c77c65dae4
	proto=RSN
}
NOTE the key on the router must be Lt5JnOW8&h#JzIq>c{35(D'uR;x(G#Au2ux-/BOK/~4Sl+f-mHT/b2PL?FB to use the above example based on some of your info. Again if the ESSID is incorrect it all must be redone to correct from beginning to end.

I perfer to just use numbers, upper, and lower case letters. Forget about those special characters. WEP, WPA, and WPA2 is easy to crack no matter what one uses for these store bought routers.

Now in some of the last post you first had the essid as mythtvbed1 then DLink and in the last post your wpa-supplicant has Dlink. Everything needs to be exact in character upper and lower case.

If the router is DLink then every place needs to be set as DLink as in ifcfg-wlan0, wpa_supplicant.conf and also in the generation of the psk key.

Brian

Last edited by Brian1; 03-16-2008 at 02:56 PM.
 
Old 03-16-2008, 02:45 PM   #11
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Read post #10 in case you miss it. Then come to post #11.

Now lets start clean.
Edit both ifcfg-eth0 and ifcfg-wlan0 and put both as ONBOOT=no
Edit rc.local and rem out the wpa_supplicant command with a # in front of it.
Generate a psk key from the routers key plus correct ESSID in correct case.
Place what it generated in the wpa_supplicant.conf file.
Add the line proto=RSN for wpa2 mode like I show.
Save and exit
Reboot machine
It starts up with no networking coming up except for lo interface which does not matter.

Once the system is back up run the following commands as root. Post output of each command.
[code]
/sbin/ifdown eth0
/sbin/ifdown wlan0
/sbin/modprobe ndiswrapper
/sbin/ifup wlan0
/usr/sbin/wpa_supplicant -dd -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

Now you need to open another terminal session and run these commands and post output. Wait to see if wpa_supplicant connects.
/sbin/iwconfig
/sbin/ifconfig wlan0
/sbin/iwlist wlan0 scan
 
Old 03-16-2008, 07:32 PM   #12
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the walkthrough Brian... Gosh, I feel a little idiotic with the password generator mixup... Anyways, things are looking better after making the changes; was REAL nice to see the link light lit after initializing it.

Anyways just wanted to fill you in on this, probably no needed... I tried to boot will correct settings (wlan-0 ON) and got error on boot:
FAILED: Bringing up loopback: does not seem to be present, delaying initialization.


Turned everything off as per your request; no failure at boot, but did think this was interesting...
[root@localhost mythtv]# /sbin/ifdown eth0
[root@localhost mythtv]# /sbin/ifdown wlan0
[root@localhost mythtv]# /sbin/modprobe ndiswrapper
[root@localhost mythtv]# /sbin/ifup wlan0
does not seem to be present, delaying initialization.
[root@localhost mythtv]# /usr/sbinn/wpa_supplicant -dd -Dwext
-iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
wpa_supplicant v0.4.9
Copyright (c) 2003-2006, Jouni Mal...


The Wireless card came online and link light flickers. The router is showing the "Wireless Client". MAC Address is listed but no IP Address: 0.0.0.0. So of course, there is no internet nor can I WinSCP into the box. Had to enable the eth0 to pass the following output information...



[root@localhost mythtv]# /sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"DLink"
Mode:Managed Frequency:2.412 GHz Access Point:
00:1C:F0:69:B4:22
Bit Rate=130 Mb/s Sensitivity=-200 dBm
RTS thr=2346 B Fragment thr=2346 B
Encryption key:1850-C69A-F80D-BF30-20D9-3EB3-B63B-9CFA
Security mode:restricted
Power Managementff
Link Quality:95/100 Signal level:-35 dBm Noise
level:-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



[root@localhost mythtv]# /sbin/ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:1C:10:E8:EC:5F
inet6 addr: fe80::21c:10ff:fee8:ec5f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4356 (4.2 KiB) TX bytes:648 (648.0 b)



[root@localhost mythtv]# /sbin/iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:1C:F0:69:B4:22
ESSID:"DLink"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:93/100 Signal level:-36 dBm Noise
level:-96 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6
Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s;
36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:18:F8:C7:BE:B2
ESSID:"home2007"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:7/100 Signal level:-91 dBm Noise
level:-96 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s;
18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9
Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 03 - Address: 00:03:93:E8:9B:94
ESSID:"Air Dragon"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.457 GHz (Channel 10)
Quality:39/100 Signal level:-71 dBm Noise
level:-96 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6
Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s;
36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 04 - Address: 00:18:39:41:78:C8
ESSID:"linksys"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:4/100 Signal level:-93 dBm Noise
level:-96 dBm
Encryption keyff
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s;
18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9
Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 05 - Address: 00:14:BF:83:F5:26
ESSID:"linksys"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:6/100 Signal level:-92 dBm Noise
level:-96 dBm
Encryption keyff
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s;
18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9
Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 06 - Address: 00:0C:41:C3:9DB
ESSID:"wireless"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:3/100 Signal level:-94 dBm Noise
level:-96 dBm
Encryption keyff
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Extra:bcn_int=100
Extra:atim=0
 
Old 03-16-2008, 08:12 PM   #13
cjtinant
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
I updated the Router and assigned the IP Address (192.168.1.103) via hardware address. Now the Wireless Adapter SHOWS the correct IP address (Wireless Status on Router), but still no internet or WinSCP connection.

Getting errors on the Router:

Wireless Statistics
Sent : 126
TX Packets Dropped : 0
Received : 2
RX Packets Dropped : 0
Errors : 29

Last edited by cjtinant; 03-16-2008 at 08:27 PM.
 
Old 03-17-2008, 04:51 PM   #14
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Can you ping the routers IP?
If you set static IP then you need to define the ISP DNS IP in /etc/resolv.conf if you can ping.

have you tried turning off the routers security for a bit and tried connecting with no security?

Brian

Last edited by Brian1; 03-17-2008 at 04:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WG111v2 Netgear wireless usb network adapter and ndiswrapper issues on Arch w/ xfce4 Cy1989 Linux - Wireless Networking 1 07-25-2007 08:57 AM
Broadcom Wireless (BCM4306) Wireless problems: modprobe ndiswrapper freezes HP Laptop shthap3ns Linux - Hardware 11 02-11-2007 12:53 PM
configuring Atheros AR5001X+ Wireless Network Adapter asilentmurmur Suse/Novell 0 03-04-2005 12:18 AM
Accessing schools wireless network & configuring ndiswrapper niteshadw Linux - Wireless Networking 8 10-03-2004 08:15 AM
modprobe error while configuring ndiswrapper jaime1978 Linux - Laptop and Netbook 3 06-16-2004 03:31 AM


All times are GMT -5. The time now is 03:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration