LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-12-2007, 05:42 AM   #1
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Rep: Reputation: 15
My Linux box does not shutdown i do when i do /sbin/shutdown -h now


hi guys,

i tend to be having a little probelm with my new Pentuim D. When ever i shutdown with this command (shutdown -h now), my system does not shutdown as in i mean power off. Any idea why?

Thanks
 
Old 09-12-2007, 05:50 AM   #2
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Quote:
Originally Posted by yawe_frek View Post
hi guys,

i tend to be having a little probelm with my new Pentuim D. When ever i shutdown with this command (shutdown -h now), my system does not shutdown as in i mean power off. Any idea why?

Thanks
$su -

#poweroff
 
Old 09-12-2007, 05:57 AM   #3
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Original Poster
Rep: Reputation: 15
hi,

su - what is this suppose to do. i am already root.


Thanks
 
Old 09-12-2007, 08:53 AM   #4
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Shell command

Quote:
Originally Posted by yawe_frek View Post
hi,

su - what is this suppose to do. i am already root.


Thanks
-, -l, --login
make the shell a login shell

As long as you're already root, "poweroff" command shall do the trick

Cheers
 
Old 09-12-2007, 10:46 AM   #5
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Original Poster
Rep: Reputation: 15
thanks SlackerLX,

i will try poweroff and get back.

Thanks
 
Old 09-14-2007, 06:13 AM   #6
tzp
LQ Newbie
 
Registered: Apr 2005
Location: Hungary
Distribution: Suse, Debian
Posts: 6

Rep: Reputation: 0
Lightbulb try with APM

I had the same problem.
I used an own compiled SMP kernel (it's a dual core machine) with APM and ACPI support.
When looking at the startup log (run dmesg) I could see that when ACPI is started, it disables APM. Further on APM poweroff is disabled for multicore CPU-s anyhow, as it is considered not SMP-safe. (I don't know why.)

The solution was that I disabled ACPI and enabled APM power off even for SMP. I think the kernel boot parameters for that were acpi=off apm=smp.

But then shutdown -h worked

I used the 2.6.20 kernel.

The list of kernel parameters can be found in the file Documentation/kernel-parameters.txt. Search for acpi and apm. The latter will redirect you to arch/i386/kernel/apm.c where you can see this:
Code:
/*
 * See Documentation/Config.help for the configuration options.
 *
 * Various options can be changed at boot time as follows:
 * (We allow underscores for compatibility with the modules code)
 *	apm=on/off			enable/disable APM
 *	    [no-]allow[-_]ints		allow interrupts during BIOS calls
 *	    [no-]broken[-_]psr		BIOS has a broken GetPowerStatus call
 *	    [no-]realmode[-_]power[-_]off	switch to real mode before
 *	    					powering off
 *	    [no-]debug			log some debugging messages
 *	    [no-]power[-_]off		power off on shutdown
 *	    [no-]smp			Use apm even on an SMP box
 *	    bounce[-_]interval=<n>	number of ticks to ignore suspend
 *	    				bounces
 *          idle[-_]threshold=<n>       System idle percentage above which to
 *                                      make APM BIOS idle calls. Set it to
 *                                      100 to disable.
 *          idle[-_]period=<n>          Period (in 1/100s of a second) over
 *                                      which the idle percentage is
 *                                      calculated.
 */
PS. I'm pretty sure that you can find a more sophisticated solution than disabling the whole ACPI.
 
Old 09-14-2007, 08:48 AM   #7
fusilier
LQ Newbie
 
Registered: Jun 2003
Posts: 6

Rep: Reputation: 0
Try passing the "-p" option to the shutdown command. That (if supported) will power off the system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Shutdown of Windows using a linux box? bigdog0007 Linux - Networking 7 05-12-2005 11:07 AM
Linux full shutdown vs. manual shutdown? LQtoto Linux - General 9 01-26-2005 07:21 PM
/sbin/shutdown german Linux - Software 2 09-03-2004 02:30 PM
/sbin/shutdown BaerRS Linux - General 3 07-17-2003 03:09 PM
KDE: anybody can shutdown my box!!! How to prevent this? vous Linux - Software 5 05-25-2003 05:07 AM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration