Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 11-02-2004, 03:21 PM   #1
Crazy Joe Davol
LQ Newbie
Registered: Aug 2004
Posts: 19

Rep: Reputation: 0
Multiple LUN Issue

My question is how can I enable multi-lun support that is persistent upon reboot?

I am running RedHat 9 with Multi-LUN Support. By default, the kernel will only scan for LUN0 of the first 18 Target ID's (at least its 18 I think). Anyway, I have a RAID controller with 4 LUN's (0-3). The only way I can get Linux to see all 4 LUN's is to add the other 3 LUN's (LUN's 1-3) manually by
echo "scsi add-single-device A B C D" > /proc/scsi/scsi where;

The problem is that after a system reboot, I need to manually add the above LUN's all over again. Is anyone aware of a way to make the changes persistent so that I do not have to do this after every boot?
Old 11-03-2004, 01:08 AM   #2
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
add the command you have to put in to /etc/rc.d/rc.local
then it will be run automatically as the last thing before login.
Old 11-03-2004, 11:16 AM   #3
Crazy Joe Davol
LQ Newbie
Registered: Aug 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks for the reply.

You have no idea how much of a major nuisance this minor issue has been.

I'll will try this and let you know if I have any more questions.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple VLAN issue with Atheros Wireless steve_f60 Linux - Wireless Networking 0 11-30-2005 02:50 PM
Multiple Connections... Routing issue? Suse 9.1 exabrial Linux - Networking 0 07-15-2004 05:10 PM
SuSe 9.0 and multiple network adapters(possible routing issue) exabrial Linux - Networking 3 03-21-2004 05:18 PM
Routing issue with multiple ppp connections eejut Linux - Networking 5 12-02-2003 09:09 PM
Multiple LUN support & need scsi inquiry command... mvega Linux - Newbie 2 09-23-2003 05:48 PM

All times are GMT -5. The time now is 03:13 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration